QuickConnect Network error

Discussion room for the QuickConnect service, which frees you from router setup and port-forwarding, while providing access to all the management and application services on DSM.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
Rense
I'm New!
I'm New!
Posts: 7
Joined: Mon Jan 14, 2013 9:37 am

QuickConnect Network error

Unread post by Rense » Mon Jan 14, 2013 9:43 am

I'm trying to set up CloudStation without port forwarding using QuickConnect. However, whenever QuickConnect tries to register for an ID, I get the error "Network error occurred. Check your DNS and network settings". This is not a very helpful error message. My network settings seem to be fine, as I can for example download packages without problems. Can anybody give some advice on which settings I should check, and what the correct settings might be? Thanks!

humbfig
Versed
Versed
Posts: 289
Joined: Fri Nov 25, 2011 10:48 pm

Re: QuickConnect Network error

Unread post by humbfig » Mon Jan 14, 2013 11:19 am

Rense wrote:I'm trying to set up CloudStation without port forwarding using QuickConnect. However, whenever QuickConnect tries to register for an ID, I get the error "Network error occurred. Check your DNS and network settings". This is not a very helpful error message. My network settings seem to be fine, as I can for example download packages without problems. Can anybody give some advice on which settings I should check, and what the correct settings might be? Thanks!
I'm thinking DNS.......
If you SSH to your DS and ping some site, can it resolv the site name?

Rense
I'm New!
I'm New!
Posts: 7
Joined: Mon Jan 14, 2013 9:37 am

Re: QuickConnect Network error

Unread post by Rense » Mon Jan 14, 2013 11:43 am

Thanks for your reply. Well, I was trying to set up things without port forwarding, so I also don't have an open port for ssh at the moment, so I can't ssh to my DS. Or isn't that what you mean?

humbfig
Versed
Versed
Posts: 289
Joined: Fri Nov 25, 2011 10:48 pm

Re: QuickConnect Network error

Unread post by humbfig » Mon Jan 14, 2013 5:18 pm

Rense wrote:Thanks for your reply. Well, I was trying to set up things without port forwarding, so I also don't have an open port for ssh at the moment, so I can't ssh to my DS. Or isn't that what you mean?
yep, that's what I meant.
You should open something..... I mean, if you're worried about security/privacy then you shouldn't use Synology servers for CloudStation anyway......
A nice thing to run at your homeplace without opening ports would be a VPN Server equipped router......

Rense
I'm New!
I'm New!
Posts: 7
Joined: Mon Jan 14, 2013 9:37 am

Re: QuickConnect Network error

Unread post by Rense » Mon Jan 14, 2013 7:14 pm

Sure, that would be my preferred setup, but I'm having trouble with opening some ports on my router, so in the meantime I thought I could a least use CloudStation with QuickConnect. But then I ran into the problem mentioned in my first post. Hence the question.

Rense
I'm New!
I'm New!
Posts: 7
Joined: Mon Jan 14, 2013 9:37 am

Re: QuickConnect Network error

Unread post by Rense » Mon Jan 14, 2013 9:11 pm

humbfig wrote: I'm thinking DNS.......
If you SSH to your DS and ping some site, can it resolv the site name?
OK, so now that I'm at home I could locally ssh into my NAS and ping http://www.synology.com. Works without problems. (I also tried ssh-ing into <myds>.synology.me, but that times out, even though http://www.yougetsignal.com reports that port 22 is open. But maybe that's another problem.)

Rense
I'm New!
I'm New!
Posts: 7
Joined: Mon Jan 14, 2013 9:37 am

Re: QuickConnect Network error

Unread post by Rense » Wed Jan 16, 2013 11:19 am

Hm, any ideas, anybody? I'm still not able to connect with QuickConnect. Any Synology staff listening in?

humbfig
Versed
Versed
Posts: 289
Joined: Fri Nov 25, 2011 10:48 pm

Re: QuickConnect Network error

Unread post by humbfig » Wed Jan 16, 2013 12:54 pm

Rense wrote:Hm, any ideas, anybody? I'm still not able to connect with QuickConnect. Any Synology staff listening in?
Is your address <myds>.synology.me> being updated? If you ping it (not from your home since your router might not deal with loopbacks) do you get your home IP address? In the DS's DDNS page is this external IP being correctly displayed? Is your DS firewall OFF? Is your router allowing all outgoing connections?
I don't know what is happening. Maybe you should try to solve your router problems first. Why are you having trouble opening ports?

Rense
I'm New!
I'm New!
Posts: 7
Joined: Mon Jan 14, 2013 9:37 am

Re: QuickConnect Network error

Unread post by Rense » Wed Jan 16, 2013 1:35 pm

Thank you! The magic word was "firewall". Apparently, CloudStation is not in the DSM firewall's allow list by default, but if you add it, I can finally connect through the open port 6690. Funny that this isn't mentioned anywhere in the documentation.

HOWEVER: this is no excuse for QuickConnect not working. With port fowarding I can't connect to CloudStation from my own network using my hostname; I have to connect to the internal IP. I guess this is because my router doesn't support loopback (it's a Huawei HG655d). This is going to be very inconvenient with a laptop that I carry around. So I would still like to use QuickConnect.

Going through the rest of your list:
- if I ping <myds>.synology.me> (through my office's VPN connection so it's "outside"), I get my external IP back, although the ping times out.
- in the DDNS page, my external IP is correctly displayed
- no, the DNS firewall is not off because my NAS in in the router's DMZ. I don't see an option for specifically allowing QuickConnect.
- is my router allowing all outgoing connections? I don't know. How would I find out?

Can this be a problem with the Synology servers? I heard there were problems before. Are other people able to connect?

humbfig
Versed
Versed
Posts: 289
Joined: Fri Nov 25, 2011 10:48 pm

Re: QuickConnect Network error

Unread post by humbfig » Wed Jan 16, 2013 3:13 pm

Rense wrote:- no, the DNS firewall is not off because my NAS in in the router's DMZ. I don't see an option for specifically allowing QuickConnect.
Control Panel->Firewall->Traffic Control->Create->Select from a list of built-in Applications->Cloud Station at 6690
Rense wrote: - is my router allowing all outgoing connections? I don't know. How would I find out?
It is.
Rense wrote: Can this be a problem with the Synology servers? I heard there were problems before. Are other people able to connect?
I'm connected. No problem.

Jeko
I'm New!
I'm New!
Posts: 1
Joined: Fri Feb 08, 2013 2:28 pm

Re: QuickConnect Network error

Unread post by Jeko » Fri Feb 08, 2013 3:00 pm

I am experiancing the same problem (I think). I cannot connet to the CloudStation on my DS at home from my work (PC win7) using QuickConnect.
Trying to configure CloudStation:"Cannot connect to the QuickConnect Server, check your network settings"
But when I use my iPad in the same WIFi network I can connect to my DS at home. So the network should not be the problem, I think.

Can anyone tell me a simple way te resolve this problem? (I'm just a beginner)

ChefChaudart
Beginner
Beginner
Posts: 29
Joined: Wed Jul 11, 2007 5:22 pm

Re: QuickConnect Network error

Unread post by ChefChaudart » Tue Mar 11, 2014 12:03 pm

Hi,

Have you created a rule in your Router that redirect port 6690 to ip address of your NAS ?

Cheers

Octopussy
I'm New!
I'm New!
Posts: 1
Joined: Sat Jun 21, 2014 12:09 pm

Re: QuickConnect Network error

Unread post by Octopussy » Sat Jun 21, 2014 12:27 pm

Hi everybody,
After fighting too with this problem for more than a year on a DS209 with DSM 4.2-3248, I managed to find a simple solution. Automatic port forwaring via EZ-Internet on my Linksys router was correctly configured.

As Quickconnect gave me an error that there was no network connection and that I should check the DNS-settings, I changed these in DSM.
--> Control Panel\Network\General
--> Check "Manually configure DNS-server"
--> Preferred DNS-Server = 8.8.8.8 <-- Google DNS-server
--> Alternative DNS-Server = 8.8.4.4 <-- Google DNS-server

These settings overruled the default DNS-servers of my internet provider.

After applying these changes the Quickconnect status changed to "Connected" and I can sync files between different computers without a problem.

I do not know whether this trick will help everybody, but trying it harms nobody.

bobfelicci
I'm New!
I'm New!
Posts: 6
Joined: Wed Mar 25, 2015 2:36 am

Re: QuickConnect Network error

Unread post by bobfelicci » Sun May 31, 2015 1:56 am

[quote="Octopussy"]Hi everybody,

--> Control Panel\Network\General
--> Check "Manually configure DNS-server"
--> Preferred DNS-Server = 8.8.8.8 <-- Google DNS-server
--> Alternative DNS-Server = 8.8.4.4 <-- Google DNS-server


DEAR OCTOPUSSY !!!!!!!!! you have save me from setting my synology on fire or running my truck over it. I used this setting and worked great. After 2 weeks trying to figure this out, I can access my synology via web. THANKS !!!!!!!!!!!! :D

psolovyov
Trainee
Trainee
Posts: 16
Joined: Mon Mar 11, 2013 7:20 pm

Re: QuickConnect Network error

Unread post by psolovyov » Wed Jun 03, 2015 9:36 pm

Try checking Server Time:

Regional Options -> Time Setting

mine was reset to year 2001 and I guess there is some kind of check between Synology Servers and NAS that blocks the connection of computers with old server date.

Locked

Return to “QuickConnect”