Cloud Station issues and update process infuriating

Discussion room for Synology Cloud Station package
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
Posts: 39
Joined: Sun May 20, 2012 12:46 pm

Cloud Station issues and update process infuriating

Postby swsquish » Fri Jul 13, 2012 9:59 pm

I just updated the software for Cloud Station on both the Synology and my Windows 7 machine. After doing this I was irritated to find that my sync folder needed to be setup again. This wouldn't be a major issue if the software didn't ask for the folder to be empty... AGAIN!!!??

When I originally setup Cloud Station, which is turning out to be one of THE WORST sync software experiences I have EVER HAD! Compared to Dropbox or SugarSync.
1. Cloud Station is a memory hog that slows down my quad core system with 4GB of RAM, ridiculous! Dropbox and SugarSync barely make a dent.
2. Not to mention the lack of folder selection like SugarSync has, which I have been posting as a suggestion with the hopes that someone in Synology is listening.
3. And the issues with random double file creation with one file looking like, OFFI~1.pdf, so many of these odd duplicates being made.
4. and the fact that if anything is deleted when cloud station is not running (like when I have to stop it because my system slowed to crawl from excess memory usage) as soon as it is running again it restores everything that was deleted without asking if that's what the user wants!!!?
5. Oh and can someone please explain to me why there is a 1GB file size limit? It's my DS with more than enough storage space and my home LAN with more than enough bandwidth, SO WHY IS THERE A LIMIT???!!!! :evil:

But I digress, the main issue was what happened after updating. Why does it need the folder to be empty? I had setup My Documents folder to be the cloud station folder, so that all my Documents would be backed up to my DS. To do that I had to move all the files out of the My Documents folder to a temp folder, which wasn't easy because of some shell folder associations which required a reboot, then I setup that now empty folder as the cloud station folder and then copy/paste everything back into the My Docs folder. Then allowed the sync to the DS to occur, which with all my files took HOURS! So to have to do that again, just because I updated the friggin software is infuriating.

6. Why does that folder have to be empty?
7. Why can't we select whatever folder for syncing, empty or not? (refer back to issue # 2)
8. and why didn't the folder association remain even through the software update?

I would like some answers from Synology devs to see that they are actually listening to their users!
I'm New!
I'm New!
Posts: 1
Joined: Sat Jul 14, 2012 4:31 am

Re: Cloud Station issues and update process infuriating

Postby zacman223 » Sat Jul 14, 2012 4:42 am

I have had the exact same issues:

1. Massive system resources on pc start-up
2. Problems with the update process and losing the sync folder
3. Duplicate files with the _HOME_date added to the file name
4. The latest update will not even complete installation

Cloud station does not seem like it is anywhere near beta.
I'm New!
I'm New!
Posts: 6
Joined: Thu Oct 21, 2010 11:13 pm

Re: Cloud Station issues and update process infuriating

Postby robertm » Sat Jul 14, 2012 10:05 am


Regarding to the memory use, may be there is something wrong on your system. On my Win 7 64bit: Dropbox memory use 41.176K and Synology Cloud 9.316K. That's less than a fourth.

Do not forget cloud station is still beta.

I'm New!
I'm New!
Posts: 1
Joined: Sat Jul 14, 2012 11:21 am

Re: Cloud Station issues and update process infuriating

Postby japs38 » Sat Jul 14, 2012 11:36 am

Forgive for my English. :oops:
A nightmare. Synchronize the files you want. I have a pdf manual and not up or the iphone and iPad .
The meaningless doubles. Actually I find it incredible that they get an update without testing
I've done testing of all forms, with Windows, MAC and does not work.
How hard is acer a CloudStation apps only.
Posts: 16
Joined: Thu Mar 17, 2011 3:45 pm

Re: Cloud Station issues and update process infuriating

Postby goodrick » Mon Jul 16, 2012 9:24 pm

I was struggling with the invalid quick connect ID, as well as a network connection error. I am using DSM 4.0-2228. While fooling around with my firewall, I got the client to install/work on a VM. When I was buttoning my firewall back down (after trying numerous configurations), I somehow made it so I couldn't install other clients, but the client I had initially installed, continued to work without issue.

I removed and installed the Cloud Station package again. No joy.
I removed my custom Quick Connect ID. No joy.
I disabled the Quick Connect service and used my domain name. No joy.
Verified 6690 was still open on my firewall.
Verified 6690 was still open on the NAS' firewall.
Verified the user was still enabled for the service.
Tried the Cloud Station service on my other NAS. No joy.

Once again, on my firewall (an Astaro/Sophos UTM Home Edition) I went through the cycle of trying NAT vs firewall rule vs web application security.

The service on the initial client worked with any of these configs. But I couldn't get another client to get past when the installer tried to connect (invalid quick connect ID or network connection error). I also noticed that in the NAS, the quick connect would initially connect, then after a few moments, it would report a network error.

Finally, I remembered that while I was getting the first client to install, I had a special firewall rule temporarily enabled for my bittorrent client. When my torrent finished, I closed it.

The firewall rule is basically this:
Source: Firewall LAN port
Service: Any
Destination: Any (network)

I found that when I open this rule, and have 6690 forwarded to my NAS, I can install the client just fine. Because I don't want to keep this rule open, I disable the rule after setting up a client (but leave 6690 forwarded). And the client works great after that (I am using ddns & my domain name to connect, not quick connect).

I'll let you figure out what that means, relative to the client's initial connection during the install. While I don't know how to replicate this rule on a "box" wireless router, I'd speculate that if you temporarily put your NAS in the demilitarized zone when you are installing a client, then moved it back once the client was set up, you might get past this issue.

I hope that helps. If it does, please confirm so that other might know to try it.
Posts: 39
Joined: Sun May 20, 2012 12:46 pm

Re: Cloud Station issues and update process infuriating

Postby swsquish » Fri Jul 20, 2012 1:46 pm

Still no response from a developer, What the hell?

I am using Windows 7 32-bit, so not as effective on memory management as the 64-bit. But if other sync software can be written to run well on either 32-bit or 64-bit, like SugarSync which I have on my 64 bit laptop and my 32 bit desktop, then so can Cloud Station.

I wish these devs would just backward engineer SugarSync and use that code to rewrite Cloud Station. :wink:

Return to “Cloud Station”

Who is online

Users browsing this forum: No registered users and 2 guests