PhpMyAdmin: Missing extension mysqli

Discuss the phpMyAdmin Package Here.
Forum rules
Synology Community is the new platform for the enthusiasts' interaction, and it will soon be available to replace the Forum.
duf42
I'm New!
I'm New!
Posts: 4
Joined: Thu May 03, 2012 9:46 pm

PhpMyAdmin: Missing extension mysqli

Unread post by duf42 » Thu May 03, 2012 9:57 pm

Hello,

I have a Synology DS210 with DSM 3.2 and I have a small problem.

Few days ago, I have activate Web Station, installed phpmyadmin via package center and install a tool (Feng Office) in a virtual host named "test".

All work well but I decided to relaunch process in another virtual host of my Web Station, so I just create another host with another name and I install again Feng Office.

Now when I try to connect to phpmyadmin, I have an error: "Missing extension mysqli".

I tried to reinstall phpmyadmin, desactivate and reactivate Web Station, reboot several times but result is always the same...

Have you an idea about the way to correct this?

Thanks,
Duf

crhiles
Rookie
Rookie
Posts: 30
Joined: Thu Mar 08, 2012 1:54 am
Location: Canada
Contact:

Re: PhpMyAdmin: Missing extension mysqli

Unread post by crhiles » Fri May 04, 2012 6:35 am

The mysqli php extension may not be loaded. On the diskstation, open control panel and go to web services. Go to the php Settings tab and click on the select php extension button. In the window that pops up confirm that the mysqli has a check mark next to it.
DS211 | 4.3-3827 Update 3 | 1xST31000528AS 1xWD10EZEX

duf42
I'm New!
I'm New!
Posts: 4
Joined: Thu May 03, 2012 9:46 pm

Re: PhpMyAdmin: Missing extension mysqli

Unread post by duf42 » Fri May 04, 2012 10:58 am

Thanks for your answer.

I have already check this option, mysgli has a check mark, I also have tried to uncheck and re-check, without any effect.

Is there a way to manually start php extension as mysqli?

User avatar
axj
Specialist
Specialist
Posts: 1059
Joined: Fri Jan 02, 2009 10:59 am
Location: Esbjerg, Danmark

Re: PhpMyAdmin: Missing extension mysqli

Unread post by axj » Fri May 04, 2012 2:43 pm

Reboot the DS!
DS509+ 4*1TB Raid+1TB DSM 4.0-2219. Logitech BOOM+Duet 7.6.1, WebCam: Linksys WVC54GCA + TrendNet TV-IP121
DS212+ 1TB & D-Link DIR-685, HP C7280, Dell 3100cn. iPad3, Programming Pascal, Clarion 5.5, html/php. http://axj.dk

crhiles
Rookie
Rookie
Posts: 30
Joined: Thu Mar 08, 2012 1:54 am
Location: Canada
Contact:

Re: PhpMyAdmin: Missing extension mysqli

Unread post by crhiles » Fri May 04, 2012 4:19 pm

Put

Code: Select all

<?php phpInfo(); ?>
in a file and call it something like test.php. Upload it to your web accessible directory and try to access it in the browser. This will show you what php extensions are loaded.
DS211 | 4.3-3827 Update 3 | 1xST31000528AS 1xWD10EZEX

User avatar
axj
Specialist
Specialist
Posts: 1059
Joined: Fri Jan 02, 2009 10:59 am
Location: Esbjerg, Danmark

Re: PhpMyAdmin: Missing extension mysqli

Unread post by axj » Fri May 04, 2012 5:38 pm

Or you can go to the administration-page of your DS210
Image
and somewhere on this page you will find something called PHPInfo
and here the system will show you everything about PHP!
DS509+ 4*1TB Raid+1TB DSM 4.0-2219. Logitech BOOM+Duet 7.6.1, WebCam: Linksys WVC54GCA + TrendNet TV-IP121
DS212+ 1TB & D-Link DIR-685, HP C7280, Dell 3100cn. iPad3, Programming Pascal, Clarion 5.5, html/php. http://axj.dk

duf42
I'm New!
I'm New!
Posts: 4
Joined: Thu May 03, 2012 9:46 pm

Re: PhpMyAdmin: Missing extension mysqli

Unread post by duf42 » Fri May 04, 2012 6:07 pm

Thanks again for your answers.

I have restarted my DS: same problem.

I add file with phpinfo and mysqli extension seems to be not loaded.

I also have to correct a mistake, my DS is a DS211j not a DS210.

User avatar
axj
Specialist
Specialist
Posts: 1059
Joined: Fri Jan 02, 2009 10:59 am
Location: Esbjerg, Danmark

Re: PhpMyAdmin: Missing extension mysqli

Unread post by axj » Sat May 05, 2012 12:03 am

Look at the help for reset of the DS! You can find how to reset and re-install the DSM without loosing your data. After re-installation check the php-option and restart again!
DS509+ 4*1TB Raid+1TB DSM 4.0-2219. Logitech BOOM+Duet 7.6.1, WebCam: Linksys WVC54GCA + TrendNet TV-IP121
DS212+ 1TB & D-Link DIR-685, HP C7280, Dell 3100cn. iPad3, Programming Pascal, Clarion 5.5, html/php. http://axj.dk

duf42
I'm New!
I'm New!
Posts: 4
Joined: Thu May 03, 2012 9:46 pm

Re: PhpMyAdmin: Missing extension mysqli

Unread post by duf42 » Sun May 06, 2012 1:59 pm

I have resolved the problem by reseting my DS.

Thank you all for your help,
Duf

zsfritz
I'm New!
I'm New!
Posts: 2
Joined: Fri Oct 19, 2012 7:35 pm

Re: PhpMyAdmin: Missing extension mysqli

Unread post by zsfritz » Fri Oct 19, 2012 7:44 pm

axj wrote:Look at the help for reset of the DS! You can find how to reset and re-install the DSM without loosing your data. After re-installation check the php-option and restart again!
Hi! I've the same problem with a DS412+.

I've iSCSI drive set up - so I'm afraid that I'll loose my data if I reset the NAS - because it's settings is important. :?

What do you think?

Is there any way to fix this problem via SSH?

User avatar
axj
Specialist
Specialist
Posts: 1059
Joined: Fri Jan 02, 2009 10:59 am
Location: Esbjerg, Danmark

Re: PhpMyAdmin: Missing extension mysqli

Unread post by axj » Fri Oct 19, 2012 9:38 pm

Not without a reset!
All Synology´s DS´s has 2 level of reset and I have never seen,
that any data has been erased using the first level of reset!!
(and I have used reset some times)
DS509+ 4*1TB Raid+1TB DSM 4.0-2219. Logitech BOOM+Duet 7.6.1, WebCam: Linksys WVC54GCA + TrendNet TV-IP121
DS212+ 1TB & D-Link DIR-685, HP C7280, Dell 3100cn. iPad3, Programming Pascal, Clarion 5.5, html/php. http://axj.dk

SKORPIOS
I'm New!
I'm New!
Posts: 8
Joined: Tue Oct 16, 2012 8:08 pm

The mcrypt extension is missing.

Unread post by SKORPIOS » Wed Mar 06, 2013 6:14 pm

The mcrypt extension is missing. Please check your PHP configuration.

I have gone through the forums here and elsewhere trying to resolve this but with the options I have seen I am still stuck with this message.

PhpMyAdmin is functioning but obviously I would like to find a fix for this error.

This is running the latest version through DSM 4.2

I have a DS212J NAS so the options to change through web services are not available to me.

Thanks

User avatar
HarryPotter
Honorary Moderator
Honorary Moderator
Posts: 19632
Joined: Mon Oct 23, 2006 12:48 pm
Location: Switzerland

Re: The mcrypt extension is missing.

Unread post by HarryPotter » Thu Mar 07, 2013 10:31 am

DSM - Control Panel - Web Services - PHP settings - Select PHP extension
*Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!*

DS718+ / DSM 6.2-23511 / ST4000VN000-2AH166 / SA400S37120G SSD cache /16 GB RAM
DS415+ / DSM 6.2-23511

LMS 7.9.1-166, 2 Squeezebox 3 + Boom

APC Smart UPS SUA750i

User avatar
Goner
Seasoned
Seasoned
Posts: 590
Joined: Tue Mar 06, 2012 2:27 pm
Location: Rotterdam, Netherlands

mysqli extension missing ?

Unread post by Goner » Mon Mar 11, 2013 11:41 pm

Just enabled MySQL and installed phpMyAdmin.

On starting phpMyAdmin it warns about several security settings, so I set a password on root and enabled the 'mcrypt' extension in php.
Now phpMyAdmin won't even start, it complains about a missing mysqli extension, but that extension is flagged in the PHP extension list ?!

just had a look with
<?php
phpinfo();
?>
and mysqli is enabled
but still phpMyAdmin will not run

NAS : DS212j with 2 ST2000DL003 in SHR / DSM 5.2-5644 Update 5
LAN : Fritz!Box 7170, 5 Devolo 200/500Mbps homeplugs, 2 5-port switches, Maxxter ACT-WNP-RP-002
HW : Raspberry Pi 2B & 3B, Conceptronic CHD3NET, ACRyan Playon!HD, Eminent EM7075dts, Wii, Wii U, PS2, D-Link DCS-930L
OS : Linux Mint 16 Cinnamon

User avatar
Goner
Seasoned
Seasoned
Posts: 590
Joined: Tue Mar 06, 2012 2:27 pm
Location: Rotterdam, Netherlands

Re: PhpMyAdmin: Missing extension mysqli

Unread post by Goner » Mon Mar 11, 2013 11:56 pm

duf42 wrote:I have resolved the problem by reseting my DS.
Exactly what kind of reset ?
Don't tell me I have to re-install DSM for one lousy php extension ?!

EDIT: after stopping/starting MySQL and phpMyAdmin the error disappeared :?

NAS : DS212j with 2 ST2000DL003 in SHR / DSM 5.2-5644 Update 5
LAN : Fritz!Box 7170, 5 Devolo 200/500Mbps homeplugs, 2 5-port switches, Maxxter ACT-WNP-RP-002
HW : Raspberry Pi 2B & 3B, Conceptronic CHD3NET, ACRyan Playon!HD, Eminent EM7075dts, Wii, Wii U, PS2, D-Link DCS-930L
OS : Linux Mint 16 Cinnamon

Post Reply

Return to “phpMyAdmin”