RT1900ac - 3G/4G dongle

Discussion about the hardware compatibility of the Synology router.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
I'm New!
I'm New!
Posts: 1
Joined: Mon Sep 17, 2018 8:21 am

RT1900ac - 3G/4G dongle

Unread post by Erath » Mon Sep 24, 2018 5:14 pm


I'm trying to get my RT1900ac Router working via 3G/4G dongle.
I'm running the the Version:
SRM 1.1.7-6941

I have tried 4 diffrent Models but i run into the same issue. (I checked with the compartible Liste on the Synology Website)
Dongles i tried:
D-Link DWM-157 H/W Ver.: B1 F/w Ver.: 2.0.1EU
Huawei E303
Huawei E3531 Model:E3531i-2
Huawei E3372h-153

The 3 Huawei Dongels all the the say issue - i can connect the dongle (without SIM Card) and I can access the Web Interface via
If i connect it with the SIM Card the Router works for ~30 sec and the CPU goes to 100% and he stops responding at all (web gui & ssh) only a reboot fixes the issue.
With the D-Link Stick - I can see the stick in the log and under Devices but he never "connects" to the Stick - meaning under the "Status" Tab it always shows "Disconnected". - With the Huawei it shows the Stick web Gui there.

It would be great if anyone knows a Tip or can point me to a working UMTS Stick to try.

I will add picures of the dmesg.

Thanks for your help. Best regards!

User avatar
Posts: 3246
Joined: Fri Jun 03, 2011 10:51 pm

Re: RT1900ac - 3G/4G dongle

Unread post by Rusty1281 » Mon Sep 24, 2018 9:45 pm

Most Huawei sticks are in router mode. That E3372h 153 has a HiLink firmware on it that makes that stick a router.

Using that stick in your syno router will mess it up for sure and you will not be able to use it properly. You need to put that stick in a usb modem mode so that syno router is the only router on the network thats initiating the connection to the outside world and on top of that, that the stick is not messing up with your LAN as well.

The problem is that once you connect to your stick it will set itself as a gatway in a subnet 192.168.8.x and if your not in the same subnet with the rest of your devices you are essentialy locking your self out and your Syno router gets messed up as well.
Synology DS918+ (4x4TB WD RED - RAID 5 with 2x250GB 960EVO NVMe) | Synology DS412+ (4x3TB WD RED - RAID 5) | RT1900AC


Return to “Hardware Compatibility”