The big problem with searching!

Discussion room for Note Station package
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
cibulicka
I'm New!
I'm New!
Posts: 4
Joined: Wed Aug 22, 2018 7:22 pm

The big problem with searching!

Unread post by cibulicka » Wed Aug 22, 2018 7:33 pm

Search never finds a word after a dot. Never! Type the text in the note: Hello world. Globe. The word Globe will never be found. The problem is a dot! :(

Briolet
Experienced
Experienced
Posts: 145
Joined: Sun Jun 23, 2013 4:47 pm

Re: The big problem with searching!

Unread post by Briolet » Wed Aug 22, 2018 9:11 pm

Not only a dot. Any character is a problem. Text is only devided in words based on the spaces. Any other symbol becomes part of a word.

Lucy that when you do a spotlight search on a share with a mac, those extra characters are no problem as you start getting results for partially words. Universal search only looks for 100% matches with its database.

I noticed this when I got significant more hits with Spotlight than with Universal search for the same share.

telos
Specialist
Specialist
Posts: 1093
Joined: Mon Sep 23, 2013 6:12 pm

Re: The big problem with searching!

Unread post by telos » Thu Aug 23, 2018 2:45 am

I get the same search results with or without the period.

cibulicka
I'm New!
I'm New!
Posts: 4
Joined: Wed Aug 22, 2018 7:22 pm

Re: The big problem with searching!

Unread post by cibulicka » Thu Aug 23, 2018 5:09 am

This error is in the Windows version. If I use a semicolon instead of a dot, it's OK. Searching works well when I write: Hello world; Globe; The dot is a problem :)

cibulicka
I'm New!
I'm New!
Posts: 4
Joined: Wed Aug 22, 2018 7:22 pm

Re: The big problem with searching!

Unread post by cibulicka » Thu Aug 23, 2018 6:22 am

Video with search error (Czech version, Windows 10) Hledat=Search
https://youtu.be/OxZyAXcQhUk

Briolet
Experienced
Experienced
Posts: 145
Joined: Sun Jun 23, 2013 4:47 pm

Re: The big problem with searching!

Unread post by Briolet » Thu Aug 23, 2018 8:25 am

Apparently it is not every character that gives a problem, but it is more than a dot alone. Also a question mark gives the probem.

I noticed this when I searched a word with spotlight on the mac and with Universal Search. You would expect everything is indexed once and both methods would find the same files.

When I noticed that spotlight always found more files, I examined the files that Universal Search missed. It were all words with another character behind it. The 3 characters I identified were dot, questionmark and a quote. (So US also won't find quoted text). When you search for the words and add the dot, ? or quote to the search, it will find it.

I don't know if settings matter. In the general settings of US I have the first two options ticked (don't include numbers in the search and better Chineese search)

Locked

Return to “Note Station”