Repeated LAN Link Down / Link Up messages in syslog

Questions pertaining to Power settings, Auto Block, Permissions, User Quotas and Email alerts may be posted here.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
MookiMoo
Trainee
Trainee
Posts: 11
Joined: Fri Feb 24, 2017 12:58 pm

Repeated LAN Link Down / Link Up messages in syslog

Unread post by MookiMoo » Sun Aug 12, 2018 9:55 am

I have an 18 Month old RS815+ and I have been seeing lots of System errors in my syslog:-

Code: Select all

Info	System	2018/08/11 05:17:12		SYSTEM	[LAN 2] link up.
Info	System	2018/08/11 05:17:08		SYSTEM	[LAN 2] link down.
Info	System	2018/08/11 05:15:46		SYSTEM	[LAN 2] link up.
Info	System	2018/08/11 05:15:43		SYSTEM	[LAN 2] link down.
Info	System	2018/08/11 05:12:39		SYSTEM	[LAN 2] link up.
Info	System	2018/08/11 05:12:36		SYSTEM	[LAN 2] link down.
There are many more of these in fact 15 downs and 15 ups running between 05:12:36 and 18:24:55 on the 11th Aug. I see no obvious pattern to the timing, so could this be indicative of a pending failure as it is the only interface affected.

I know by tomorrow there will be more as the above is just a small sample and has been going on for a few weeks now, and IMSMC this has started after a recent DSM update. I have a DHCP server bound to this interface if that helps.

User avatar
WST16
Versed
Versed
Posts: 261
Joined: Sun Oct 02, 2016 10:03 am

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by WST16 » Sun Aug 12, 2018 6:47 pm

Hi,

Did you try doing some basic troubleshooting steps?

Change the cable.
Try a different port on the switch.
Power down the switch for a while and then up.
Power down the DS and power it up after a while.
Try a different switch altogether (even for a short while just to see).

Looking at the logs alone might not solve the problem, you’ll need to find the cause.
DS216+II : DS118 : APC Back UPS ES 700 : Mac user

MookiMoo
Trainee
Trainee
Posts: 11
Joined: Fri Feb 24, 2017 12:58 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by MookiMoo » Mon Aug 13, 2018 10:40 am

Thank you for your reply. Well to be honest no I haven't, as the unit is in a rack that no one but me has access to which is why I haven’t changed the cable as I couldn’t see how it can get damaged with not having access the rack in weeks.

Having said that I have however taken your advice and moved the Lan 2 to another port using a new cable on the (physical) switch and I’ll give that time to cook and report back.

tb123
Knowledgeable
Knowledgeable
Posts: 362
Joined: Sun Sep 03, 2017 10:55 am

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by tb123 » Mon Aug 13, 2018 10:43 am

MookiMoo wrote:
Mon Aug 13, 2018 10:40 am
Having said that I have however taken your advice and moved the Lan 2 to another port using a new cable on the (physical) switch and I’ll give that time to cook and report back.
Probably would have been better to either just shift the port, OR, change the cable.
One action at a time is easier to prove cause.
DS916+, 3 x 4TB WD Red, 1 x 4TB WD Purple
UniFi USG, 16 port PoE switch and 4 x AP’s, some Windows, Mac, Android and iDevices

turncloud
I'm New!
I'm New!
Posts: 8
Joined: Tue Jun 30, 2015 5:07 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by turncloud » Mon Aug 13, 2018 1:06 pm

We are seeing this and I'm starting to think an update has caused it. Restarting the NAS sometime cures it for several hours and sometimes just for a few minutes. Was looking at changing the switch until I saw this post.

MookiMoo
Trainee
Trainee
Posts: 11
Joined: Fri Feb 24, 2017 12:58 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by MookiMoo » Mon Aug 13, 2018 1:11 pm

turncloud, that was (and TBH remains my thinking) but I didn't say anything in the OP as I wasn't exactly sure when it started and as I don't check the logs every week (never mind day) so it only confused the issue for me. My thinking was that if anyone else was experiencing it then it may be easier to point a finger.

turncloud
I'm New!
I'm New!
Posts: 8
Joined: Tue Jun 30, 2015 5:07 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by turncloud » Mon Aug 13, 2018 1:17 pm

I have been onsite to this, this morning and tried all of the other cabel, alternative switch tests. A reboot of the switch and then the NAS brings it back for several hours. A reboot of just the NAS only gets you 5 minutes before the link drops again. We are on 6.2-23739 update 2 and there is no option to backrev.

MookiMoo
Trainee
Trainee
Posts: 11
Joined: Fri Feb 24, 2017 12:58 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by MookiMoo » Mon Aug 13, 2018 1:21 pm

Same version here : DSM 6.2-23739 Update 2

turncloud
I'm New!
I'm New!
Posts: 8
Joined: Tue Jun 30, 2015 5:07 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by turncloud » Mon Aug 13, 2018 1:32 pm

What model is yours? - Just on Support chat now

turncloud
I'm New!
I'm New!
Posts: 8
Joined: Tue Jun 30, 2015 5:07 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by turncloud » Mon Aug 13, 2018 1:57 pm

On the advice of the support Chat I have moved to LAN2 and we'll see how we go

MookiMoo
Trainee
Trainee
Posts: 11
Joined: Fri Feb 24, 2017 12:58 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by MookiMoo » Wed Aug 15, 2018 7:30 am

I have a RS815+ and last night I turned off the DHCP server bound to the LAN Interface and there are no errors in my syslog, coincidence? I think not. I have been experiencing odd issues when DHCP clients are started and the whole LAN becomes unusable for a while, the it returns to normal, so out of annoyance last night I turned off the DHCP server. I'm not a betting man but if I were I'd be putting my money on an issue with the DHCP server.

MookiMoo
Trainee
Trainee
Posts: 11
Joined: Fri Feb 24, 2017 12:58 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by MookiMoo » Wed Aug 15, 2018 2:20 pm

An update to the above. As things were grinding to a half with the DHCP server disabled I had to re-enable it, and within the hour I am now seeing the Link Down / Link Up errors appear in the syslog. These errors were not there prior to my restarting the service (as I checked), so I deduce from that the the culprit here is in fact the DHCP server.

Does anyone at Synology read these forums and maybe bring this to the attention of the development team?

telos
Specialist
Specialist
Posts: 1093
Joined: Mon Sep 23, 2013 6:12 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by telos » Wed Aug 15, 2018 5:36 pm

File a support request w/Synology.

turncloud
I'm New!
I'm New!
Posts: 8
Joined: Tue Jun 30, 2015 5:07 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by turncloud » Tue Aug 28, 2018 4:08 pm

We have just hit this problem again (Link Up / Link Down) on the replacement NAS whilst the customer's original one is with Synology for repair (we hold a hot spare). Exactly the same symptoms.

We have just disabled DHCP and moved the DHCP function to the router and the unit is starting to behave again. Will watch it now but CPU use has dropped from 99% to 34% and no more link up / link down messages yet.

turncloud
I'm New!
I'm New!
Posts: 8
Joined: Tue Jun 30, 2015 5:07 pm

Re: Repeated LAN Link Down / Link Up messages in syslog

Unread post by turncloud » Wed Aug 29, 2018 1:04 pm

Has happened again today with DHCP disabled. back to the drawing board.

Locked

Return to “System Management”