My pages point images to //nas/wordpress/image.jpg instead of //mydomain.com/wordpress/image.jpg

Discussion room for Wordpress, a weblog based social networking community.
Forum rules
Synology Community is the new platform for the enthusiasts' interaction, and it will soon be available to replace the Forum.
ameli0rate
I'm New!
I'm New!
Posts: 3
Joined: Mon Jul 17, 2017 11:11 pm

My pages point images to //nas/wordpress/image.jpg instead of //mydomain.com/wordpress/image.jpg

Unread post by ameli0rate » Sun Jul 08, 2018 2:32 pm

I've been playing with a site for a while now and never really used it for public viewing. I just found out that all images I upload point to http://nas/wordpress instead of using the actual URL.

That means that anything that doesn't know what "NAS" is (meaning, anything outside of my house) can't see any images.

I see that in the config, my WordPress Address (URL) field shows "http://nas/wordpress", and it's grayed out.

The Site Address (URL) is editable and shows the proper URL.

I suspect that is what causes Wordpress to insert media with a link to http://nas instead.

I'm loath to go in and edit the wp_config.php file willy-nilly, but I understand that my issue should be resolved if I insert these two lines in it;
define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com');

Is that correct, or should I look elsewhere for a setting to tell my Wordpress install to not use "NAS" for the name?


Also, when I get that name changed, what will I need to go to get all my posts updated to not point to http://NAS but to point to http://mydomain.com instead?

tfloyd
I'm New!
I'm New!
Posts: 6
Joined: Fri Aug 31, 2018 4:19 pm

Re: My pages point images to //nas/wordpress/image.jpg instead of //mydomain.com/wordpress/image.jpg

Unread post by tfloyd » Fri Aug 31, 2018 4:22 pm

This is exactly my problem too. Any useful info would be appreciated.

ameli0rate
I'm New!
I'm New!
Posts: 3
Joined: Mon Jul 17, 2017 11:11 pm

Re: My pages point images to //nas/wordpress/image.jpg instead of //mydomain.com/wordpress/image.jpg

Unread post by ameli0rate » Sun Sep 09, 2018 7:11 am

I ended up adding the two "define" statements. Now both my URL fields in the Wordpress settings are grayed out, but they are correct and the images now work as they should.

Post Reply

Return to “Wordpress”