DAHUA not working with SS 8.1

All questions/comments regarding the Surveillance Station using IP Cameras may be placed here
Forum rules
Synology Community is the new platform for the enthusiasts' interaction, and it will soon be available to replace the Forum.
ombrard
I'm New!
I'm New!
Posts: 5
Joined: Thu May 17, 2018 11:58 pm

DAHUA not working with SS 8.1

Unread post by ombrard » Fri May 18, 2018 12:10 am

Hello Guys,

i'm pretty new at using SS but everything with Synology is pretty straight forward. For some reason this is not the case.

I recently purchased a DAHUA IPC-HDBW4431E-AS (after researching features and compatibility with synology) to test and purchase a bunch more afterward.

So here is the problem:

I first setup the camera's IP and password and made sure everything worked. I left everything else set to default.
Then i launched SS and in the IP cameras section i tried to add the camera and this is where the problems started.

Thinking that the camera was compatible and in the list i looked for it via the network lookup and sure enough it showed up so i just selected it, added the user and password and the test worked and showed an image.

As soon as i hit OK SS tried to connect to the camera without success saying something about the RTSP config so i started checking everything from top to bottom. Forced UDP, TCP, HTTP (which btw only HTTP worked during the connection test even if i set the proper ports). Also i've updated the firmware of the camera to make sure it wasn't a version problem but that didn't work either.

After long hours of messing with the settings i managed to make it work ONLY in ONVIF mode and ONLY with the default settings. As soon as i try to change anything on the camera settings it stops working.

Obviously i picked this camera for various reasons, one bein H265 for saving bandwidth but i can't make it work for the life of me. The only thing i understand so far is that there is something seriously wrong with the camera profile inside of SS and i can't figure out what it is. Changing the connection, codec or anything else doesn't seem to work if i'm not in ONVIF mode.... and there is no H265 there.

Can anybody help me?

litris
Novice
Novice
Posts: 41
Joined: Thu Jul 17, 2014 12:37 pm

Re: DAHUA not working with SS 8.1

Unread post by litris » Fri May 18, 2018 9:23 am

The same thing happens to me if I use Onvif with authentication deactivated when the test pulse shows the image but when I give it to save it seems to me disconnected error configuration Rtsp.

How could you use Onvif? I used port 80 and without authentication.
The error is the same with the correct Dahua generic profile test and when loading the configuration appears discounted and also at that moment I can not access the camera is restarting.

Thank you.

ombrard
I'm New!
I'm New!
Posts: 5
Joined: Thu May 17, 2018 11:58 pm

Re: DAHUA not working with SS 8.1

Unread post by ombrard » Fri May 18, 2018 6:38 pm

Hi Litris,

i had issues with ONVIF too. All i did was reset the configuration of the camera (not the user or ip) and it started working using the ONVIF. Just make sure the codec is set to H264 in camera.

I've been running it for 24 hours doing some tests with different framerates to check the occupied size.

Also make sure you change the bitrate to variable IN CAMERA. There is no way to do it via SS and that saves a LOT of space.

Here is a pic of the settings. Just make sure is set to H264, everything else is set by SS except Variable Bit Rate

Image

Still i'd like to run the camera in H265 to save even more space and with the proper config.

Anybody else had luck with DAHUA cams in H265??

ombrard
I'm New!
I'm New!
Posts: 5
Joined: Thu May 17, 2018 11:58 pm

Re: DAHUA not working with SS 8.1

Unread post by ombrard » Sun May 20, 2018 12:19 am

Can somebody recoomend H265 cameras compatible with SS using the proper profile?

User avatar
Makc666
Trainee
Trainee
Posts: 17
Joined: Tue Jan 03, 2017 1:06 am

Re: DAHUA not working with SS 8.1

Unread post by Makc666 » Sun Sep 02, 2018 11:41 pm

I found out that Surveillance Station (SS) work with Dahua camera ONVIF if HTTPS is switched of on the camera.

I found out this way.
I have two Dahua cameras.
When first I installed SS and setup it to use ONVIF for both cameras on port 80 (HTTP).

At the same time I also turned on HTTPS on both cameras.
But I found out that both 80 (HTTP) and 443 (HTTPS) ports were still working on the cameras.
In other words I was able to access cameras on both 80 (HTTP) and 443 (HTTPS) ports.

But later the new firmwares came out to both cameras.
I installed those firmwares on cameras port 80 (HTTP).
And SS stopped working with my cameras.
SS was saying that Authentication failed (Login or Password).
I tried many things to change Login or/and Password
But that didn't help.

So after investigation I found out that when SS tried ONVIF out search it found my cameras but says in "Port" column that port is "N/A".
So I switched off HTTPS on cameras.
And ONVIF started working on SS.

I tried to switch HTTPS back on cameras.
And then point ONVIF setup at SS to port 443 (HTTPS).
But SS was saying "error".

So for the current moment I switched HTTPS at cameras and ONVIF works on port 80.

What I found out that after Dahua updated firmwares on cameras one little thing happened.
When you turn HTTPS on on camera then 80 (HTTP) begins to redirect to 443 (HTTPS) port.
But in old Dahua firmwares both 80 (HTTP) and 443 (HTTPS) ports were still working when you enable HTTPS.

I think it is SS problem so I want to write Synology support about this one. :)
DS916+ (8GB) / DSM 6.2-23739 Update 2 / Surveillance Station (SS) 8.1.5-5513

Post Reply

Return to “Surveillance Station”