How to adjust maximum upload file size.

Discussion room for Wordpress, a weblog based social networking community.
Forum rules
Synology Community is the new platform for the enthusiasts' interaction, and it will soon be available to replace the Forum.
Cartaphilus
Trainee
Trainee
Posts: 12
Joined: Tue Feb 16, 2010 7:36 pm

How to adjust maximum upload file size.

Unread post by Cartaphilus » Mon Feb 13, 2017 11:50 am

Currently my Synology Wordpress installation only support uploads with a filesize of max 32 MB. How do I raise this max size?

I tried the following options, but they don't seem to work (and yes I restarted apache/NAS after the changes):

- editing theme's `functions.php`

@ini_set( ‘upload_max_size’ , ’100MB’ );
@ini_set( ‘post_max_size’, ’100MB’);
@ini_set( ‘memory_limit’, ’100MB’ );

- editing /etc/php/php.ini

upload_max_filesize = 100M
post_max_size = 100M

-editing /volume1/web/wordpress/etc/htaccess_php.conf

php_value upload_max_filesize 100M
php_value post_max_size 100M


No matter what I do, Wordpress keeps saying: Maximum upload file size: 32 MB.

smithwaresale
I'm New!
I'm New!
Posts: 1
Joined: Tue Feb 28, 2017 3:38 pm

Re: How to adjust maximum upload file size.

Unread post by smithwaresale » Tue Feb 28, 2017 3:53 pm

+1 on this issue. Forums and knowledge bases for Synology, Wordpress, PHP all alude to various files, folders, and parameters to change to effect this feature, but no definitive method is documented anywhere. Mere suggestions are not the answer.

I am developing/testing a photography website on my NAS prior to production. Imagery files to upload can easily exceed 32MB, but individually are less than 64MB.

I am using Synology current versions of Wordpress and PHP, and DSM. I have also tried a variety of the methods described in forums, to no avail.

Know that when one moves a wordpress site to a public server, that hosting company may also have to upgrade their facility parameters to support this. Having a clear method to effect this change would benefit many website developers.

kdg2173
I'm New!
I'm New!
Posts: 2
Joined: Wed Mar 01, 2017 3:56 am

Re: How to adjust maximum upload file size.

Unread post by kdg2173 » Wed Mar 01, 2017 5:40 am

In DSM go to the web station -> "php settings" -> "Advanced Settings" -> "Core".
There you can set post_max_size, upload_max_filesize and max_execution_time.
Simple and Easy! (took me a while to find)

Weasel
Trainee
Trainee
Posts: 14
Joined: Wed Oct 15, 2014 10:18 pm

Re: How to adjust maximum upload file size.

Unread post by Weasel » Mon Apr 30, 2018 4:58 pm

I've tried the Web Station setting as well as everything else I could find, but the max upload file size is still stuck on 32M. Anyone have any info at all on this? Please.

Weasel
Trainee
Trainee
Posts: 14
Joined: Wed Oct 15, 2014 10:18 pm

Re: How to adjust maximum upload file size.

Unread post by Weasel » Tue May 01, 2018 4:37 pm

This is what finally worked for me: https://wordpress.org/plugins/php-settings/
The "PHP Settings" plugin.

Post Reply

Return to “Wordpress”