Problem viewing video files [SOLVED!]

Discussion room for Video Station package
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
lanark
Trainee
Trainee
Posts: 15
Joined: Mon May 11, 2015 9:59 pm

Problem viewing video files [SOLVED!]

Unread post by lanark » Mon May 11, 2015 10:26 pm

Hi everyone

New user here. Bought a DS215j a month ago, mostly for listening to music - which is fine and I haven't had a problem from that side.

I also want to use Video Station too, so I've merrily loaded movies and TV shows into the correct folders, wrestled with the indexing until it seemed to work and the tried to watch .... and very few of the files will play.

All of these will play offline - VLC is my go-to media player to the latest version is loaded and there's nothing intrinsically wrong with the files.

I've even tried using several browsers. Here's my findings:

Firefox
.mkv files often work okay (but not always)
.mp4 files play sound, but not the picture, all I get is the blue squares going round and round, also the pause / play button won't work with .mp4s, just the stop button
.avi files don't play at all, but also don't give an error message. They just stay on 0.00/0.00

Chrome
.mkv files work okay for the most part
.mp4 files work okay for the most part
.avi files throw up an error message saying that they can't be played on my computer.

IE
same as Firefox.

Almost all of the TV shows I have have been saved as .avi files (including a LOT of Doctor Who) so I really don't want to have to convert them all.

Any help will be very gratefully received. Thanks.
Last edited by lanark on Tue May 12, 2015 2:03 pm, edited 1 time in total.

lanark
Trainee
Trainee
Posts: 15
Joined: Mon May 11, 2015 9:59 pm

Re: Problem viewing video files

Unread post by lanark » Tue May 12, 2015 2:09 am

Update

I've replaced the 32bit version of VLC with the 64 bit version and there's been a slight improvement. Now in Firefox, mkv files work okay, and most of the mp4 files work too, but still I'm being told that avi files can't be opened in My computer.

It must be a browser thing because when I log into DS Video on my cheap Hudl2 the avi files work fine. I really want to be able watch these files in my Browser on Video Station though - I'm sure that I shouldn't be having this much bother.

Any advice or ideas?

lanark
Trainee
Trainee
Posts: 15
Joined: Mon May 11, 2015 9:59 pm

Re: Problem viewing video files

Unread post by lanark » Tue May 12, 2015 1:22 pm

Okay this gets more and more baffling.

I'm using Windows 7 and I have the latest version of Firefox loaded.

I removed all copies of VLC and reinstalling Firefox.

First I loaded the 64 bit version of VLC. This didn't install the plugin to Firefox. The result (without the VLC plugin) was as follows
.mkv files pretty much all played fine
.mp4 files pretty much all played fine
.avi files threw up the error notice that the file format could not be played on my computer

I then loaded the 32 bit version of VLC. This installed the web plugin for Firefox. Result
.mkv files still pretty much played fine
.mp4 files play sound but no video. I see the total time for the video and the time counter seems to be moving, but if I try to click on the Play / Pause button nothing happens and the only player button that works is Stop.
.avi files. Play sound but the total and running time for the video both stay at 0.00/0.00 and again the play / pause buttons don't do anything.

This is all through the Synology Video Station package and also when I go into File Station, right click and choose play.

I'm utterly baffled. Nobody else seems to have these problems. does anyone have any idea what might be causing this. Is there any other browser I could use that would play better, is there anywhere in the setting that I can tweak something to make this work?

All files work absolutely fine on my desktop, it's when I try to open files inside DSM through Video Station that the problems occur.

lanark
Trainee
Trainee
Posts: 15
Joined: Mon May 11, 2015 9:59 pm

Re: Problem viewing video files

Unread post by lanark » Tue May 12, 2015 2:03 pm

SOLVED! (but I'm not sure how)

This afternoon I was told that there was an update to DSM (must be brand new as I'd asked it to check and been told I had the most up-to-date version before). Loaded that up.

Next I was told that Video Station needed updating as it was no longer compatible with DSM (again, I'd checked if there were updates to VS available and been told no). Updated that and the other media packages too.

Lo and behold after the update all files will play in Firefox - mkv, mp4 and avi all playing nicely.

I've no idea why the updates weren't appearing before, but I'm much relieved.

benyorke
I'm New!
I'm New!
Posts: 1
Joined: Tue May 12, 2015 2:24 pm

Re: Problem viewing video files [SOLVED!]

Unread post by benyorke » Tue May 12, 2015 2:33 pm

I am very curious to get home and update mine. I have had issues starting about a month ago. I think it was an update to Chrome that caused my issues, but there is no longer a VLC plugin for Chrome and I can't view movies using the Video Station on my DS212j. It give me a black screen and says it cannot be displayed.
I've tried downloading Firefox multiple times, but it does strange things to my computer and cause me to have to do a hard restart. I hope the update solves it, but I think it's more to do with Chrome.

lanark
Trainee
Trainee
Posts: 15
Joined: Mon May 11, 2015 9:59 pm

Re: Problem viewing video files [SOLVED!]

Unread post by lanark » Tue May 12, 2015 11:36 pm

Hope you get it sorted out - it's pretty miserable thinking that you're the only person having problems with something as basic as watching video.

Have to say that avi files are still a bit flaky compared to mkv and mp4 files - the time elapsed / total time indicators never changes from 00.00/00.00 and the picture expands and blocks the player controls so that my only control is to watch or close the tab.

However, I'm just glad that the pictures are working. It's nice to able to play things from the indexed library view, but if things got really difficult, I can always open the NAS as a network drive and simply open the file with vlc on my desktop.

lmerega
Beginner
Beginner
Posts: 20
Joined: Wed May 13, 2015 3:09 pm

Re: Problem viewing video files [SOLVED!]

Unread post by lmerega » Thu May 14, 2015 9:28 am

I can view all of my videos using the latest version of VLC and Firefox.
Chrome has a strange behavior.
All of my 720p tv shows have the same problem:
They have .mkv extensions, I can hear sound with no video.
If I rename it to .mp4, I cann see video and subs, no audio.
As I told, no problems with firefox.
Ideas?

mrhome0212
I'm New!
I'm New!
Posts: 3
Joined: Sun Dec 11, 2016 8:23 pm

Re: Problem viewing video files [SOLVED!]

Unread post by mrhome0212 » Tue Dec 13, 2016 5:13 pm

Im using DS215j
and i think i have similar problems like you guys say above
but my problem hasnt solved till now.

Im using Chrome Browser to access Video Station
and all the videos with extension .rmvb / .mkv
cannot be played.
it says "マイコンピュータはこのビデオフォーマットに対応していません”
(My Computer do not match the video format)

i installed the VLC plugin for the Chrome Browser
but it seems to me nothing has been done.

i tried Firefox and Safari and
same thing happened

do anyone know what is it about? and how to solve it?

thanks all

User avatar
syno.dustin
Sorcerer
Sorcerer
Posts: 2244
Joined: Thu Oct 29, 2015 11:03 pm
Location: Seattle, WA

Re: Problem viewing video files [SOLVED!]

Unread post by syno.dustin » Tue Dec 13, 2016 8:39 pm

Sounds like the VLC plugin isn't kicking in which will be needed as AFAIK none of those browsers natively play MKV. Download the file first and then try VLC or another MKV compatible player.
If you need technical support please use this form: https://account.synology.com/support/support_form.php
Synology does not consistently browse this forum for technical support, feature requests, or any other inquiries as it notes at the top of the page. Please use the proper channels when you need help from someone at Synology.

icerabbit
Sharp
Sharp
Posts: 187
Joined: Wed Mar 12, 2008 5:07 pm

Re: Problem viewing video files [SOLVED!]

Unread post by icerabbit » Thu Dec 15, 2016 10:54 pm

So much frustration ...

Brand new Core i7 Windows 10 64bit etc latest Firefox Edge VLC etc
Attached to our HDTV (after using a trusty core 2 duo and then a media stick pc)

Firefox will not play the 500mb mkv file

MS Edge does, but it stutters every 10 secs and needs to buffer for a sec or two??

No Wifi involved in this case. All gigabit cat6 network that can move files at over 100MB/s

What is going on with video station and it looks like a custom flash player? no settings no options ...

This stuff used to work AOK on the old crusty 32 bit system with a fraction of the power, ram, etc. when we also still had a previous version of DSM.

Figured I could update to the latest 5.x in the mean time.

Big mistake, without a way back it seems.

PS: As far as downloading files ... yeah, not really why we have these $$$$ powerful centralized NAS and networks for, is it? to have the headache of localized downloads and maintenance.

bamix
I'm New!
I'm New!
Posts: 7
Joined: Mon Feb 13, 2017 4:10 am
Location: Melbourne, Australia

Re: Problem viewing video files [SOLVED!]

Unread post by bamix » Mon Feb 13, 2017 4:41 am

I have had a DS212 DIskStation for about 5 years. Not long after I purchased a Hauppauge USB Tuner (from the Synology approved list) and, for most of the time, enjoyed the option of watching Live FTA TV at my PC using the VideoStation app in a Firefox browser session with the VLC plug-in active. As I say, it has worked pretty well over these past few years. I did have the odd hiccup or two but they were mostly overcome by Synology updates flowing through.

However, this latest issue has been going on for months. As the other posters mentioned, I get audio but no video (just a black screen) and the counter and controls on screen don't respond or function. The exception is the toggle for Full Screen and not Full Screen. If I click that, during the change the video will appear for about a second and then go to black again. The same happens if I toggle the other direction.

If I copy the link for the Live TV stream and open it as a network location direct in VLC then it plays no problem. I have contacted Synology Support and opened a ticket but there response was along the lines of it being a router problem. I have had the same router with the same settings for ages so I don't understand why that would change. I have checked the UPnP settings in the router and they all seem to line up with the changes needed and configured by the DiskStation anyway. I have tried uninstalling/reinstalling, changed Windows firewall settings, turned firewalls off altogether but nothing seems to make a difference. I have checked the DLNA list and made changes to see if it had any affect, nothing has influenced it at all for better or for worse.

I don't use VideoStation for sorting a video library, never have, just for the DTV and recording DTV function. Previously recorded DTV files on the DiskStation in Transport Stream (.ts) format behave exactly the same way as live TV.

One thing I did notice at the point where it seemed to go haywire was when I went to watch live TV, I found that all the previously scanned channels for the Tuner were gone, there was nothing there at all. This made me wonder whether there was a connection between a recent VideoStation update and this problem that I am now left with. There has since been updates for VideoStation, Media Server and the main OS but this problem has remained.

I would be interested to know if anyone else is having such a problem or if any of the posters above actually resolved this issue. I have spent hours on this and still haven't found an answer.

bamix
I'm New!
I'm New!
Posts: 7
Joined: Mon Feb 13, 2017 4:10 am
Location: Melbourne, Australia

Re: Problem viewing video files [SOLVED!]

Unread post by bamix » Tue Feb 21, 2017 12:03 pm

OK, now my problem is solved by doing an uninstall of Media Server and Video Station to the earliest that my (current) version of DSM would allow.

See more info at this thread, https://forum.synology.com/enu/viewtopi ... 75#p471975

So for all my time wasted checking, changing, double-checking researching checking, changing, trying and failing; it turns out is a problem with one of these
packages recent updates anyway.

As I mentioned in the other thread, it's not the first time I have had such a problem over the years. If anyone else is having a similar issue and you have seemingly
exhausted all other logical avenues, try a package roll back. It just may solve your problem too.

wheadon
I'm New!
I'm New!
Posts: 5
Joined: Sun Dec 31, 2017 3:44 pm

Re: Problem viewing video files [SOLVED!]

Unread post by wheadon » Tue Jan 23, 2018 8:34 pm

I have added a special extension to chrome and installed some custom node.js script and
my 216J diskstation plays streams all films in what ever codec now transcoding them on the workstation instead
Please contact me here for the work around. :D :D

lord_lolzworth
I'm New!
I'm New!
Posts: 1
Joined: Tue Aug 29, 2017 12:45 am

Re: Problem viewing video files [SOLVED!]

Unread post by lord_lolzworth » Fri Feb 23, 2018 1:22 am

wheadon wrote:I have added a special extension to chrome and installed some custom node.js script and
my 216J diskstation plays streams all films in what ever codec now transcoding them on the workstation instead
Please contact me here for the work around. :D :D
Could you please run us through the plugins you have used. I am in the same boat with not been able to play .mkv files.

Thanks,

Locked

Return to “Video Station”