Access to /photo for non-administrator

Questions pertaining to Power settings, Auto Block, Permissions, User Quotas and Email alerts may be posted here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
b00134n
I'm New!
I'm New!
Posts: 6
Joined: Tue May 15, 2012 6:10 am

Access to /photo for non-administrator

Postby b00134n » Fri Feb 17, 2017 5:51 am

Hi all. I'm trying to set up my camera to automatically upload pictures to my DS916. I have everything mostly working, but am currently uploading photos into an "/ftp/photo" folder and would really like to get them into "/photo" so that they appear in Photo Station.

Unfortunately, the "upload" user that I created (for security) does not have access to the "/photo" folder as a member of the Users group. When I try to change the folder permissions using "control panel -> shared folder -> photo -> edit -> permissions" -- there is an overlay instructing me to manage the permissions from within Photo Station. So, I go to Photo Station and confirm that all of the privileges possible (browse album, upload files, manage) are assigned to the "upload" account via "Settings -> User Accounts -> Edit".

What am I missing here? It must be possible to access the "/photo" folder as a non-administrator. If anyone can help, I would greatly appreciate it! :)
User avatar
HarryPotter
Honorary Moderator
Honorary Moderator
Posts: 17968
Joined: Mon Oct 23, 2006 12:48 pm
Location: Switzerland

Re: Access to /photo for non-administrator

Postby HarryPotter » Fri Feb 17, 2017 9:23 pm

Do not use the system group "users" for permission settings. Create your own groups.
*Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!*

DS415+ / DSM 6.1-15047 / ST4000VN000-2AH166
DS713+ / DSM 6.1-15047 / HD501LJ + HD502IJ (RAID0)
DS712+ / DSM 6.1-15047 / HD154UI + ST31000340AS (RAID0)

2 Squeezebox 3 + Boom

APC Smart UPS SUA750i
b00134n
I'm New!
I'm New!
Posts: 6
Joined: Tue May 15, 2012 6:10 am

Re: Access to /photo for non-administrator

Postby b00134n » Fri Feb 17, 2017 9:44 pm

HarryPotter wrote:Do not use the system group "users" for permission settings. Create your own groups.

Thanks for the reply. I just tried to create a new user group and the permissions are all grayed out for /photo and cannot be changed in the "Assign shared folder permissions" dialogue of the Group Creation WIzard.
Last edited by b00134n on Fri Feb 17, 2017 9:48 pm, edited 1 time in total.
User avatar
HarryPotter
Honorary Moderator
Honorary Moderator
Posts: 17968
Joined: Mon Oct 23, 2006 12:48 pm
Location: Switzerland

Re: Access to /photo for non-administrator

Postby HarryPotter » Fri Feb 17, 2017 9:47 pm

Disable all permissions for the system group "users" (nothing should be ticked there).
*Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!*

DS415+ / DSM 6.1-15047 / ST4000VN000-2AH166
DS713+ / DSM 6.1-15047 / HD501LJ + HD502IJ (RAID0)
DS712+ / DSM 6.1-15047 / HD154UI + ST31000340AS (RAID0)

2 Squeezebox 3 + Boom

APC Smart UPS SUA750i
b00134n
I'm New!
I'm New!
Posts: 6
Joined: Tue May 15, 2012 6:10 am

Re: Access to /photo for non-administrator

Postby b00134n » Fri Feb 17, 2017 10:31 pm

HarryPotter wrote:Disable all permissions for the system group "users" (nothing should be ticked there).

Nothing is ticked there. I created an "upload" group and recreated the "upload" user, but have the same problem as before.
b00134n
I'm New!
I'm New!
Posts: 6
Joined: Tue May 15, 2012 6:10 am

Re: Access to /photo for non-administrator

Postby b00134n » Sat Feb 18, 2017 2:52 am

In case anyone else is having this issue, I received a response from Synology support. Apparently it is not possible to fix this issue with Photo Station installed. I was able to resolve things by uninstalling Photo Station, changing "/photo" permissions for the "upload" user and then reinstalling Photo Station. Thanks for trying to help, HarryPotter.

Return to “System Management”

Who is online

Users browsing this forum: No registered users and 1 guest