Network Backup Failed (between two identical Synology NAS)

Reference only! Archived older discussions about backup and restore of the DiskStation to any client.
Forum rules
Synology Community is the new platform for the enthusiasts' interaction, and it will soon be available to replace the Forum.
maninblue
I'm New!
I'm New!
Posts: 2
Joined: Mon Feb 22, 2010 7:12 pm

Network Backup Failed (between two identical Synology NAS)

Unread post by maninblue » Mon Feb 22, 2010 7:29 pm

Hi,

I have a problem to get Network Backup working. Everything is set up by the instructions: http://forum.synology.com/wiki/index.ph ... in_DSM_2.2
Just starting backup job, status shows connected and making backup and after 1 minute it fails. Protocol shows:

([30] Failed to connect to the destination server. Please make sure: 1. The server name or IP is correct. 2. Network Backup service has been enabled on the destination server. 3. The destination server is connected to an active network.
or
([43] Failed to connect to the destination server. Please make sure: 1. The server name or IP is correct. 2. Network Backup service has been enabled on the destination server. 3. The destination server is connected to an active network.

- both Synology stations are identical (DS110j, latest firmware DSM 2.2-0965, same 1TB disk, same admin account and password)
- both Synology stations are on the same local subnet (192.168.2.xxx) directly connected to the switch
- the local subnet is connected to internet by the SPI firewall. It doesn't matter if the SPI is Off or On (tried)
- Network Backup service is enabled on the destination server
- they see each other (ping from one to the other works)
- All synology Applications off on both servers
- tried several diferrent settings, several hours, with no progress :?

Could you help me please?
Thanks, Pete

ryandiriga
I'm New!
I'm New!
Posts: 2
Joined: Thu Feb 18, 2010 5:29 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by ryandiriga » Mon Feb 22, 2010 9:53 pm

I am having this same problem except mine are on two DS508 boxes. Any help would be greatly appreciated.

Network Backup failed to backup task [TWNASMAIN] to [TWSPNAS (192.168.0.10)]. ([43] Failed to connect to the destination server. Please make sure: 1. The server name or IP is correct. 2. Network Backup service has been enabled on the destination server. 3. The destination server is connected to an active network.)

Says it is connected to destination server, the IP and name are correct, I can ping back and forth. Network backup service has been enable on both servers and they are connected to the same switch.

Started failing even though no changes were made, hope someone can help, this has been going on for over a week.

maninblue
I'm New!
I'm New!
Posts: 2
Joined: Mon Feb 22, 2010 7:12 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by maninblue » Tue Feb 23, 2010 12:21 am

Firmware bug?

wkoedam
I'm New!
I'm New!
Posts: 2
Joined: Tue Mar 30, 2010 9:17 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by wkoedam » Wed Mar 31, 2010 11:52 am

I have a similar issue. I am trying to back up my DS408 to my DS207+. Both systems are on DSM2.3, but issue was also there under older versions.
On the DS408 I have four shared directories: documents, movie, picture and photo. All directories are bigger than 300GB, except for the documents one. The first back-up goes fine, all is back-up perfectly.
However, the next back-up go well, EXCEPT for the photo one, it fails. The network back-up log is giving a [30] Failed to connect to destination server error. And it does this permanently. All is OK except for photo directory.
I have checked all settings, and settings are everywhere the same for each directory. Photo directory is relatively big, but movie and music directorie are bigger and have more subdirectories.
When looking at the properties of the directories/files via file station function, then there seems to be a difference between photo and the others. The privileges are invisible, that is the “V-sign” in front of the read, write and execute privileges are blurred/invisible whereas for the other directories/files this is not the case. And on the back-up NAS, nothing is blurred/invisible, even not for the photo directory.
If I make a copy of –part of- the photo directory under a new shared directory “photoz” I have exactly the same problems (blurred, [30] error etc.), BUT if I call the directory “zphoto”, then there is no issue at all !

It seems for whatever reason that if I name the directory “photo***” Synology has a problem. That does seem to be strange. Has it to do with the “photo station” functionality that conflicts with the back-up procedures ? (note that photo station is not enabled) ? Of course I can change the directory to “zphoto” permanently, but that means that I have to do a lot of changes in other applications as they are looking for “photo”. Any suggestions ?

Robster
Enlightened
Enlightened
Posts: 407
Joined: Thu Oct 26, 2006 7:20 am

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by Robster » Fri Apr 02, 2010 8:54 am

Hi Guys

I too have had this problem.

And I think I have PARTIALLY solved it.

For some reason if you have too many files/folders or something the backup fails and says it cannot connect to the other server which is a totally false error.

I have broken by DS209+II backup into two backups and one, the smaller one (larger capacity but less files) now repeatedly backs up fine from one DS to another.

I am now trying the smaller back up (capacity but lots more smaller files/folders) to see f this will also back up repeatedly.

Worth a try.

Robin
-----------------------------------------------------------------------------------------
DS412+ as primary and DS411+II as Backup server
RT2600ac Router

Robster
Enlightened
Enlightened
Posts: 407
Joined: Thu Oct 26, 2006 7:20 am

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by Robster » Sat Apr 03, 2010 7:40 am

It is/was definitely the Backups folder.

I can only get Network backup to run if I select a subset of the folders within this main folder.

However my main files backup from DS209 to DS207 now runs reliably and repeatedly and the subset of my Backups folder also runs reliably and repeatedly.

HOWEVER, I still want Synology to fix this problem ASAP.

Robin
-----------------------------------------------------------------------------------------
DS412+ as primary and DS411+II as Backup server
RT2600ac Router

Midtjyden
Sharp
Sharp
Posts: 189
Joined: Sat Feb 20, 2010 12:21 pm
Location: Silkeborg, Denmark

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by Midtjyden » Sat Apr 03, 2010 9:20 am

How many files are we talking about - just out of curiosity. :)
DS409+ | DSM 2.3-1141 | 4 x 2TB Hitachi HDS722020ALA330 RAID5
DS408 | DSM 2.2-0965 | 2 x 2TB Western Digital WD20EARS RAID0 + 1TB Western Digital WD10EADS
DS101g+ | DSM 2.3-1141 (Goetz hack and guide) | 1 x 500GB Seagate ST3500630AS

Robster
Enlightened
Enlightened
Posts: 407
Joined: Thu Oct 26, 2006 7:20 am

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by Robster » Sat Apr 03, 2010 9:55 am

Hi

Sorry but I am not sure how to find this information from my Mac?

I know it is around ^00Gb's in size and I know that there are a large number of files and directories but no idea how to find out exactly how many of each I am afraid?

Regards.

Robin
-----------------------------------------------------------------------------------------
DS412+ as primary and DS411+II as Backup server
RT2600ac Router

FlashKit
Apprentice
Apprentice
Posts: 85
Joined: Mon Jan 28, 2008 6:05 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by FlashKit » Sun Apr 04, 2010 8:56 am

It usually works for me, but from time to time I have a simialr issue ([30] Failed to connect to destination server error) with a scheduled network backup from a DS508 to a DS509+.
Fortunately, manually resubmitting the backup fixes the failure.
Fingers crossed....
DS1817+ (6x WD60EFRX - SHR/BTRFS) - DSM 6.1
DS1817+ (6x WD60EFRX - SHR/BTRFS) - DSM 6.1
DS1817+ (6x WD60EFRX - SHR/BTRFS) - DSM 6.1
DS1815+ (4x ST10000VN0004 - SHR/BTRFS) - DSM 6.1

wkoedam
I'm New!
I'm New!
Posts: 2
Joined: Tue Mar 30, 2010 9:17 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by wkoedam » Wed Apr 07, 2010 12:38 pm

Hi,


I also thought it could possibly have to do with the size and/or amount of subdirectories and/or amount of files. However, both my video directory and music directory are bigger in size, have more directories etc., but are still backing up smoothly. Only thing is that indeed the photo directory might have a few more actual files. However, when I made 2x a copy of the same part (around 10%) of the photo directory and named one "photoz" and the other "zphoto", then the "photoz" directory is having exactly the same problem as with the big directory, but the "zphoto" directory is doing everything perfectly ! That leads me to the conclusion that the actual amount of files is not the issue, but there is possibly an issue with naming your directory "photoxxxxx". I know it sounds strange, but after testing so many things, this is the only thing that is left over....at least, that is my conclusion...

Luc
Rookie
Rookie
Posts: 33
Joined: Sun Jul 05, 2009 9:35 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by Luc » Wed Apr 07, 2010 9:43 pm

Robster wrote:Hi

Sorry but I am not sure how to find this information from my Mac?

I know it is around ^00Gb's in size and I know that there are a large number of files and directories but no idea how to find out exactly how many of each I am afraid?

Regards.

Robin
OK, let's give it a try. I rebuild the volume on my backup server to start with an empty disk.
My (other) disk stations have shares with the following data to backup.
# files # folders GB
181168 12836 141
92860 864 205
57264 2386 111
15906 1409 181
7656 60 23
636 99 214
26 5 43
5 1 6
I will backup the shares one by one and create as little as possible other network traffic.
When a backup fails I will check how many files/folders/GB are copied so far. Maybe we learn something from it.
Cheers, Luc
DS211/DSM 3.1-1742 /2x WD20EARS-00MVWB0 RAID1 /Squeeze Center 7.5.4 /Photostation 4 /usbprinter HP Laserjet 4050 via Parallel-USB interface
DS209+II/DSM 3.1-1742 /2x WD10EAVS-00D7B1 RAID1 /Download Station /Surveillance Station 5 /Squeeze Center 7.5.4
DS207+/DSM 3.1-1613 /2x WD15EARS-008SB1 Basic /Network backup service /usbprinter Canon iP4500
DS207/DSM 3.1-1613 /ST31000340NS+WD7500AAKS Basic /Network backup service

Luc
Rookie
Rookie
Posts: 33
Joined: Sun Jul 05, 2009 9:35 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by Luc » Thu Apr 08, 2010 6:59 am

_My backup test_
So far, so good. Backed up two small shares. Current state: 138 GB copied with an average of 4.9 MB/s. When the current backup finishes (expected this afternoon at 1 pm) the backup of a big one will start: a share with 93K files and 205 GB data. Estimated backup time: between 11.6 and 17.3 h. Let's see what happens.
Cheers, Luc
DS211/DSM 3.1-1742 /2x WD20EARS-00MVWB0 RAID1 /Squeeze Center 7.5.4 /Photostation 4 /usbprinter HP Laserjet 4050 via Parallel-USB interface
DS209+II/DSM 3.1-1742 /2x WD10EAVS-00D7B1 RAID1 /Download Station /Surveillance Station 5 /Squeeze Center 7.5.4
DS207+/DSM 3.1-1613 /2x WD15EARS-008SB1 Basic /Network backup service /usbprinter Canon iP4500
DS207/DSM 3.1-1613 /ST31000340NS+WD7500AAKS Basic /Network backup service

Luc
Rookie
Rookie
Posts: 33
Joined: Sun Jul 05, 2009 9:35 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by Luc » Fri Apr 09, 2010 6:38 am

_My backup test_ part two
The backup of the 93K files didn't make it. It stopped with the usual failure at 23:15 pm after 03:13:02 hours copying of 40491 files, 264 maps and 44.8 GB data.
None of the numbers ring a bell to me. No other network traffic that time. I restarted the backup this morning; 52K more files to go. Let's see what happens next.
So far backupped 365.3 GB data in total to a JBOD of two 1.0 TB disks.
Cheers, Luc
DS211/DSM 3.1-1742 /2x WD20EARS-00MVWB0 RAID1 /Squeeze Center 7.5.4 /Photostation 4 /usbprinter HP Laserjet 4050 via Parallel-USB interface
DS209+II/DSM 3.1-1742 /2x WD10EAVS-00D7B1 RAID1 /Download Station /Surveillance Station 5 /Squeeze Center 7.5.4
DS207+/DSM 3.1-1613 /2x WD15EARS-008SB1 Basic /Network backup service /usbprinter Canon iP4500
DS207/DSM 3.1-1613 /ST31000340NS+WD7500AAKS Basic /Network backup service

FlashKit
Apprentice
Apprentice
Posts: 85
Joined: Mon Jan 28, 2008 6:05 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by FlashKit » Fri Apr 09, 2010 8:27 am

Not sure that this issue is related to file count or backup size....
My backup share is approx 1.3 TB (first launch needs approx 18 hours to go, next ones need approx 15 minutes to complete) with 300 000+ files and subdirectories, individual file size from few bytes up to 6 GB/each.
The network backup works well - except (as said before) from time to time (once every ten backups or so) it fails ([30] Failed to connect to destination server error).
Relaunching the backup has always fixed the problem for me.
DS1817+ (6x WD60EFRX - SHR/BTRFS) - DSM 6.1
DS1817+ (6x WD60EFRX - SHR/BTRFS) - DSM 6.1
DS1817+ (6x WD60EFRX - SHR/BTRFS) - DSM 6.1
DS1815+ (4x ST10000VN0004 - SHR/BTRFS) - DSM 6.1

Luc
Rookie
Rookie
Posts: 33
Joined: Sun Jul 05, 2009 9:35 pm

Re: Network Backup Failed (between two identical Synology NAS)

Unread post by Luc » Fri Apr 09, 2010 4:37 pm

_My backup test_ part three
Relaunching the backup doesn't always work for me. The backup failed the second time in succession after 02:19:15 hours and 13K files, 189 folders and 33.6 GB.
I will relaunch the backup again. 39K more files to go. :?
Cheers, Luc
DS211/DSM 3.1-1742 /2x WD20EARS-00MVWB0 RAID1 /Squeeze Center 7.5.4 /Photostation 4 /usbprinter HP Laserjet 4050 via Parallel-USB interface
DS209+II/DSM 3.1-1742 /2x WD10EAVS-00D7B1 RAID1 /Download Station /Surveillance Station 5 /Squeeze Center 7.5.4
DS207+/DSM 3.1-1613 /2x WD15EARS-008SB1 Basic /Network backup service /usbprinter Canon iP4500
DS207/DSM 3.1-1613 /ST31000340NS+WD7500AAKS Basic /Network backup service

Locked

Return to “Backup/Restore (Archived)”