A HDD changed, rebuild successfull, expansion stuck at 0.00% and then crash

Topics pertaining to volume setup, boot/shutdown, initialization, DSM update, HDD migration.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://account.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
tintronic
I'm New!
I'm New!
Posts: 9
Joined: Tue Sep 08, 2015 2:26 pm

A HDD changed, rebuild successfull, expansion stuck at 0.00% and then crash

Postby tintronic » Mon Nov 20, 2017 4:03 pm

Hello,
My 4-bay NAS (DS411) had 2x4TB WD RED + 2x1.5TB in SHR for a total of about 6.3TB (reported). I had been struggling to keep free space on in, and now with the drone-mapping-pictures I've been taking I was having none left.

I decided to increase the storage capacity by replacing one of the 1.5TB drives with another 4TB WD RED drive. Everything was going well to the point where NAS status went from degraded to healty and onto the step on which it started adding the new available space, but 24 hours later it remained stuck on 0.00%.

I've done this a couple of times, replacing bad drives or adding more space, and it took several days for the whole process to finish, so I was expecting about a week for it to finish, but it had never before gone stuck.

However, after googling abit, I didn't find anyone having the exact same issue, and some reported they had to reboot the NAS to get one of the previous steps unstuck at a given percent (which took the rebuild process back to square one) for it to finish sucessfully.

I tryied to reboot it but got the message that a scrubbing was still being performed. I googled a bit more but coudn't find much about it (do/don't), except a reboot was the only way to get a rebuild unstuck. Since my NAS status was already healthy and it was only attempting to add the remaining space but wouldn't get past that 0.00%, I finally decided to reboot anyway.

Now after the reboot the NAS status is CRASHED! Why the hell? It was healthy before, consistency check and rebuild had finished ok, only adding the free space remained. I'm using the lates DSM version (6.1.4-15217 Update 1) and I rebooted using the reboot option from the web interface.

The NAS status cannot be both healthy and non-rebootable.
Currently it's checking parity consistency at 39.75% and I am obviously unable to access the drive contents. I hope it rebuilds well.

Anyone else had such a problem?
Last edited by tintronic on Thu Nov 23, 2017 11:35 pm, edited 2 times in total.
tintronic
I'm New!
I'm New!
Posts: 9
Joined: Tue Sep 08, 2015 2:26 pm

Re: A HDD changed, rebuild successfull, expansion stuck at 0.00% and then crash

Postby tintronic » Thu Nov 23, 2017 8:03 pm

HORROR! The parity check failed and the volume showed up permanently crashed. No access to any data.
I created a ticket with synology and received a quick reply with instructions on how to grant them access to my NAS to try and repair the problem.

I had trouble granting them access because my internet provider is a 30 km long wireless link and he doesn't provide a public (external) IP address.
The other option I had didn't work either because the router of my cellphone internet provider is totally blocked and doesn't have uPnP.
I finally had to move my DS411 +UPS to a friends house in the nearest city with "landline" internet, where I was able to gran them access.
All these tries to grant them access were accompanied by a very fluent email exchange with the support guy at synology untill his working hours ended that day.

The next day he replied that he had to escalate this to the developers in Taiwan, which would take an additional 24 to 48 hours due to the time zone difference. This got me really scared for my data.

Today I logged remotely into it an voilá! The volume is back to degraded mode with parity checking on the way, meaning I am able to access my data again. Yay!
tintronic
I'm New!
I'm New!
Posts: 9
Joined: Tue Sep 08, 2015 2:26 pm

Re: A HDD changed, rebuild successfull, expansion stuck at 0.00% and then crash

Postby tintronic » Thu Nov 23, 2017 11:11 pm

Someting a little weird and confusing is going on.

Now Storage Manager reports "System is healty". "degraded" is no longer to be seen anywhere.
However, the volume is still "Repairing (Checking parity consistency)" and percentage count has restarted from zero.

I didn't take a screen capture, but the volume seems to have changed from "Degraded (Checking parity consistency)" to "Repairing (Checking parity consistency)". Is it double checking parity consistency? This is before any spare space is added.

Return to “Installation, Configuration, Migration, Expansion”

Who is online

Users browsing this forum: cmeyer25, kudzu53 and 2 guests