TypeError: undefined is not an object (evaluating 'a.btnEl.setARIA') Error when searching using AudioStation 6.3.0-3260

Questions/comments regarding the Audio Station can be placed here
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
benjibarnicals
Enlightened
Enlightened
Posts: 471
Joined: Sun Mar 18, 2007 10:49 pm

TypeError: undefined is not an object (evaluating 'a.btnEl.setARIA') Error when searching using AudioStation 6.3.0-3260

Unread post by benjibarnicals » Tue Oct 31, 2017 10:37 pm

Hi all,

Just upgraded to the latest AudioStation 6.3.0-3260, and I'm getting this error:

Image
TypeError: undefined is not an object (evaluating 'a.btnEl.setARIA') ux-all.js:31:109403

It happens when I first load AudioStation and type in the search box (top left), like in my example "Goodnight" when searching "All Categories". It doesn't happen if you're searching a specific section of Artists, Genre, Title etc.

Console logging the browser shows this error, the whole DSM interface hangs showing the "Loading" popup continually, you can't click on or around it. Waiting for minutes doesn't resolve it. Instead, you have to reload DSM in the browser.

If you, however, play a song first, for example, if you go specifically to a song without searching, and then do the same search on "All Categories" it works fine and will search everything.

I've tested this on the latest Mac Chrome and Mac Safari, though I haven't tried on Windows machines. Anyone else getting this?

User avatar
sjeph8je
Seasoned
Seasoned
Posts: 555
Joined: Fri Jan 29, 2010 10:06 pm
Location: Netherlands

Re: TypeError: undefined is not an object (evaluating 'a.btnEl.setARIA') Error when searching using AudioStation 6.3.0-3

Unread post by sjeph8je » Wed Nov 01, 2017 8:07 am

Hi,
I am seeing this behavior too and there is already another post complaining about the search in AS not working.
DS-218+ (10GB) | DSM 6.2-23739-2 | 1 x WD20EFRX (Basic-btrfs) (Hyper backup vault, DS, Docker, Tvheadend)
DS-916+ (8GB) | DSM 6.2-23739-2 | 2 x WD40EFRX (RAID1-btrfs) | 2 x WD10EFRX (RAID1-btrfs) (AS, Calendar, Chat, CMS, Docker, Hyper backup, PS, Snapshot Replication, SVN, VS, WS, Webdav)
  • Startech S3510SMU33 | WD20EFRX (ext-4)
DS-213J | DSM 6.2-23739 | 1 x WD20EFRX (Basic-ext4) (Hyper backup vault)
DS-209 | DSM 6.2-23739-2

Corruption wears infinite disguises.

gordo_nelson
I'm New!
I'm New!
Posts: 2
Joined: Sun Mar 27, 2016 3:38 pm

Re: TypeError: undefined is not an object (evaluating 'a.btnEl.setARIA') Error when searching using AudioStation 6.3.0-3

Unread post by gordo_nelson » Thu Nov 16, 2017 6:32 pm

Same issue with AS search for last month with AudioStation 6.3.0-3260

I opened a ticket just today (16 NOV 2017).
"Audio Station search has stopped working when in any browser. Tried numerous browser combinations (Mac - Chrome, Safari; PC - Firefox, Chrome) and can't get around this issue.
Anytime I initiate a search with the Audio Station search function, the application hangs forever. I have to bounce the AS service to get it back. Only a search task initiates this behavior. If I never initiate a search, Audio Station seems to work well (all other functions).
Also, while in this inop state, if I use the Audio Station app on iOS, a search returns properly and is not affected by the inop state of the browser-based AS app. So, it would seem the underlying AS service is still functioning properly, but something is amiss with all browser-based AS apps."

Post Reply

Return to “Audio Station”