107+ Firmware 524 External USB Problem

All questions, comments, discussion about firmware 518 can be placed here. Please place regular support questions in one of the subjects below.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
User avatar
Kenny-M
Experienced
Experienced
Posts: 132
Joined: Sat Oct 28, 2006 4:00 pm
Location: Connecticut

107+ Firmware 524 External USB Problem

Unread post by Kenny-M » Thu Jan 10, 2008 1:23 pm

I recently upgraded my DS-107+ from 0518 to 0524 firmware.

Now when cold starting the system by first powering up the external USB drive and waiting a while then powering up the DS-107+ the external USB drive is not always see. Sometimes yes sometimes no.

Below is a clip of the initial 'dmesg' followed by cycling power on the external USB device then the tail of another 'dmesg'.


Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
DiskStation2>

External USB drive not seen at startup

Power off and back on external USB drive. Now its seen.

scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
Vendor: Hitachi Model: HDT725032VLAT80 Rev: V54O
Type: Direct-Access ANSI SCSI revision: 00
drivers/scsi/sd.c (1687) Got USB disk
SCSI device sdk: 625142447 512-byte hdwr sectors (320073 MB)
sdk: assuming drive cache: write through
SCSI device sdk: 625142447 512-byte hdwr sectors (320073 MB)
sdk: assuming drive cache: write through
sdk: sdk1
sd 2:0:0:0: Attached scsi disk sdk
sd 2:0:0:0: Attached scsi generic sg1 type 0
usb-storage: device scan complete
kjournald starting. Commit interval 5 seconds
EXT3 FS on sdk1, internal journal
EXT3-fs: mounted filesystem with writeback data mode.

Ken
------------
Synology: DS-107+,2.3-1157 [Ajax] Hitachi HDT725032VLA360 320GB SATA-II.
Assistant: 2.3-1157. Backup: Thermaltake N0012US w/320GB WD SATA-II drive.
Set Two: ESATA case RoseWill RX353-S WD 1TB and WD 1TB USB2.
Synology: DS-101,2.01-0371 Maxtor DiamondMax-9 160GB IDE.
Backup: USB Ext. case/fan UltraProducts ULT31310 & Maxtor DiamondMax-9 160GB IDE.

User avatar
Franklin
Synology Inc
Synology Inc
Posts: 6662
Joined: Sat Oct 14, 2006 11:33 pm
Location: Washington, USA

Unread post by Franklin » Fri Jan 11, 2008 2:47 am

Kenny-M

I'm not sure if you are conferring with our support team or not (I believe you still have active tickets regarding your DOS network) but I would let them see this log and see if they can provide any suggestions.

Hope this helps.
**Franklin is not available**
**Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!**
Library ~ SynologyWiki ~ Synology FAQ ~ Compatibility Lists
Forum Links ~ Forum Policy ~ 3rd-party forums ~ Help us help you ~ Posting Images
Demo Links ~ DSM GUI ~ Photo Station
Downloads ~ Firmware Downloads ~ Beta Program
Support ~ Support Form ~ Submit Kernel ~ Synology eNews

User avatar
Kenny-M
Experienced
Experienced
Posts: 132
Joined: Sat Oct 28, 2006 4:00 pm
Location: Connecticut

Unread post by Kenny-M » Fri Jan 11, 2008 2:33 pm

Franklin,

Yes. I spoke with Leon who advises me for now to power up DS-107+ unit and wait for it to come ready then power up external USB drive. That did work.

However, I purchased a RoseWill Ext SATA/USB case/fan model RX353-S and installed a Hitachi 320GB SATA-II drive and connected to DS-107+ using an eSATA cable. This arrangement does not have the same symptons. Strangely enough local backups do not run that much faster then a USB 2.0 external drive.

Thank you for asking. I worked with Adair. The DOS issue had to be abandonded. Backing the DS-101 down from 0371 to 0240 resulted in directory function displaying correctly under DOS but made my existing backup USB external drives unreadable by the DS-101! So, I went back to 0371 and will work around the directory display issue (ignore it).

-Ken
------------
Synology: DS-107+,2.3-1157 [Ajax] Hitachi HDT725032VLA360 320GB SATA-II.
Assistant: 2.3-1157. Backup: Thermaltake N0012US w/320GB WD SATA-II drive.
Set Two: ESATA case RoseWill RX353-S WD 1TB and WD 1TB USB2.
Synology: DS-101,2.01-0371 Maxtor DiamondMax-9 160GB IDE.
Backup: USB Ext. case/fan UltraProducts ULT31310 & Maxtor DiamondMax-9 160GB IDE.

cmale
Beginner
Beginner
Posts: 26
Joined: Wed Dec 19, 2007 7:41 am

Unread post by cmale » Sat Jan 12, 2008 11:21 am

I find using eSATA about 20% quicker than USB. That 20% helps when you are backing up 1tb!!!.

cam

User avatar
Kenny-M
Experienced
Experienced
Posts: 132
Joined: Sat Oct 28, 2006 4:00 pm
Location: Connecticut

Unread post by Kenny-M » Sat Jan 12, 2008 1:31 pm

Cam

You are correct. After checking the backup logs I was wrong.

Backup to SATA example 200GB 15:42 - 19:28
Backup to USB example 200GB 09:45 - 14:07

I stand corrected.

Thanks,
Ken
------------
Synology: DS-107+,2.3-1157 [Ajax] Hitachi HDT725032VLA360 320GB SATA-II.
Assistant: 2.3-1157. Backup: Thermaltake N0012US w/320GB WD SATA-II drive.
Set Two: ESATA case RoseWill RX353-S WD 1TB and WD 1TB USB2.
Synology: DS-101,2.01-0371 Maxtor DiamondMax-9 160GB IDE.
Backup: USB Ext. case/fan UltraProducts ULT31310 & Maxtor DiamondMax-9 160GB IDE.

Locked

Return to “Firmware 518 for x07, x06, DS-101j Models”