Windows Explorer not seeing all files & subfolders

All questions regarding using our system with Windows XP, Vista, 7 may go here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form: ... p?lang=enu

2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
I'm New!
I'm New!
Posts: 9
Joined: Thu Nov 11, 2010 1:11 pm

Windows Explorer not seeing all files & subfolders

Unread post by acee3 » Sat Mar 17, 2012 12:59 pm

DS410 in JBOD, running DSM 3.2. Win7 x64 desktop (and x32 laptop).

The DS has been functioning more or less normally since last year, basically being used as a media repository to feed multiple media players via DLNA and SMB. Shares / mappings are set up ok, and I can browse all content via the media players & Win Explorer.

Recently, I copied over about 75gb of media to the DS via the eSATA port, using DSM. Files (and subfolders) were added to an existing folder.

Everything seemed ok, as I was seeing the newly copied files/folders in DSM, and when accessed via SMB on my various media players (linux based).

However, I just tried to view them via a mapped share on the desktop and laptop, and none of the newly copied files/folders are visible. There doesn't appear to be any permission issue, in DSM the main directory & all subfolders are full R/W as demonstrated by the media players, however Windows Explorer just refuses to see them. I'll see everything that was there before that import session, but nothing that was added is showing in Windows. The weird thing is that Windows Explorer is seeing the proper size of that main directory when I check properties, but just not able to see any of the subfolders or files.

Have tried deleting & remapping the shares on both Windows devices, double checked permissions in DSM (which are applied to all the subfolders), but can't seem to correct this.

Any ideas?

Post Reply

Return to “Windows OS”