Getting Windows 10 laptop ID mapped to one Synology knows

All questions regarding using our system with Windows XP, Vista, 7 may go here.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
Swiss Frank
I'm New!
I'm New!
Posts: 3
Joined: Sat Feb 01, 2014 2:39 am

Getting Windows 10 laptop ID mapped to one Synology knows

Unread post by Swiss Frank » Sat Feb 10, 2018 7:56 am

I have a Synology DS1513+ running DSM5.0-4493 update 1 (a several-year-old OS, but that doesn't seem to be the cause of the question).

I have Windows 7 and 10 laptops mounting that disk, along with a Linux laptop mounting the same area via NFS. Both Windows boxes can read and write, though in places the 10 balks that it doesn't have permission to write (or at least, to delete).

My development account on the Linux box and Synology is user ID 1000.

I'd like my Windows boxes to present that user ID as well so they have full permission to edit everything, create and delete files etc. (I develop software that is intended to work on both OS's so edit and build on both OS's.)

On the Windows 7 box long ago I apparently also set it's user ID to 1000 somehow. When I create a test file via windows share, then look at the file properties, I see the file Owner as MyUser. If I create a similar test file on Win10, properties says the file is user ID 4294967294. How can I change that to 1000?

When I "map network drive" I've tried checking "mount with different credentials," expecting it'd ask me for an alternate user ID, but it doesn't seem to ever query WHAT different credentials to use.

I've also tried net use V: \\diskstation\volume1\MyDisk MyPassword /USER:SynologyUserName and am told:

You can't connect to the file share because it's not secure. This
share requires the obsolete SMB1 protocol, which is unsafe and could
expose your system to attack. Your system requires SMB2 or higher. For
more info on resolving this issue, see:
https://go.microsoft.com/fwlink/?linkid=852747
I've also tried going to Control Panel\User Accounts\Credential Manager\Add a Windows Credential, and typing the share \diskstation\volume1\MyDisk, MyUser, and MyPassword. Upon OK:

This information cannot be
saved. Make sure all the information is correct and that all required fields are completed.

Error code: 0x80070057
Error Message: The parameter is incorrect.
I've also tried share as simply diskstation. Upon OK, it is accepted, and appears on Control Panel\User Accounts\Credential Manager as "diskstation" under Windows Credentials. But then I unmount and remount the share, try creating a file, and the UID is still 4294967294, not the 1000 of the name of the credential I created.

I've also googled for "map synology user ID." Not finding anything useful.

I've ssh'd in and did find from / for any config files with samba in the name and don't find anything. (Well, two tiny files, but don't seem to be samba.conf or anything for mapping users.)

I've also searched systematically through the synology's control panel over the http interface and nothing.

Locked

Return to “Windows OS”