Can't login to DS through SMB on Windows

All questions regarding using our system with Windows XP, Vista, 7 may go here.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
fahid
I'm New!
I'm New!
Posts: 1
Joined: Sun Jan 28, 2018 7:46 am

Can't login to DS through SMB on Windows

Unread post by fahid » Sun Jan 28, 2018 8:12 am

Hello everyone,

Normally I am a user of QNAP but recently purchased a Synology for usage as private Mail Server (Mail Station), but as Synology has 3TB in RAID1, I though why not use it for data as well. But when I try to brows to DS, I get Authentication error, even I have tried multiple times and for a fact I know my credentials were correct at least most of time.

One important thing however is that Synology DS connects to LDAP Server on my QNAP NAS.
- all LDAP users can login to DS via web browser and Mail/Webmail/IMAP/SMTP, through web browser everything works fine. but when I try to brows DS from Windows through SMB, I get error. SMB (SMB1 to SMB3) is enable in DS. When I brows to \\DS or \\192.168.1.XX, I see a login prompt. I enter the login credentials and get an Authentication Error.

I tried with LDAP user as username:password, username@domain.tld:password, but failed in both cases.
I though maybe LDAP/Domain user can't access SMB so I tried with DS Local users, same problem, Authentication Failure, hell I even tried with DS-Administrator account but same error.

I enabled Local Master Browser under DS-CP > File Services > SMB/AFP/NFS > SMB > Advanced Settings
No Help

I created a Network Share with name Public and set its permissions to RW for everyone, including guest.
No Help

Synology Assistnt finds DS and when I try to map Drive from there, it asks for credentials, but returns the that Password is wrong. At least through Synology Assistant I know that if I try with LDAP users with domain (@domain.tld), it says user not found, but when I user user@domain.tld, I get Password error, but it is the same with LDAP or local users.


What am I missing or why isn't it working the way it should?
please help.


It is a DS212+ (2Ghz CPU, 512MB RAM) with DSM 6.1.4-15217 Update 5

lorandd
I'm New!
I'm New!
Posts: 2
Joined: Fri Dec 26, 2014 1:57 pm

Re: Can't login to DS through SMB on Windows

Unread post by lorandd » Mon Feb 26, 2018 5:12 pm

Same issue here. It works with afp://

phealey
I'm New!
I'm New!
Posts: 2
Joined: Wed Sep 09, 2015 5:22 am

Re: Can't login to DS through SMB on Windows

Unread post by phealey » Fri Mar 02, 2018 11:53 pm

Yes, i've had the issue since the last few updates, didnt notice the issue until a reboot of the NAS.

AlBundy
I'm New!
I'm New!
Posts: 9
Joined: Sun Sep 17, 2017 5:56 pm

Re: Can't login to DS through SMB on Windows

Unread post by AlBundy » Wed Apr 04, 2018 6:56 pm

I experienced the same problem today. :-/

After switching from SMB1 to SMB2 in DSM I was abloe to login.

Al

Locked

Return to “Windows OS”