"The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

All questions regarding using our system with Windows XP, Vista, 7 may go here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://account.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
jwsg
I'm New!
I'm New!
Posts: 2
Joined: Tue Sep 11, 2012 7:32 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby jwsg » Thu Nov 23, 2017 11:42 pm

I've had the problems above - first the directory name error which seems fixed - but also the crashes on Word and Excel - infarct I lost a fair bit of work on a first save in Excel which doesn't seem to keep the same incrementals as Word

Probably one of the worst problems I've seen in many years of Synology ownership - just a simple home user so no need for the endless list of enhancements that appear in each release - I'd settle for reliability and a simple interface as I have a low end model.
aleilmago
Trainee
Trainee
Posts: 17
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby aleilmago » Fri Nov 24, 2017 6:57 am

Hello everyone.

If you can (and if you haven't already done) please inform Synology Support about this problem.

I have already written them several e-mails about the problem of saving, but, in my opinion, they must have more cases to understand the source of this problem.

Until now I have found only two temporary solutions to fix:
1. execute "Clear SMB Cache" on DSM after every user logon (if the user disconnects himself, the problem returns): obviously this is impossible with hundreds users
2. enable again "SMBv1 Client" option in MS Windows 10 1709

Best regards.
Alessandro
stipman
I'm New!
I'm New!
Posts: 2
Joined: Fri May 13, 2016 4:13 am

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby stipman » Mon Nov 27, 2017 11:28 pm

I'm running Microsoft Windows [Version 10.0.16299.64] (you can just type ver at the command prompt)

My fix was this:

Update the following registry key in Windows 10:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
Change AllowInsecureGuestAuth from 0 to 1

No reboot/logoff necessary. Change was immediate and satisfying :-)

The registry key did not exist in Microsoft Windows [Version 10.0.15063] on my other computer which still worked properly.
dethknite
Trainee
Trainee
Posts: 10
Joined: Mon Aug 12, 2013 10:36 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby dethknite » Tue Nov 28, 2017 4:09 pm

I have disabled transport encryption and it helps a bit, but I still have to clear the SMB cache about every day or two days. Can we get a fix for this? Super annoying..

* running on the latest beta DSM 6.2-22259...
jefftiger
I'm New!
I'm New!
Posts: 4
Joined: Sun Nov 05, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby jefftiger » Tue Nov 28, 2017 5:14 pm

As noted by some earlier posters, this problem (i.e., "The directory name is invalid") was addressed with the latest 6.1.4 release. The initial 6.2 beta does not include the fix for this. So, those of us (like me) running the 6.2 beta are still waiting for this fix, which hopefully will be included in the next 6.2 beta update.
ZataH
I'm New!
I'm New!
Posts: 1
Joined: Sun May 11, 2014 6:44 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby ZataH » Tue Nov 28, 2017 8:23 pm

I am also on 6.2 beta :( So no update for me

The regedit fix didnt work. Only thing that semi works, seems to be the clear smb cache.

Please get a fix out soon
bensonmcmoran
I'm New!
I'm New!
Posts: 6
Joined: Thu Aug 11, 2011 12:17 am

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby bensonmcmoran » Fri Dec 01, 2017 2:29 pm

I've been working with Synology's support regarding the saving/crashing issue with Microsoft Office 2016.
According to Synology's support, they confirmed with their development team that this issue is a known issue and is supposed to be resolved in DSM6.1.5 (Not Yet Released).
Support described the issue as after the Windows update which disables SMB 1.0, the NAS may think it is negotiating with a MacOSX client, and provides less info than is needed for Windows.
aleilmago
Trainee
Trainee
Posts: 17
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby aleilmago » Fri Dec 01, 2017 9:15 pm

Benson,
I have also worked with Synology Support about this problem and they also wrote me about the next release 6.1.5 to solve the problem.

But please note this point that I have already written to Synology Support: on all my clients with MS Windows 10 1703 I had already disabled the SMBv1 Protocol and I hadn't problems for months.
After MS Windows 1709 and DSM 6.1.4, I began to have the saving problem on all my clients.
So I'm not so sure that the reason is only due to SMBv1 on the Windows side.

So we have to wait 6.1.5 to have the final response. :wink:

Best regards.
Alessandro
bensonmcmoran
I'm New!
I'm New!
Posts: 6
Joined: Thu Aug 11, 2011 12:17 am

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby bensonmcmoran » Fri Dec 01, 2017 9:45 pm

Alessandro,

I agree that what is actually causing the problem may be some what unclear.
However if Synology is aware of the issue and intends to fix it then I would like to think that they can reproduce the issue and figure out exactly what the problem is so that it can be properly addressed.
You are right though, we won't know for certain until the next DSM release.
jameshurrell
I'm New!
I'm New!
Posts: 7
Joined: Sat Jan 29, 2011 11:23 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby jameshurrell » Wed Dec 06, 2017 3:04 pm

I wanted to add my experience with this to the thread:

Situation: 6 x Windows 10 1703 + Office 2016, with SMBv1 client and server disabled manually on all PCs. SMB1 server disabled on Synology, set to SMB2 min and SMB3 max. These had been working fine with a Synology DS216+11 for many months.

- Windows self updates from 1703 to 1709 some time in the last couple of weeks.
- NAS still on 6.1.3-15152-8
- Users start complaining about the first bug - invalid path to file or folder when accessing files on the NAS - workaround was to right click files and select "open with", but this did not work for all.
- Cleared this issue by rebooting the NAS or clearing the SMB cache on the NAS (i.e. restarting the network stack), but problem re-occurs when Win 10 machine either reboot or the network stack is somehow restarted.
- Version: 6.1.4-15217-1 is then installed on NAS and for two whole days, no issue - I don't know whether they weren't accessing files in this time though.
- Now users are complaining of the second bug "Excel 2016 crashing when attempting to save files on the NAS".
- Searching forums leads me to this thread and also https://community.spiceworks.com/topic/ ... work-share.
- So now I am waiting for firmware 6.1.5 for a potential fix. Note that I have not installed Version: 6.1.4-15217-2 - which fixes Samba vulnerabilities.
- In the meantime I will reluctantly re-enable SMB1 client on all PCs to hopefully get around this....

The PCs and NAS are in the UK, so not related to Italian version of Office. From what I see, this is purely something Microsoft changed in 1709.
marmite
Trainee
Trainee
Posts: 19
Joined: Wed Apr 05, 2017 4:21 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby marmite » Thu Dec 07, 2017 12:38 pm

Same here
Excel 2016 crashing on saving file to the NAS (any file)
Leaving TMP files behind.

Only just reported to me - 25 users - and NAS running 614 update 2 (for a week) - and all Windows 1709 - but have been for a month (!).

Only one user reporting issue, and said "PC updated last night" - so that is either Office 2016 (365 business premium) or Windows - lol - who knows.

But wondering if any more updates/fixes - as this thread seems old for what is a serious user issue?
jameshurrell
I'm New!
I'm New!
Posts: 7
Joined: Sat Jan 29, 2011 11:23 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby jameshurrell » Thu Dec 07, 2017 2:56 pm


I've read that too - however, on my Synology, SMB1 is already disabled in DSM (SMBv2 = minimum and SMBv3 = maximum) and my users still have the issue, so I think that article is misleading to claim that the issue can be fixed by doing that. I suspect that when the blogger modifyied the SMB options in DSM this caused the SMB service to be restarted, thus making the issue go away - until the PC reboots when it will come back.

The only real 'fixes' to this issue is either to restart the SMB service on the NAS (but this 'fix' will only work until the PC reboots), or to re-enable SMBv1 on the Windows 10 PC (not sure if it is just the client service that is required or whether the server service also needs to be enabled). The second 'fix' is not a permanent 'fix' in my opinion though as it defeats the whole reason why I manually disabled SMBv1 on both Windows 10 and the Synology in the first place - security.

Synology are apparently aware of this issue and a fix has been mentioned in DSM 6.1.5....which hopefully when applied will mean I can re-disable SMBv1 on the PCs.
Last edited by jameshurrell on Thu Dec 07, 2017 3:13 pm, edited 2 times in total.
marmite
Trainee
Trainee
Posts: 19
Joined: Wed Apr 05, 2017 4:21 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby marmite » Thu Dec 07, 2017 3:00 pm

Thanks for that.

I've only got 1 user at 1 customer site reporting it (out of 25 on that site), so not sure on the difference between him and the rest. All are on 1709

The NAS is set to allow SMB1 so that needs looking at - maybe historic due to scan-to-file. But will address that.

User too busy to do tests so not sure whats going on yet.
aleilmago
Trainee
Trainee
Posts: 17
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby aleilmago » Sun Dec 10, 2017 3:48 pm

James,
your post is the perfect summary/timeline of this problem.

Marmite,
a possible reply: maybe the only one user (who has the problem) has the SMBv1 Client disabled, while the others have the SMBv1 Client enabled.

So we are all waiting the next release 6.1.5 to solve this problem.

Best regards,
Alessandro

Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 1 guest