"The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

All questions regarding using our system with Windows XP, Vista, 7 may go here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
delineator
I'm New!
I'm New!
Posts: 3
Joined: Thu Oct 12, 2017 9:00 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby delineator » Mon Nov 13, 2017 8:26 pm

aleilmago wrote:Hello.

New problem after the new release 6.1.4 has solved the problem about "The directory name is invalid".

Now I have new problem on all the clients with MS Windows 10 1709 (Fall Creators Update): when I open an .xlsx or .docx with MS Excel 2016 and MS Word 2016 (latest patch release 8625.2121) and I save the files, the two programs crash immediately with the message "Microsoft Word/Excel has stopped working". The files are not saved and .tmp files appear in the shared folder (one .tmp for every saving attempt).

Any idea?

Thank you.
Best regards.
Alessandro

This! Applied updated last week, however, getting this error this morning (albeit with SketchUp files, not word files). Seems to apply only to me, as all our other workstations don't have Fall Creators update yet. Just cleared SMB cache again, so we'll see if thats a temporary fix for now.
necrosis
Experienced
Experienced
Posts: 105
Joined: Sat Jun 16, 2012 6:20 am

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby necrosis » Tue Nov 14, 2017 5:35 am

Running the new: DSM 6.1.4-15217 Update 1

Havent seen the issue yet with transport encryption set to forced <knock on wood>.
DS1812+ (DSM 6.1.4-15217 Update 1) 8x Samsung HD203WI {2TB} - RAID6 {10.72TB}
    DX510 5x Seagate ST33000650NS {3TB} - SHR [1 Drive] {10.73TB}
    DX510 5x Seagate ST33000650NS {3TB} - SHR [1 Drive] {10.73TB}
APC Back-UPS Pro 1500 160w Load {20%} 36min
aleilmago
Trainee
Trainee
Posts: 17
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby aleilmago » Tue Nov 14, 2017 7:16 am

Hello.

Only a clarification: two problems are different, but probably linked.

The first ("The directory name is invalid" after the update to MS Windows 10 1709) has been solved with new release DSM 6.1.4-15217 Update 1 (or also DSM 6.1.4-15217).

The second (problems to save with MS Word/Excel 2016 on SMB network shares) is also appearead after MS Windows 10 1709, but has not been solved by DSM 6.1.4-15217 Update 1.

The temporary workaround ("Clear SMB Cache") works for both problem, but it's not a good solution, because it must be applied after every restart of the workstations.

Necrosis, your setting on transport encryption solves the first, the second or both the problems? Have you already tried to restart the workstations after this setting?

Thank you.
Regards.
Alessandro
necrosis
Experienced
Experienced
Posts: 105
Joined: Sat Jun 16, 2012 6:20 am

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby necrosis » Tue Nov 14, 2017 9:02 pm

I havent tried restarting the computer and trying again since turning encryption back on. Will tonight when I head home (in another 2 hours or so).

I dont have word on my home computer to test but ill take my work laptop home which is running FCU and has full office.
DS1812+ (DSM 6.1.4-15217 Update 1) 8x Samsung HD203WI {2TB} - RAID6 {10.72TB}
    DX510 5x Seagate ST33000650NS {3TB} - SHR [1 Drive] {10.73TB}
    DX510 5x Seagate ST33000650NS {3TB} - SHR [1 Drive] {10.73TB}
APC Back-UPS Pro 1500 160w Load {20%} 36min
aleilmago
Trainee
Trainee
Posts: 17
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby aleilmago » Wed Nov 15, 2017 10:31 am

Hello.

"kush", "Dark345" and "pcmauro", what is your actual situation about the saving problem with MS Word/Excel?

I have updated MS Windows 10 1709 with the last patches and my Synologys with the last patch (6.1.4-15217-1), but I still have the problem.

The only solution is to "Clear SMB Cache" after every restart of the workstations.

Regards.
Alessandro
pcmauro
Beginner
Beginner
Posts: 20
Joined: Wed Sep 28, 2011 5:18 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby pcmauro » Wed Nov 15, 2017 12:51 pm

aleilmago wrote:Hello.

"kush", "Dark345" and "pcmauro", what is your actual situation about the saving problem with MS Word/Excel?

I have updated MS Windows 10 1709 with the last patches and my Synologys with the last patch (6.1.4-15217-1), but I still have the problem.

The only solution is to "Clear SMB Cache" after every restart of the workstations.

Regards.
Alessandro


Just tried after montly patch tuesday (both Win10 1709 and Office2016) and the issue is still happening. I have to enable SMB1/CIFS on Win10 to get rid of it.
aleilmago
Trainee
Trainee
Posts: 17
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby aleilmago » Wed Nov 15, 2017 3:07 pm

Grazie pcmauro for your reply.

I have already written to Synology Support Service to underline this problem: unfortunately to enable SMB1.0 is not a permanent and secure solution.

"delineator", what is your situation now about this problem?

I'm quite sure that is linked to the update of MS Windows 10 1709 (with SMB1.0 disable) and probably to something on DSM, because it's very strange that after "Clear SMB Cache" all is perfect until the next restart.

Thank you.
Regards.
Alessandro
delineator
I'm New!
I'm New!
Posts: 3
Joined: Thu Oct 12, 2017 9:00 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby delineator » Wed Nov 15, 2017 3:18 pm

aleilmago wrote:Grazie pcmauro for your reply.

I have already written to Synology Support Service to underline this problem: unfortunately to enable SMB1.0 is not a permanent and secure solution.

"delineator", what is your situation now about this problem?

I'm quite sure that is linked to the update of MS Windows 10 1709 (with SMB1.0 disable) and probably to something on DSM, because it's very strange that after "Clear SMB Cache" all is perfect until the next restart.

Thank you.
Regards.
Alessandro

Still in the same boat - I'm the only one in my office running FCU, and I need to clear SMB cache everyday or else Sketchup (the program I mostly use) crashes when I try to save. After I clear the smb cache, problem gone. I'm currently on DSM 6.1.4-15217
Dark345
I'm New!
I'm New!
Posts: 5
Joined: Sun Nov 05, 2017 7:32 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby Dark345 » Thu Nov 16, 2017 7:26 pm

still experiencing the issue of MS EXCEL/WORD crashing... :(
aleilmago
Trainee
Trainee
Posts: 17
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby aleilmago » Fri Nov 17, 2017 6:59 am

Hello.

As "pcmauro" wrote, the only temporary solution is to enable "SMB1.0 Client" on MS Windows 10 1709.

As you can read in this forum, the problem is also with other software, not only MS Word/Excel.

I wrote to Synology Service Support to understand why, after 1709 upgrade, we must enable "SMB1.0 Client" if the minimun SMB protocol on DSM is SMB2.0 or SMB3.0.

Regards.
Alessandro
aleilmago
Trainee
Trainee
Posts: 17
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby aleilmago » Fri Nov 17, 2017 9:09 am

Hello.

Unfortunately I must deny my previous post!

This morning, with "SMB1.0 Client" enable, all the clients with MS Windows 10 1709 has the same problem on the Synology SMB Shares.

Regards.
Alessandro
anvu2407
I'm New!
I'm New!
Posts: 3
Joined: Sat Nov 11, 2017 3:21 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby anvu2407 » Fri Nov 17, 2017 4:16 pm

well i thought:
1/ my synology files are corrupted
2/ my network hubs are failing
3/ my cables are failing

now this :)

btw, i replaced my switch and cable, since restarting the switch helps..for 30 mins
Embattle
Student
Student
Posts: 70
Joined: Mon Sep 15, 2008 10:29 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby Embattle » Fri Nov 17, 2017 5:59 pm

I just got this problem when trying to play a video file which is on my NAs via File explorer.

If I use Open With VLC it goes into VLC and comes up with warnings "File reading failed:
VLC could not read the file (Bad file descriptor)."

Seems the earlier Disable "transport encryption mode" fix sorted mine for the moment.
DS1815+ - 6 x 3TB ST3000VN000 (RAID 6)
Embattle
Student
Student
Posts: 70
Joined: Mon Sep 15, 2008 10:29 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby Embattle » Sat Nov 18, 2017 9:01 am

Seems in between the shutdown last night and startup today the issue has reappeared.
DS1815+ - 6 x 3TB ST3000VN000 (RAID 6)
pcmauro
Beginner
Beginner
Posts: 20
Joined: Wed Sep 28, 2011 5:18 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Postby pcmauro » Thu Nov 23, 2017 9:31 pm

Updated to 6.1.4 update 2 which adresses Samba security issues but again problems with Excel saving files and crashing.

Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 3 guests