"The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

All questions regarding using our system with Windows XP, Vista, 7 may go here.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
Dark345
I'm New!
I'm New!
Posts: 9
Joined: Sun Nov 05, 2017 7:32 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by Dark345 » Sun Nov 05, 2017 7:36 pm

kipik wrote:no need to enable SMB1 again. Stay on SMB2 at minimum and keep your system safe:

- go onto SMB/ Advanced settings (using smb2 / SMB3) Disable "transport encryption mode" . Probelm solved.

check when you can re-enable as soon fix has been released.
Hi, experiencing the same issue here. Your fix seems to be partially risolutive, because the problem happens again but very less frequently.

I hope in a patch soon. Not a defintely good experience for 1st time buying a Synology...

jefftiger
I'm New!
I'm New!
Posts: 5
Joined: Sun Nov 05, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by jefftiger » Sun Nov 05, 2017 7:44 pm

Sorry, that didn't work for me. On reboot of Windows 10, I again see "The directory name is invalid" message. It appears that you can change any of the settings in Advanced Settings and the Synology box will reset the network. This cures the problem until the next Windows box reboot.

Hopefully, someone (Synology or Microsoft) will come up with a solution soon.

kipik
Beginner
Beginner
Posts: 20
Joined: Tue Dec 15, 2015 7:53 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by kipik » Mon Nov 06, 2017 8:13 pm

jefftiger wrote:Sorry, that didn't work for me. On reboot of Windows 10, I again see "The directory name is invalid" message. It appears that you can change any of the settings in Advanced Settings and the Synology box will reset the network. This cures the problem until the next Windows box reboot.

Hopefully, someone (Synology or Microsoft) will come up with a solution soon.
True, this fix does not seem to survive a reboot. let's wait MSFT or Syno fix the issue. AFAIK dont know where the issue comes from yet, both actors seem to have identified the issue though.
DS 716+ (8GB RAM) + DX213 - RAID 10 /6TB BTRFS (4*WD RED 3 TB)
Proper Raid 10 with Expansion Units : https://forum.synology.com/enu/viewtopic.php?f=7&t=115462&p=426512#p426512

kipik
Beginner
Beginner
Posts: 20
Joined: Tue Dec 15, 2015 7:53 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by kipik » Mon Nov 06, 2017 8:20 pm

Dark345 wrote:I hope in a patch soon. Not a defintely good experience for 1st time buying a Synology...
Quite exceptional, don't worry you have made a good choice !
DS 716+ (8GB RAM) + DX213 - RAID 10 /6TB BTRFS (4*WD RED 3 TB)
Proper Raid 10 with Expansion Units : https://forum.synology.com/enu/viewtopic.php?f=7&t=115462&p=426512#p426512

Stanzilla
I'm New!
I'm New!
Posts: 2
Joined: Fri Oct 03, 2014 7:03 am

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by Stanzilla » Tue Nov 07, 2017 12:13 pm

I got offered Version: 6.1.4-15217 today, about to install it. Anyone tested and knows if it contains a fix yet?

It lists
Enhanced the compatibility of Windows AD and NFS protocol.
in the changelog so I am hopeful.

Dark345
I'm New!
I'm New!
Posts: 9
Joined: Sun Nov 05, 2017 7:32 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by Dark345 » Tue Nov 07, 2017 9:24 pm

I have just tried it and it seems to be fixed!

kipik
Beginner
Beginner
Posts: 20
Joined: Tue Dec 15, 2015 7:53 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by kipik » Wed Nov 08, 2017 2:19 pm

Stanzilla wrote:I got offered Version: 6.1.4-15217 today, about to install it. Anyone tested and knows if it contains a fix yet?

It lists
Enhanced the compatibility of Windows AD and NFS protocol.
in the changelog so I am hopeful.
The issue has nothing to do with Windows AD nor NFS. Both can be deactivated and user can still experience the issue, which seem to be related to an evolution/Fix on the windows build and a bug on the samba package deployed on previous syno OS build.I have noted that Samba package has been updated from 4.4.13 to 4.4.16 with new 6.1.4 version.

But i agree with your statement that following the update to 6.1.4-15217, issue seems to be fixed.

https://www.samba.org/samba/history/samba-4.4.16.html
DS 716+ (8GB RAM) + DX213 - RAID 10 /6TB BTRFS (4*WD RED 3 TB)
Proper Raid 10 with Expansion Units : https://forum.synology.com/enu/viewtopic.php?f=7&t=115462&p=426512#p426512

SR71black
I'm New!
I'm New!
Posts: 3
Joined: Mon Oct 23, 2017 10:23 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by SR71black » Thu Nov 09, 2017 4:59 am

The latest firmware update fixed the issue for us, and the fix is permanent, it sticks after a Windows reboot. Thanks, Synology!

aleilmago
Beginner
Beginner
Posts: 20
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by aleilmago » Thu Nov 09, 2017 8:52 pm

Hello.

New problem after the new release 6.1.4 has solved the problem about "The directory name is invalid".

Now I have new problem on all the clients with MS Windows 10 1709 (Fall Creators Update): when I open an .xlsx or .docx with MS Excel 2016 and MS Word 2016 (latest patch release 8625.2121) and I save the files, the two programs crash immediately with the message "Microsoft Word/Excel has stopped working". The files are not saved and .tmp files appear in the shared folder (one .tmp for every saving attempt).

Any idea?

Thank you.
Best regards.
Alessandro

orum
I'm New!
I'm New!
Posts: 2
Joined: Sat Nov 08, 2014 4:11 am

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by orum » Fri Nov 10, 2017 9:40 pm

I am not seeing 6.1.4 for my 1812+ yet. I had to re-enable SMBv1 (just did client only) to resolve this issue for now.

Dan

pcmauro
Beginner
Beginner
Posts: 21
Joined: Wed Sep 28, 2011 5:18 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by pcmauro » Sun Nov 12, 2017 1:03 am

aleilmago wrote:Hello.

New problem after the new release 6.1.4 has solved the problem about "The directory name is invalid".

Now I have new problem on all the clients with MS Windows 10 1709 (Fall Creators Update): when I open an .xlsx or .docx with MS Excel 2016 and MS Word 2016 (latest patch release 8625.2121) and I save the files, the two programs crash immediately with the message "Microsoft Word/Excel has stopped working". The files are not saved and .tmp files appear in the shared folder (one .tmp for every saving attempt).
Exactly same issue here...Alessandro, I'm also from Italy..it might be something about italian localization of excel or DSM?

DSM 6.2 beta still has the same issue as the 6.1.3.

Dark345
I'm New!
I'm New!
Posts: 9
Joined: Sun Nov 05, 2017 7:32 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by Dark345 » Sun Nov 12, 2017 11:14 am

Same problem here. But it's not related to Excel/Word only...
Alessandro, I'm also from Italy..
ciao io pure

aleilmago
Beginner
Beginner
Posts: 20
Joined: Fri Jan 20, 2017 7:39 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by aleilmago » Sun Nov 12, 2017 11:23 am

Hello. (Buongiorno a tutti! :wink:)

I don't know if the problem is only related to Synology DSM or also to MS Windows 1709 update.

Please read on reddit(dot)com the article "Windows 10 1709 + Office Suite 2016" (published two days ago).

I can temporarily solve the problem running "Clear SMB Cache" in the SMB "Advanced Settings" on DSM: but this method only survives until the reboot of the clients (so I must run this command every morning).
The same temporary solution of the previous problem "The directry name is invalid".

Best regards.
Alessandro

Mike Rubin
Trainee
Trainee
Posts: 16
Joined: Sat Mar 19, 2016 3:13 am

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by Mike Rubin » Sun Nov 12, 2017 7:28 pm

aleilmago wrote:Hello. (Buongiorno a tutti! :wink:)

I don't know if the problem is only related to Synology DSM or also to MS Windows 1709 update.

Please read on reddit(dot)com the article "Windows 10 1709 + Office Suite 2016" (published two days ago).

I can temporarily solve the problem running "Clear SMB Cache" in the SMB "Advanced Settings" on DSM: but this method only survives until the reboot of the clients (so I must run this command every morning).
The same temporary solution of the previous problem "The directry name is invalid".

Best regards.
Alessandro
Thank you so much for posting this. Using this workaround, I finally was able to run a backup that I could not complete because the "directory name is invalid" error prevented my backup application from reading the source directories.

kush
Rookie
Rookie
Posts: 31
Joined: Mon Feb 23, 2015 4:36 pm

Re: "The directory name is invalid" after fall creators update on Synology share with uninstalled SMBv1

Unread post by kush » Mon Nov 13, 2017 7:14 am

Just started experiencing this now with my DS1817. It's really annoying, On DSM 6.1.3-15152 Update 8. 6.1.4 is not available for me yet.

Locked

Return to “Windows OS”