916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

All questions regarding using our system with Windows XP, Vista, 7 may go here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://account.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
sieberta
Sharp
Sharp
Posts: 195
Joined: Sun Feb 22, 2015 2:59 pm

916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby sieberta » Mon Jun 05, 2017 3:51 pm

I have a recently configured 916+ on the latest version of 6.1 (Update 4). Clients report occasionally loosing CIFS/SMB connectivity to the NAS. This shows itself by explorer closing the window if open to a mapped drive and briefly putting a red x on the mapped drives. Simply clicking the drive again allows it to open again, but obviously annoying as you lose your spot.

I was running a 415+ before and didn't have this issue... here is what else changed besides the model:
Synology Active Directory in Use
Synology DHCP in Use
Synology DNS in Use

sieberta
sieberta
---------
Devices: DS415+ (2014), DS216+II (2016), DS916+ (2017)
Public Service Announcement: Please do not rely on RAID as "backup"... at minimum buy a cheap USB 3.0 HDD and use Hyper Backup...
sieberta
Sharp
Sharp
Posts: 195
Joined: Sun Feb 22, 2015 2:59 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby sieberta » Mon Jun 05, 2017 4:48 pm

I have determined that machines do not lose connectivity simultaneously. The drops/reconnects cannot be found in the windows error logs.

sieberta
sieberta
---------
Devices: DS415+ (2014), DS216+II (2016), DS916+ (2017)
Public Service Announcement: Please do not rely on RAID as "backup"... at minimum buy a cheap USB 3.0 HDD and use Hyper Backup...
sieberta
Sharp
Sharp
Posts: 195
Joined: Sun Feb 22, 2015 2:59 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby sieberta » Mon Jun 05, 2017 5:25 pm

Still testing, but I actually think this may have been a result of Group Policy auto Refresh on the Win 10 clients. The drive mapping was written as "replace". I've changed it to "create" and am hopeful...

sieberta
sieberta
---------
Devices: DS415+ (2014), DS216+II (2016), DS916+ (2017)
Public Service Announcement: Please do not rely on RAID as "backup"... at minimum buy a cheap USB 3.0 HDD and use Hyper Backup...
ac16161
Trainee
Trainee
Posts: 18
Joined: Sat Jan 30, 2016 4:40 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby ac16161 » Mon Jun 12, 2017 6:23 pm

Random dropping of the SMB connection to my 416play from my Windows 7 PC has just started for me as well, and I'm on update 4. Have never had this issue before, it's very inconvenient as applications relying on continuity of the connection can fail. I have submitted a ticket as nothing has changed on my PC or network environment that would explain this.
sieberta
Sharp
Sharp
Posts: 195
Joined: Sun Feb 22, 2015 2:59 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby sieberta » Tue Jun 13, 2017 12:58 pm

ac16161 wrote:Random dropping of the SMB connection to my 416play from my Windows 7 PC has just started for me as well, and I'm on update 4. Have never had this issue before, it's very inconvenient as applications relying on continuity of the connection can fail. I have submitted a ticket as nothing has changed on my PC or network environment that would explain this.


For me, it had nothing to do with CIFS/SBM services from the disk station, it was all about a group policy I should've configured differently.

I don't have any ideas for you, and you indicated you already submitted a ticket... let us know what you find out please.

sieberta
sieberta
---------
Devices: DS415+ (2014), DS216+II (2016), DS916+ (2017)
Public Service Announcement: Please do not rely on RAID as "backup"... at minimum buy a cheap USB 3.0 HDD and use Hyper Backup...
lucho
I'm New!
I'm New!
Posts: 2
Joined: Tue Jun 20, 2017 3:04 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby lucho » Tue Jun 20, 2017 3:20 pm

I've been dealing with this problem for some days. In our case, it happened exactly 10 hours after the computers were turned on. Nothing in log files showed why this was happening.

Access databases lost connection to the server and logged event 300 (network interrupted). This is how I knew this was happening 10 hours after the machines were turned on.

Checking GPO to look for a 10 hours value, I found out that kerberos service ticket is set to 10 hours by default. I've changed it to 15 hours, which is the time our systems keep connected.

So, it seems connection is lost everytime kerberos service ticket expires. Does anybody know how to avoid this? Is this problem related to ad issues in last DSM updates?

This is happening to all our windows 10 machines (which I was deploying when I realized the problem).
sieberta
Sharp
Sharp
Posts: 195
Joined: Sun Feb 22, 2015 2:59 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby sieberta » Wed Jun 21, 2017 7:14 pm

According to this, Windows only renews certificates when locked. This doesn't describe it, but I would think you could programmatically renew them???
https://lists.samba.org/archive/samba/2014-March/179669.html
sieberta
---------
Devices: DS415+ (2014), DS216+II (2016), DS916+ (2017)
Public Service Announcement: Please do not rely on RAID as "backup"... at minimum buy a cheap USB 3.0 HDD and use Hyper Backup...
lucho
I'm New!
I'm New!
Posts: 2
Joined: Tue Jun 20, 2017 3:04 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby lucho » Wed Jun 21, 2017 7:21 pm

Thanks for the info! Unfortunately, this doesn't seem to work in our environment. All of our users are locked after 15 minutes of innactivity (gpo). They have a 2 hours lunch break so their systems always get locked during the 10/15 hours ticket lifetime. I'll try to find out why the ticket is not renewing...
ac16161
Trainee
Trainee
Posts: 18
Joined: Sat Jan 30, 2016 4:40 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby ac16161 » Wed Jul 19, 2017 9:39 pm

An update on my experience with random drops of SMB connections. Problem started with one of the 6.1.x updates. Tech support have looked at logs and been unable to find a problem. Issue arises when running multi-file batch conversion (e.g. mass audio conversion using dBpoweramp, and never had a problem before). The 6.1.3-15152 update actually made it worse, indeed almost unusable. I tried many things, and in the end going to advanced SMB file service settings in DSM and selecting "Enable SMB2 lease" stopped dBpoweramp file conversions from crashing. I'm not technically savvy enough to know why this might have fixed my problem, or whether it's just a coincidence, but thought I'd share.
an0nimen
I'm New!
I'm New!
Posts: 2
Joined: Tue Sep 03, 2013 3:43 pm

Re: 916+ on DSM 6.1 Dropping CIFS/SMB Connections Randomly

Postby an0nimen » Wed Aug 16, 2017 3:14 pm

Same problem here after i try to delete/copy/move a file on my windows share it freezes for 30 seconds or so while a green bar that normaly simbolises windows search starts to run and my mapped drives dont show any info no free space no nothing and are also unresponsive until that 30-40s time and then everything goes back to normal and completes the action i ren before disconnect. I am running Windows 10 PRO and RS2211+ and the problem also started with one of the recent 6.x updates. It seems like share looses connection or stops responding for abount 30s then it works again until next action from windows on the mapped drives.

EDIT: Enabling "Enable SMB2 lease" like suggested by ac16161 did make the situation much less frequent but it still happens so there seems to be somthing with the samba server that is not agreeing with windows in the latest DSM patch. Big thanx to u ac16161 for the suggestion it seems to be making the problem bit better :)

Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 3 guests