Intermittent Mapped Folders are Lost

All questions regarding using our system with Windows XP, Vista, 7 may go here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://account.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
Occams razor
Trainee
Trainee
Posts: 15
Joined: Thu Dec 06, 2012 10:27 pm

Intermittent Mapped Folders are Lost

Postby Occams razor » Thu May 11, 2017 6:56 pm

Every now and then,my mapped folders have the big red x and won't connect.
The only way I can fix it is.....

1. Go to>Programs/features>turn windows features on/off>UNCHECK SMB 1.0/CIFS File Sharing Support>Reboot
2.Go to>Programs/features>turn windows features on/off>CHECK SMB 1.0/CIFS File Sharing Support>Reboot
3. Things are working again.

This is more of a hassle,since I know how to fix it. Anybody else had this issue or any suggestions on a permanent fix?
Josh
I'm New!
I'm New!
Posts: 1
Joined: Thu Jun 01, 2017 12:15 pm

Re: Intermittent Mapped Folders are Lost

Postby Josh » Fri Jun 02, 2017 12:14 pm

Unfortunately i do not have a fix for this issue but i just wanted to report i am having the issue on a customers network. They have a DS713+ running DSM 6.1.1-15101 Update 4 and the issue occurs on windows 7 computers.

I have tried multiple solutions from the Synology and Microsoft forums but nothing has worked. This issue for our client does seem to fall in line with us disabling smb1 when the wanna-cry outbreak happened so i'm in the process of re-enabling smb1 on one of the windows 7 computer to see if this fixes the issue. Other device on the network running windows 10 don't seem to have this problem with the network drive, so i assume it something to do with windows 7 and smb1.

I have seen a reply in another topic on the forum where someone was having a very similar problem and he outcome was to re-enable smb1 on the computer and everything started working again. Strangely he said when smb1 was re-enabled on the computers and the mapped drives was working he disabled smb1 on the NAS and the mapped drives still worked without any problems.

Like the OP (and many others I guess) the recent WannaCry outbreak lead me to disable SMBv1 clients on all the PCs in my network.

Following that, I found I was no longer able to see the Synology DS215j in the File Explorer of any of the PCs, variously running Windows 10, 8.1 and 7.

I rummaged about in the Synology File Service settings to no avail.

In the end, the only thing that worked was re-enabling SMBv1/CIFS. I did this the easy way in Win10 and 8.1 using the checkbox in 'Programs and Features' section of the Control Panel, and in Win 7 using two sc.exe commands.

So that restored the ability of File Explorer to see the Synology (and a WD NAS too) under the Network folder.

Despite all of the above, I have found that the File Explorer still sees the Synology even though in the Synology File Service 'SMB/Advanced' I have set SMB to Minimum SMB2, Maximum SMB3 - i.e. SMB1 is disabled.

So to my question:
How come I need SMB1 enabled in the client (PCs) even though it is disabled in the Server (Synology)?

PS All PCs are fully patched, so I am not so concerned from the security perspective, more to understand the interaction between SMB client/server versions
Tsynologyuser
I'm New!
I'm New!
Posts: 1
Joined: Thu Jul 27, 2017 1:44 pm

Re: Intermittent Mapped Folders are Lost

Postby Tsynologyuser » Mon Jul 31, 2017 7:26 pm

Hi,

have exactly the same issue , have you resolved yet ?

Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 2 guests