SickBeard: Automatic TV Show Download

See if your 3rd party software (such as backup software) is compatible with our product.
Forum rules
This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
sverzijl
Trainee
Trainee
Posts: 14
Joined: Thu Oct 07, 2010 9:43 pm

Re: SickBeard: Automatic TV Show Download

Postby sverzijl » Fri Dec 17, 2010 12:55 pm

sverzijl wrote:Been trying to get this puppy running on DS207+ but it keeps hanging on "Starting Sick Beard on http://localhost:8081". It doesn't go any further and there's no listener on port 8081 at this time.

I just bought a DS411+ and again tried to install SickBeard. On this box it works perfectly, no issues whatsoever. Also just using the python that was delivered with Merty's SABnzbd package. I was pretty surprised that it worked after the issues on DS207+, but I'm happy ;)
Brickman
Beginner
Beginner
Posts: 23
Joined: Sat Nov 13, 2010 5:23 pm
Contact:

Re: SickBeard: Automatic TV Show Download

Postby Brickman » Sat Dec 18, 2010 9:56 am

tophe323 wrote:
Brickman wrote:The only problem left is that two processes of Sick Beard are still running after the shutdown through the web interface. Has anyone a clue to solve this?


I have the same issue ...
This causes my Synology to not rebooting as it can't kill SB.

Did you solve this issue meanwhile ?

Code: Select all

#
# Temp fix: Kill the left over Sick Beard threats
$DIR/utils/bin/fuser -k $DIR/utils/bin/python >>/dev/null


This is my fix to kill the left over threads, where $DIR/utils/bin/python is your path to the used python executable (e.g. /usr/bin/python).
DS410 / DSM 4.0 2198 / 4x Samsung EcoGreen F4EG (HD204UI)
with APC Back-UPS ES 550G

HowTo for Synology NAS: http://synology.brickman.nl/
gwakamol
I'm New!
I'm New!
Posts: 4
Joined: Sun Dec 26, 2010 6:56 pm

Re: SickBeard: Automatic TV Show Download

Postby gwakamol » Sun Dec 26, 2010 7:39 pm

Hi everybody,

I'm also facing this problem.

I install sabnzb+ with the merty package; and sickbeard as shown in this thread.
At first i was unable to start sickbeard at all, but as soon as i install manualy python py25-cheetah and py25-cherrypy with ipkg, sickbeard start. But without the webinterface...
(nothing on nasip:8081 and with netstat -na | grep 8081)
The log in /opt/share/sickbeard/Logs is empty...

Here is what i see when i start sickbeard manualy :

Code: Select all

NASMultimedia> /opt/bin/python2.5 /opt/share/sickbeard/SickBeard.py &
NASMultimedia> Starting up Sick Beard master from /opt/share/sickbeard/config.ini
19:15:49 INFO::MainThread :: Checking database structure...
19:15:49 INFO::MainThread :: Starting Sick Beard on http://localhost:8081

and here is what i have in the process list :

Code: Select all

NASMultimedia> ps | grep sickbeard
 2123 root     17692 S    /opt/bin/python2.5 /opt/share/sickbeard/SickBeard.py
 2126 root     17692 S    /opt/bin/python2.5 /opt/share/sickbeard/SickBeard.py
 2127 root     17692 S    /opt/bin/python2.5 /opt/share/sickbeard/SickBeard.py
 2129 root      2596 S    grep sickbeard


Has anyone found a solution?

I will open a thread about this problem on the sickbeard forum. if i get any solution i'll write it here.

Gwakamol
Brickman
Beginner
Beginner
Posts: 23
Joined: Sat Nov 13, 2010 5:23 pm
Contact:

Re: SickBeard: Automatic TV Show Download

Postby Brickman » Wed Dec 29, 2010 5:58 pm

@gwakamol

What version of the DSM are you running?
DS410 / DSM 4.0 2198 / 4x Samsung EcoGreen F4EG (HD204UI)
with APC Back-UPS ES 550G

HowTo for Synology NAS: http://synology.brickman.nl/
gwakamol
I'm New!
I'm New!
Posts: 4
Joined: Sun Dec 26, 2010 6:56 pm

Re: SickBeard: Automatic TV Show Download

Postby gwakamol » Sun Jan 02, 2011 3:34 pm

Sorry i forgot this important information ^^

I'm using the last one. DSM 3.0-1354.

Gwakamol
dv8ed
I'm New!
I'm New!
Posts: 8
Joined: Wed Dec 08, 2010 7:57 am

Re: SickBeard: Automatic TV Show Download

Postby dv8ed » Thu Jan 06, 2011 4:35 am

so we're supposed to go into Package Management then click on Stop for shutdown?

I do that but when i refresh it always says Running still never says Stopped.
Synology DS-410 DSM 3.0-1354 (4x - 2TB SAMSUNG Spinpoint F4 HD204UI RAID-5)
Zyxel NSA-220 Firmware v3.22 (2x - 1TB WD10EACS-22D6B0 RAID-1)
D-Link DNS-323 Firmware v1.09 (2x - 1TB WD10EACS-00ZJB0 & WD10EADS-00L5B1 JBOD)
Brickman
Beginner
Beginner
Posts: 23
Joined: Sat Nov 13, 2010 5:23 pm
Contact:

Re: SickBeard: Automatic TV Show Download

Postby Brickman » Thu Jan 06, 2011 6:26 pm

dv8ed wrote:so we're supposed to go into Package Management then click on Stop for shutdown?

I do that but when i refresh it always says Running still never says Stopped.


I modified the sabstart.sh and sabstop.sh that the processes of Sickbeard are started and stopped when sabnzbd+ and sickbeard are started and stopped together.

The status checker checks if the included python executable is running or not.
DS410 / DSM 4.0 2198 / 4x Samsung EcoGreen F4EG (HD204UI)
with APC Back-UPS ES 550G

HowTo for Synology NAS: http://synology.brickman.nl/
gwakamol
I'm New!
I'm New!
Posts: 4
Joined: Sun Dec 26, 2010 6:56 pm

Re: SickBeard: Automatic TV Show Download

Postby gwakamol » Thu Jan 06, 2011 10:52 pm

ok, as i'm not finding any solution to my problem; does anyone know a soft able, like sickbeard, to fetch data from site like tvdb for renaming purpose ?
Or maybe a script that can be run by sabnzbd during post-processing ?
And obviously running on a DS207+.

Or maybe i'm just asking too much from my syno ^^
JunkDeluxe
I'm New!
I'm New!
Posts: 4
Joined: Sat Mar 27, 2010 10:16 pm

Re: SickBeard: Automatic TV Show Download

Postby JunkDeluxe » Fri Jan 07, 2011 1:10 am

Hi guys,

Just recently installed Sick Beard, and it is working fine on my local network and the NAS (DS409).
Although i seem to have problems accessing it from outside my network. I have made the setup exactly as the OP posted, and it does in fact work fine.
A part from a huge load when it needs to load all the ep data from thetvdb.org, but that is understandable.

Anyone of you had any trouble accessing it through the WAN? The 8081 port is open on the router, and should let all traffic through to the box.
I did the same for SABNzbd, and the web interface is working fine from the outside. I also added the port on the firewall in DSM3.0
User avatar
jmurre
Rookie
Rookie
Posts: 38
Joined: Mon Mar 16, 2009 10:01 am
Location: The Netherlands

Re: SickBeard: Automatic TV Show Download

Postby jmurre » Fri Jan 07, 2011 8:07 am

JunkDeluxe wrote:Hi guys,

Just recently installed Sick Beard, and it is working fine on my local network and the NAS (DS409).
Although i seem to have problems accessing it from outside my network. I have made the setup exactly as the OP posted, and it does in fact work fine.
A part from a huge load when it needs to load all the ep data from thetvdb.org, but that is understandable.

Anyone of you had any trouble accessing it through the WAN? The 8081 port is open on the router, and should let all traffic through to the box.
I did the same for SABNzbd, and the web interface is working fine from the outside. I also added the port on the firewall in DSM3.0

Have no issues here with that. Just have made a NAT rule on the outside router to let all traffic for port 5051 through to the IP address of my NAS and I am able to reach SickBeard. You have no issues reaching your DSM page of the box itself?
JunkDeluxe
I'm New!
I'm New!
Posts: 4
Joined: Sat Mar 27, 2010 10:16 pm

Re: SickBeard: Automatic TV Show Download

Postby JunkDeluxe » Fri Jan 07, 2011 9:12 am

jmurre wrote:Have no issues here with that. Just have made a NAT rule on the outside router to let all traffic for port 5051 through to the IP address of my NAS and I am able to reach SickBeard. You have no issues reaching your DSM page of the box itself?


No problems reaching any other service on the NAS, that i allowed through the router.SSH, DSM, SABNzbd, FTP, etc. Everything is working fine except Sick Beard.
I'll try changing the ports on the service and have another go at it later today.
Gotcha007
I'm New!
I'm New!
Posts: 1
Joined: Wed Jan 26, 2011 5:57 pm

Re: SickBeard: Automatic TV Show Download

Postby Gotcha007 » Wed Jan 26, 2011 6:44 pm

Anyone knows if it's running on a DS110J?
kinnth
Trainee
Trainee
Posts: 18
Joined: Tue Feb 08, 2011 4:44 pm

Re: SickBeard: Automatic TV Show Download

Postby kinnth » Tue Feb 08, 2011 4:59 pm

Hi All,

I have the synology 411j running DSM 3.0. I have got sabnzbdb running using the precompiled file found on this forum. I now also want to get sickbeard installed but I was wondering if people have still been finding any problems with sickbeard on the synology? Also should I use python 2.6?
Meester
I'm New!
I'm New!
Posts: 1
Joined: Wed Feb 09, 2011 11:33 pm

Re: SickBeard: Automatic TV Show Download

Postby Meester » Thu Feb 10, 2011 11:08 pm

Hi all,

i have samilar problems as some other users have posted here. i used the guide made by brickman to install sickbeard and couchpatato. i used his scripts to replace the sabstart/stop.sh and to create start/stop script for both apps.

couchpatato works fine. but sickbeard doesn't get past the following:

Starting up Sick Beard master from /volume1/@appstore/sickbeard/config.ini
23:06:07 INFO::MainThread :: Checking database structure...
23:06:08 INFO::MainThread :: No duplicate episode, check passed
23:06:08 INFO::MainThread :: Starting Sick Beard on http://localhost:9100


this happen when i execute :

/opt/bin/python2.5 /volume1/@appstore/sickbeard/SickBeard.py

with:
/var/packages/sab2/target/utils/bin/python

it doesn't pass the config line

with python 2.6 i get an error message. i have an DS107+ with latest firmware

hope some1 can help me get it running, i'm stuck. would love to use it.
SiXke
I'm New!
I'm New!
Posts: 5
Joined: Tue Jan 04, 2011 11:36 am

Re: SickBeard: Automatic TV Show Download

Postby SiXke » Fri Feb 11, 2011 8:17 pm

Hi guys

I have installed SabNzb, Couchpotato and SB on my 1511

Sab and Couch are started automatically, however, SB wont start automatically

When I use following command manually, it starts, when I put it in rc.local, it wont start

Code: Select all

/var/packages/sab2/target/utils/bin/python /volume1/@appstore/sickbeard/SickBear


Can anyone explain the difference between running it manually and putting it in rc.local?

Anyone got those 3 programs up and running automatically?

Grtz

Return to “Software Compatibility Lists”

Who is online

Users browsing this forum: No registered users and 2 guests