Fixing tty name with udev

Questions and mods regarding system management may go here
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/support_form.php?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
mseuda
I'm New!
I'm New!
Posts: 1
Joined: Sun Jan 24, 2016 7:23 pm

Fixing tty name with udev

Postby mseuda » Sun Jan 24, 2016 7:27 pm

Hi all
I need to fix the name of usb Aeon Z-wave stick G5 to ttyACM0
I try with udev in my Syno but it's difficult.

I've created file in /lib/udev/rules.d
99-usb-aeon-zwave.rules

with this content :
ENV{SUBSYSTEM}=="tty"
ACTION=="add", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", ATTRS{serial}=="ffffffd1ffffffb2ffffffdbffffffa0", SYMLINK+="ttyACM0"

but it doesn't work, help please... ;)
gdusordet
I'm New!
I'm New!
Posts: 2
Joined: Sun Apr 10, 2016 10:05 am

Re: Fixing tty name with udev

Postby gdusordet » Sun Apr 10, 2016 10:14 am

Any luck? experiencing simular issue! how can we assign a seral port to the controller Aeotec Z-Stick Gen5? it keep changing between /dev/ttyACM0 and /dev/ttyACM1 after each restart of my Synology
help much appreciated
G
jamie_b
Trainee
Trainee
Posts: 12
Joined: Sun Jan 08, 2017 4:49 pm

Re: Fixing tty name with udev

Postby jamie_b » Fri Dec 01, 2017 9:38 am

Did you guys manage to solve this issue?

Return to “System Managment Mods”

Who is online

Users browsing this forum: No registered users and 4 guests