Downgrading DS414Slim from 6.1.4-15217 Update 1

Questions and mods regarding system management may go here
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/support_form.php?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
Vinatopian
I'm New!
I'm New!
Posts: 2
Joined: Tue Dec 05, 2017 3:38 pm

Downgrading DS414Slim from 6.1.4-15217 Update 1

Postby Vinatopian » Sat Jan 13, 2018 7:39 pm

I am trying to downgrade my DS414Slim from DSM 6.1.4-15217 Update 1 to DSM 5.2 5967.

I have been following the process documented by @knudsen in the following thread: https://forum.synology.com/enu/viewtopic.php?f=39&t=46450

To this end I have updated /etc.updates/VERSION to read like this:

Code: Select all

majorversion="5"
minorversion="2"
buildphase="hotfix"
buildnumber="5644"
smallfixnumber="0"
builddate="2015/11/12"
buildtime="17:17:16"
unique="synology_armada370_414slim"


...and the Update and Restore page in Control Panel now indicates the system is 'version 5.2 (null) 5644' - as expected

I have changed the NIC MTU to 1500 and disabled all firewalls and AV on the PC from which I am serving the update.

I then invoked a Manual DSM Update and selected DSM_DS414slim_5967.pat for the upgrade.

The upgrade begins OK but then bombs-out with the error "the certificate of the .pat file could not be verified"

The DS414Slim runs on a single core Marvell Armada 370 88F6707, so I don't think it is compatible with the boot-loader mod described at http://www.synology-forum.de/showthread.html?80481-Downgrade-6-1-beta-6-0-x&p=668623&viewfull=1#post668623

Would anyone be able to point me in the right direction on this please? I may have missed something obvious or simply not have read enough posts to find the critical thing I need to change in my config to make it work...

Thanks in advance
User avatar
sjeph8je
Seasoned
Seasoned
Posts: 522
Joined: Fri Jan 29, 2010 10:06 pm
Location: Netherlands

Re: Downgrading DS414Slim from 6.1.4-15217 Update 1

Postby sjeph8je » Sun Jan 14, 2018 11:41 am

Hi,
Did you read the red lines in the first post, it states that this procedure doesn't work any more from 6.1 beta (and upwards). It is possible to downgrade but it involves reflashing the bootloader as is stated in edit 2 of the first post. This is a risky procedure but can be done (I have done it myself on an older NAS)
DS-916+ | DSM 6.1.4-15217-5 | 2 x WD40EFRX (RAID1-btrfs) | 2 x WD10EFRX (RAID1-btrfs) (AS, Calendar, Chat, CMS, Docker, Hyper backup, PS, Snapshot Replication, SVN, VS, WS, Webdav)
  • Startech S3510SMU33 | WD20EFRX (ext-4)
DS-213J | DSM 6.1.4-15217-5 | 2 x WD5000AAKS (RAID0-ext4) (Download Station)
DS-209 (DS211j modded) | DSM 6.1.4-15217-5 | 2 x WD20EFRX (RAID1-ext4) (Hyper backup vault)

Corruption wears infinite disguises.

Return to “System Managment Mods”

Who is online

Users browsing this forum: No registered users and 2 guests