Downgrade Firmware (not working anymore for DSM 6.1 Beta!!)

Questions and mods regarding system management may go here
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/support_form.php?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
qschan
I'm New!
I'm New!
Posts: 2
Joined: Thu Feb 09, 2017 2:04 pm

Downgrade DSM to older versions

Postby qschan » Mon Nov 13, 2017 12:12 am

Several years ago, I ran into this same problem. After Googling, I had successfully downgraded the DSM to older version by taking out the harddisk from DS109 and connected to a linux station. I changed the header of the text file ./etc.defaults/VERSION to a version older than the good DSM:-

majorversion="4"
minorversion="5"
smallfixnumber="8"
productversion="4.5.8"
buildphase="GM"
buildnumber="6281"
builddate="2014/10/20"
buildtime="20:22:08"

after complete the editing, I return the harddisk back to DS109 and reboot the system. It allowed me to upgrade to the latest DSM or manually to your choice of DSM from Synology's server.

Now, I will defer all DSM upgrades until I got an all clear signal from this forum.

Try at your own risk and Good Luck!

Now: DS1515+ and QNAP-TS451
Old: DS109, DS211, DS214Play
parnassus
Sharp
Sharp
Posts: 173
Joined: Wed Mar 02, 2016 2:11 pm

Re: DSM 6.2 downgrade to 6.1 stable?

Postby parnassus » Wed Dec 06, 2017 2:14 pm

neilmcg wrote:When you install the Beta, you're told you can't roll it back.

I remember, that in order to downgrade (not supported), you needed to access a config file via ssh or telenet. I haven't downgraded a firmware since DS 106j days.

If you're really set on downgrading, you should search the forum - it's been covered.


Hello neilmcg, can you provide a link to a post/thread that discussed the unsupported procedure cited above (DSM 6.2 Beta to DSM 6.1 Stable), if any?

Just curious to see if it is possible and what are the steps to follow (I suspect that the considered starting point is a DS/RS unit already in DSM 6.2 Beta status with SSH access enabled...).

Thanks, Davide.
User avatar
neilmcg
Versed
Versed
Posts: 216
Joined: Tue Jan 01, 2008 3:36 pm
Location: West Coast, Sweden
Contact:

Re: DSM 6.2 downgrade to 6.1 stable?

Postby neilmcg » Wed Dec 06, 2017 3:58 pm

• Model: DS111; Firmware: DSM 6.2-(β); HDD: WD Red 3TB • iTunes Server | Photo | VPN
• Model: DS212; Firmware: DSM 6.2-(β); HDD: WD Red 3TB x2 • Server

Netgear WNR3500L
ASUS RT-AC68U
Sonos ZoneBridge | Sonos ZonePlayer ZP90 | Sonos play:5 [White] x 2 | Sonos play:1 [White] | Apple Airport Express | Revo BLiK DAB

• Model: DS106j; Firmware: 4.0-2166 (β); HDD: WD 1TB • Server - http ; (Goetz Tip) based on DS108j x 2
Elrick
I'm New!
I'm New!
Posts: 8
Joined: Mon May 20, 2013 10:10 am

Re: Downgrade Firmware (not working anymore for DSM 6.1 Beta!!)

Postby Elrick » Sat Dec 23, 2017 6:15 pm

Hi to all,

I'm using RS816 Synology with 6.1.4-15217 update 1 and i would like to downgrade it to 6.0.1 7393.

FIRST TRY :
I try to apply this tuto https://www.youtube.com/watch?v=DFtOmEv63n4
But i didn't have grub_cksum.syno into firmware and this file doesn't seems present in the another firmware version file.

SECOND TRY :

I modify VERSION file in /etc.defaults like this with root access right (Telnet mode) :

majorversion="6"
minorversion="0"
productversion="6.0"
buildphase="release"
buildnumber="7321"
smallfixnumber="0"
builddate="2016/03/23"
buildtime="11:46:57"

My current version is changed immediately (control panel > Update), i click on "Update manually", it run the process but i receive this error message :

Image

How can i fix it ?

Many thks.
lpreda
I'm New!
I'm New!
Posts: 1
Joined: Sat Dec 23, 2017 10:26 pm

Re: Downgrade Firmware (not working anymore for DSM 6.1 Beta!!)

Postby lpreda » Sat Dec 23, 2017 10:37 pm

I have tried to downgrade from 6.2 to 6.1 and there is a very important piece of information which is missing from the instructions - after you change the /ect.defaults/VERSION file you don't reboot but immediately run Synology Assistant to detect and perform the downgrade (choose to migrate the data on your disks).

Just for the record, this is how VERSION looks while being on 6.1.4:
majorversion="6"
minorversion="1"
productversion="6.1.4"
buildphase="GM"
buildnumber="15217"
smallfixnumber="5"
packing="nano1"
packing_id="1"
builddate="2017/12/20"
buildtime="23:50:07"

Hope this will help some guys to spend less time with the downgrade :D
matt_pl
I'm New!
I'm New!
Posts: 9
Joined: Fri Oct 19, 2012 10:12 am

Install DSM 3.2 on DS212j

Postby matt_pl » Sun Jan 07, 2018 11:03 am

Hi
I have a problem to make a fresh installation of 3.2 DSM version on my DS212j, with Synlogy Assistant.
I found this initial DSM release for this model performing very well and 5.xx and 6.xx versions underperfoming on this hardware.

Two hard drives are empty and Synology Assistant status "Not installed".
Device will only operate in LAN with no external access.

Synology Assistant "detects" that I should install the latest version which is 6.1.x
Even Synology Assistant ver 3.2 will force installation of version 6.1.x, even if I disable internet access.
When I select 3.2.1944 Pat file, it is rejected.

How to perform the installation of 3.2 DSM?
Thank you.

Image
Vinatopian
I'm New!
I'm New!
Posts: 3
Joined: Tue Dec 05, 2017 3:38 pm

Re: Downgrade Firmware (not working anymore for DSM 6.1 Beta!!)

Postby Vinatopian » Fri Jan 12, 2018 6:58 pm

Elrick wrote:<snip>
SECOND TRY :

I modify VERSION file in /etc.defaults like this with root access right (Telnet mode) :

majorversion="6"
minorversion="0"
productversion="6.0"
buildphase="release"
buildnumber="7321"
smallfixnumber="0"
builddate="2016/03/23"
buildtime="11:46:57"

My current version is changed immediately (control panel > Update), i click on "Update manually", it run the process but i receive this error message :

Image

How can i fix it ?

Many thks.


Hi Elrik,

I am having exactly the same problem with my DS414Slim. I am downgrading to 5.2 (5967) from 6.1.4-15217 Update 1 but I get the same error message as you "the certificate of the .pat file could not be verified".

Did you ever work out how to fix it?

Return to “System Managment Mods”

Who is online

Users browsing this forum: No registered users and 2 guests