Sickbeard and SabNZBD+ won't display web pages

Questions regarding modifying the torrent engine or download station may go here.
Forum rules
Please note the disclaimer before modifying your Synology Product.
I'm New!
I'm New!
Posts: 2
Joined: Sat Mar 03, 2012 10:17 pm

Sickbeard and SabNZBD+ won't display web pages

Postby Larzjg » Sat Mar 03, 2012 10:54 pm


I'm a relative noob here, and I'm experiencing trouble with my installs of SabNZBD+ and Sickbeard. I'm fairly certain my mistake is an incredibly basic one, so here goes:

What happens?
I start SAB or SB from the package menu.
They run, according to their logs and to an SSH top-command.
But the websites time out, and never display a homepage.

What should happen?
I'd like their web pages to display :)

How do I reproduce it?
I click the links in the "more" section of their package center pages, and it returns a nicely formatted page with an error message when they service is stopped.
But when the services are running, I get a page that hangs on "sending request", until it 10-20 seconds later returns an error of no response.

What's your system?
DS411, brand new.
Running 4.0 beta. Exact same problem was there with 3.2 tho.

What did I try to fix it?
Well, I think I've tried everything, but I obviously haven't. By now, I'm convinced I've made a complete rookie mistake somewhere, so that's why I'm posting. :)

I did an SSH login to check if their services were running - they were.

I've looked at their logs through package center, as I thought maybe they have errors during startup. They don't seem to - SabNZBD+ starts on ip, which concerns me.

I disabled Photo Station, as someone said the ports might conflict.

I wanted to try and edit the .ini file for sabnzbd, but I wasn't able to get in with SFTP, I got a filezilla error message. My Linux SSH skills are just about exhausted by running putty, logging in and typing "top", so while I can get in with SSH, I dunno what the commands are for navigating, and I couldn't find a command list or help online. :(

I'm sure it is the same error for both - their reactions are completely similar, after all. I just don't know how to fix it.

So how did I get here:
1. I've installed both packages, plus python, from

2. I've disabled my firewall. Just for now, until I figure this out.

Anyone have an idea what my problem might be? I'm drawing a blank here, to be honest. :(

Thanks for reading people, I appreciate it - I know how tiring tech support on a forum can be.

I'm New!
I'm New!
Posts: 2
Joined: Sat Mar 03, 2012 10:17 pm

Re: Sickbeard and SabNZBD+ won't display web pages

Postby Larzjg » Sun Mar 04, 2012 7:21 pm

So, I fixed my problem - I'll share, in case anyone else is running into the same issue.

What was the problem?
I was accessing my Synology DS411 from the external IP. When Synology was linking to the SabNZBD+, it linked to the external IP with the altered port. My router's port forwards were not configured correctly for those.

How did I solve it?
Instead of going to the external ip,, I went to the local IP that looks like This served the pages perfectly.

Lessons learned?
I will remember that if it feels like a firewall issue, it probably is a firewall issue. :)

Return to “Torrent Engines/Download Station Mods”

Who is online

Users browsing this forum: No registered users and 3 guests