[DS-207+] Installing PMS (PS3 Media Server)

Questions about using 3rd party Media Streaming software may go here
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
atrem
I'm New!
I'm New!
Posts: 7
Joined: Sun Jul 20, 2008 11:39 pm

[DS-207+] Installing PMS (PS3 Media Server)

Unread post by atrem » Sun Feb 08, 2009 1:51 pm

Hi,

I was wondering if anyone has succesfully installed PMS ( PS3 Media Server) on the Synology DS-207+ ?

This is what I did so far:

- Installed a Java VM called ‘jamvm’ (version 1.5.1-1) through ipkg package based install.
- Installed 'classpath' (version 0.97.2-2) also with ipkg install.
- Downloaded and unpacked PMS-linux-1.04
- Made the shell script executable (chmod ug+x PMS.sh)
- Changed the following code in PMS.sh:

Code: Select all

# Setup the JVM

if [ "x$JAVA" = "x" ]; then
            if [ "x$JAVA_HOME" != "x" ]; then
                        JAVA="$JAVA_HOME/bin/java"
            else
                        JAVA="jamvm"
            fi
fi
and also:

Code: Select all

# Execute the JVM

exec "$JAVA" $JAVA_OPTS -Xmx512M -Djava.encoding=UTF-8 -Djava.net.preferIPv4Stack=true -jar "$PMS_JAR" "$@"
- Now when I execute ./PMS.sh I get:

Code: Select all

java.lang.reflect.InvocationTargetException
   at java.lang.reflect.Method.invokeNative(Native Method)
   at java.lang.reflect.Method.invoke(Method.java:367)
   at jamvm.java.lang.JarLauncher.main(JarLauncher.java:50)
Caused by: java.lang.UnsatisfiedLinkError: Native library `gconfpeer' not found (as file `libgconfpeer.so') in gnu.classpath.boot.library.path and java.library.path
   at java.lang.Runtime.loadLibrary(Runtime.java:763)
   at java.lang.System.loadLibrary(System.java:662)
   at gnu.java.util.prefs.gconf.GConfNativePeer.<clinit>(GConfNativePeer.java:332)
   at gnu.java.util.prefs.GConfBasedPreferences.<clinit>(GConfBasedPreferences.java:83)
   at gnu.java.util.prefs.GConfBasedFactory.<clinit>(GConfBasedFactory.java:52)
   at java.lang.reflect.Constructor.constructNative(Native Method)
   at java.lang.reflect.Constructor.newInstance(Constructor.java:328)
   at java.lang.Class.newInstance(Class.java:1154)
   at gnu.classpath.ServiceProviderLoadingAction.run(ServiceProviderLoadingAction.java:140)
   at java.security.AccessController.doPrivileged(AccessController.java:195)
   at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(ServiceFactory.java:529)
   at gnu.classpath.ServiceFactory$ServiceIterator.<init>(ServiceFactory.java:435)
   at gnu.classpath.ServiceFactory.lookupProviders(ServiceFactory.java:305)
   at gnu.classpath.ServiceFactory.lookupProviders(ServiceFactory.java:229)
   at java.util.prefs.Preferences.getFactory(Preferences.java:214)
   at java.util.prefs.Preferences.userRoot(Preferences.java:156)
   at net.pms.io.WinUtils.start(WinUtils.java:182)
   at net.pms.io.WinUtils.<init>(WinUtils.java:178)
   at net.pms.PMS.init(PMS.java:261)
   at net.pms.PMS.get(PMS.java:895)
   at net.pms.PMS.main(PMS.java:957)
   at java.lang.reflect.Method.invokeNative(Native Method)
   ...2 more

- I tried to compile several other versions of classpath myself but no luck.

Anyone?

joystick
I'm New!
I'm New!
Posts: 1
Joined: Sun Apr 05, 2009 5:27 pm

Re: [DS-207+] Installing PMS (PS3 Media Server)

Unread post by joystick » Sun Apr 05, 2009 5:35 pm

hi,

dont know if you solved your problem, but the java app is not able to find the file libgconfpeer.so

its looking in its classpath for this file. you need to either specify the location of this file via the -classpath arg for the jvm (or check this jvm's syntax, "classpath" is what Sun uses for its jvm)...or u can simply put the .so file in one of the folders the app is already looking in, typically a subfolder from where u start the jvm...

hope this helps.

gregoire
Versed
Versed
Posts: 263
Joined: Sun Oct 29, 2006 9:51 pm

Re: [DS-207+] Installing PMS (PS3 Media Server)

Unread post by gregoire » Sat Jul 25, 2009 10:38 pm

Anny news on this one?
DS-508, DS214Play
Samung UE46C6900
Wireless network.

atrem
I'm New!
I'm New!
Posts: 7
Joined: Sun Jul 20, 2008 11:39 pm

Re: [DS-207+] Installing PMS (PS3 Media Server)

Unread post by atrem » Thu Jul 30, 2009 8:31 pm

gregoire wrote:Anny news on this one?
Hi Gregoire,
With a lot of effort I finally managed to get PMS working on my DS207+.
I didn't succeed to listen to webradio and watch (lowres) on the PS3 yet, I can only view photo's and listen to mp3's at the moment .

Here's more info about it from PMS's forum:
http://ps3mediaserver.org/forum/viewtop ... t=30#p8275
http://ps3mediaserver.org/forum/viewtop ... 859#p12549

Locked

Return to “Media Streaming Mods”