Indexing with PDFtoText | Sphider-Plus

Questions regaring MySQL and PHP may go here
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/support_form.php?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
Danelicious
I'm New!
I'm New!
Posts: 4
Joined: Fri Mar 04, 2016 1:08 am

Indexing with PDFtoText | Sphider-Plus

Postby Danelicious » Fri Mar 04, 2016 1:18 am

Hi there,

I installed Sphider-Plus (http://sphider-plus.eu/) on my DS215j. Only problem, I can't get PDF-files indexed.

I followed the instructions here: http://sphider-plus.eu/index.php?f=14#14_8

The path to the pdftotext diectory must be right, because I don't get an error message (got one before, than changed the path). But when I try to index a link to a pdf-file, it does not do so (also shows no error message).

Does anyone know how to fix this problem?

BTW: I also successfully installed pdftotext via ipkg, but this should not concern my issue. Thanks in advance!
Danelicious
I'm New!
I'm New!
Posts: 4
Joined: Fri Mar 04, 2016 1:08 am

Re: Indexing with PDFtoText | Sphider-Plus

Postby Danelicious » Fri Mar 04, 2016 11:58 am

Well, after waking up today, I had an idea that worked fine. Maybe this will help someone in the future.

It's easier to install pdftotext via ipkg (terminal: "ipkg install pdftotext") - given ipkg is installed on your DS. Afterwards I just entered the path (/opt/bin/pdftotext) to the config-file of sphider (which you find in the settings folder). And now my pdf-indexing works like a charme. :D

I recommend to also install ipkGui (interace for your ipkg installations). Just in case the path above doesn't work, you can get the right path from ipkGui.

So happy it finally worked. Took me a whole day :lol:

Return to “MySQL/PHP Mods”

Who is online

Users browsing this forum: No registered users and 1 guest