No PHP write permissions

Questions regaring MySQL and PHP may go here
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
catotonic
I'm New!
I'm New!
Posts: 1
Joined: Tue Nov 14, 2017 1:51 pm

No PHP write permissions

Unread post by catotonic » Tue Nov 14, 2017 2:49 pm

I am trying to install Fengoffice on my Synology 216+ii.
I copied the unzipped files into my web directory as directed and tried running the installer but got the message the PHP does not write permissions for several folder, and I assume their files.
I ran chmod and all the required files now 0755 permissions
Upon more research, I believe the problem is that the Fengoffice files were installed using my login credentials with a simple file copy and that PHP is trying to access them with the user name "http".
I tried to chown the folders to "http" but there is no group name and Synology ignores me.
My question(s)
How do I copy file into my web directory so that PHP has write access to them?
or
What can I do the folders and files besides chown or chmod?
or
Do I need to, (should I) change the user name of Apache web server?
How would I change the name?
Thanks

Post Reply

Return to “MySQL/PHP Mods”