httpd.conf and Timeout

Questions about HTTP Access/Mods may go here
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
I'm New!
I'm New!
Posts: 1
Joined: Fri Sep 23, 2016 8:10 am

httpd.conf and Timeout

Postby ssiondubois » Fri Sep 23, 2016 8:21 am

Hi fellow,

I'm hosting a php/mysql Website on my RS2414+ with DSM 5.x

I have a php script that takes a while to execute, and after 300 sec (Default Timeout settings for apache) I get a 502 Proxy error Reason: Error reading from remote server.

I tried to add in httpd.conf-user Timeout et ProxyTimeout settings to increase their value up to 1000 but the script still stop at 300sec after restarting apache. I can see that these argument are correctly inserted in httpd.conf. Note that the PHP.ini file is correctly setted up, and the php script's timeout are fine, by the way it is not a php error.

Do you know where to set the Timeout and ProxyTimeout argument in the synology, so my scripts can run without stopping after 300 sec ?



Return to “HTTP/Apache Mods”

Who is online

Users browsing this forum: No registered users and 2 guests