Amazon Echo/Dot Alexa skills

Discuss with the community any ideas you'd love to see in future DiskStations and DSM updates! We do our best to monitor and forward all of them, but we recommend to also use this form as our team will systematically see your suggestion:
https://www.synology.com/en-global/form ... y/feedback
Forum rules
We do our best to monitor and forward your ideas to our team, but due to the large amount, we may not see every single one and recommend to also use this form as our team will systematically see your suggestion:
https://www.synology.com/en-global/form ... y/feedback
User avatar
DaveHamilton
Student
Student
Posts: 70
Joined: Fri Aug 17, 2012 10:47 pm

Re: Amazon Echo/Dot Alexa skills

Postby DaveHamilton » Wed Nov 01, 2017 2:01 pm

I got it working on my DS1817+. A few things that might be helpful:

  • Make sure you're running DSM 6.2 Beta
  • Update to AudioStation 6.3.0-3260 (at least)
  • Go into Audio Station > Settings > Advanced and enable the Alexa skill. While here, note the public address and port. For me it was my normal address and port 5001. As noted, you'll need a certificate (I use Let's Encrypt) on whatever this is.
  • Presumably you also need to make Audio Station accessible from the outside world (mine already was). Alexa is a cloud-based service, meaning your internal IP doesn't matter. If you can access Audio Station from outside your network you're good. If not, go ahead and configure your router/firewall to make that happen.
  • Add the skill at alexa.amazon.com or in the Alexa iOS (or presumably Android) app
  • Make sure to plug in that same public address and port during the Alexa Skill setup.

And now I'm all set. "Alexa Tell Audio Station to play Rush" works just fine, thank you very much. ;) It's even better if you have a Sonos One. ;)
Pfalder
Trainee
Trainee
Posts: 10
Joined: Wed Sep 26, 2012 9:40 pm

Re: Amazon Echo/Dot Alexa skills

Postby Pfalder » Wed Nov 01, 2017 4:54 pm

When I try to activate the Enable Alexa swith in Audio Station settings it fails.

I have the correct hostname in with port 5001 and I have created a certificate with Lets Encrpt for name.synology.me
I have also tested that I can get external access to Diskstation Manager on my NAS. (on port 5001)

The error message is "failed to apply settings. Check internet connectivity and ensure normal access from the internet"

Any ideas whats going wrong?
mgibbs
I'm New!
I'm New!
Posts: 1
Joined: Thu Nov 02, 2017 10:53 am

Re: Amazon Echo/Dot Alexa skills

Postby mgibbs » Thu Nov 02, 2017 10:55 am

I have the same problem as Pfalder
Xziz
I'm New!
I'm New!
Posts: 1
Joined: Thu Nov 02, 2017 4:29 pm

Re: Amazon Echo/Dot Alexa skills

Postby Xziz » Thu Nov 02, 2017 4:36 pm

I also have the same problem. I just created a certificate and it's valid according to chrome but when trying to add the skill I receive this error.

Image
Streemer
I'm New!
I'm New!
Posts: 2
Joined: Thu Nov 02, 2017 8:30 pm

Re: Amazon Echo/Dot Alexa skills

Postby Streemer » Thu Nov 02, 2017 8:46 pm

Count me in as well.

Synology support was so kind to guide me through the certification process but now I'm getting the same error-message after checking the Alexa-box and clicking OK.

I'm also having some trouble linking the Alexa-skill to my account. What exactly am I supposed to enter on the initial screen following the 'https://'? Is this where the certified host goes? Am I supposed to enter the entire certified host-name shown at Audio station 'xxxxxxx.synology.me:5001' or do I leave the ':5001' off at that point?

If I enter the entire name, I'm getting 'A valid SSL certificate is required for the authentication.' Same applies without ':5001'.

However, 'xxxxxxx.synology.me' IS listed as Default certificate under 'Certificate' in the settings.

Any help would be highly appreciated. I also sent a message to Synology about this error-code and will report any updates ASAP.
Streemer
I'm New!
I'm New!
Posts: 2
Joined: Thu Nov 02, 2017 8:30 pm

Re: Amazon Echo/Dot Alexa skills

Postby Streemer » Thu Nov 02, 2017 10:23 pm

BTW, I also have the feeling that something might be wrong with the certification.

As I stated before, 'xxxxxxx.synology.me' is certified according to Synology through Let's Encrypt but when I'm entering 'xxxxxxx.synology.me' into my chrome-browser, I end up at a screen that says 'Frontier Router' and shows a log In for a User-name and Password. I have the feeling that I'm not doing this right... :mrgreen:

Can somebody please tell me what I'm supposed to enter for the 'xxxxxxx' at 'xxxxxxx.synology.me'? The guy on the phone said that is supposed to be the name of the server but I tried that and it is not working.
andrewmv
Trainee
Trainee
Posts: 11
Joined: Wed Apr 13, 2016 6:29 pm

Re: Amazon Echo/Dot Alexa skills

Postby andrewmv » Sat Nov 04, 2017 8:17 am

Pfalder wrote:When I try to activate the Enable Alexa swith in Audio Station settings it fails.

I have the correct hostname in with port 5001 and I have created a certificate with Lets Encrpt for name.synology.me
I have also tested that I can get external access to Diskstation Manager on my NAS. (on port 5001)

The error message is "failed to apply settings. Check internet connectivity and ensure normal access from the internet"

Any ideas whats going wrong?


It took me some trial and error to figure this out, but for me, the problem was that the Let's Encrypt certificate signed to [hostname].synology.me wasn't the default certificate, so when the Alexa still attempted to connect to the NAS to test the connection, the NAS's webserver was vending the self-signed built-in certificate synology.com instead of the correctly signed one for the DDNS.

To fix this, I went to Control Panel -> Security -> Certificate -> [hostname].synology.me -> Configure, and selected [hostname].synology.me as the cert for the "Default" role (but allowed the built-in cert to continue to be associated with the other roles).

When you perform the account linking at alexa.amazon.com or the Alexa app on a mobile device, the correct string to enter seems to be "https://[hostname].synology.me:5001" - it did not work when I didn't explicitly specify the port.

I had some trouble at this step because my local DNS server didn't actually resolve [hostname].synology.me from inside the LAN, so Alexa's attempt to forward me to the NAS's OAuth webserver didn't work correctly - I fixed this by explicitly resolving the host in my /etc/hosts file on my workstation - I suspect people with more conventional router configurations won't have this problem.
Pfalder
Trainee
Trainee
Posts: 10
Joined: Wed Sep 26, 2012 9:40 pm

Re: Amazon Echo/Dot Alexa skills

Postby Pfalder » Sun Nov 05, 2017 1:16 am

I don’t think that’s the case for me as I set it to be default certificate and even removed the ynology certificate to leave just this new certificate.
Bve
I'm New!
I'm New!
Posts: 1
Joined: Sun Nov 05, 2017 9:40 am

Re: Amazon Echo/Dot Alexa skills

Postby Bve » Sun Nov 05, 2017 9:49 am

Hi, I finaly succeeded in linking Amazin Echo to Audiostation. However when I ask Alexa to play a track, no sound from echo. If I ask Alexa tell audio station what’s playing, she responds with the right track is playing now. However, no sound.
I even re-encoded my whole library from Alac tot Mp3. Still no success.
Is there a setting I overlooked? Router, ports anything?
Are others succesfull in playing their audio station library on the Echo?
Thanks for replying.
jhmorri2
I'm New!
I'm New!
Posts: 5
Joined: Tue Mar 21, 2017 12:04 am

Re: Amazon Echo/Dot Alexa skills

Postby jhmorri2 » Thu Nov 16, 2017 8:40 pm

I called synology as I have been unable to figure out how to setup the SSL Cert and then the ability to configure audio station to stream to Alexa. I own over 12 Synology devices and sale them all the time. You would think synology would give me a bit more time other than just telling me its in beta so they can't help.

If anyone has gone through the process from start to finish in setting up the SSL Cert, and audio station to stream; please post a step by step and screen shots. Synology knowledge base is useless when it comes to anything more than the easiest way to set it up, and without any issues.
andrewmv
Trainee
Trainee
Posts: 11
Joined: Wed Apr 13, 2016 6:29 pm

Re: Amazon Echo/Dot Alexa skills

Postby andrewmv » Thu Nov 16, 2017 9:32 pm

jhmorri2 wrote:I called synology as I have been unable to figure out how to setup the SSL Cert and then the ability to configure audio station to stream to Alexa. I own over 12 Synology devices and sale them all the time. You would think synology would give me a bit more time other than just telling me its in beta so they can't help.

If anyone has gone through the process from start to finish in setting up the SSL Cert, and audio station to stream; please post a step by step and screen shots. Synology knowledge base is useless when it comes to anything more than the easiest way to set it up, and without any issues.


It was a bunch of trial and error for me, but it's actually not difficult when you guess at what they're asking for. I'll preface the steps, however, by staying that the Alexa skill, while functional in the strictest technical definition of the word, is quite primitive, and not actually very useful. Some of this it to be expected with beta software, of course, but I feel like it has a long way to go for primetime.

Setting up Alexa skill for Audio Station:
1) If you have not already, Set up DDNS, which is not a new feature, but having a domain name is a prerequisite for the Alexa skill. If you already have a domain name for your network, or another DDNS appliance, you can skip this step, but if you don't know the answer to this question, you don't.
To set up DDNS, in your DSM desktop, go to Control Panel -> External Access -> DDNS -> Add
Use Synology as the service provider, whatever you would like as your hostname, though I recommend the same thing you're using as your QuickConnect ID if you already have one of these. Otherwise just a word that uniquely describes your DiskStation. Provide your DiskStation username and password, and follow the prompts.

2) If you have not already, create a certificate. This is also not a new feature, but is a prerequisite for the Alexa skill. Alternatively, you could create and install a certificate manually, but I'll assume here that, like most people, you have not.
To create a certificate, go to Control Panel -> Security -> Certificates -> Add -> Add a new certificate -> Get a certificate from Let's Encrypt
In the prompts, provide the information you just entered into the DDNS in step 1.
When asked what services you'd like it associated with, use this new certificate for the "Default" service, which encompasses Audio Station

3) Ensure the OAuth Service is installed on your DiskStation, which is required for authenticating your Amazon account to your NAS.
To do this, open Package Center, search for OAuth Service, and click install. It shouldn't require any kind of special setup.

4) Set up the Alexa skill
Open the Alexa app on your phone, or go to alexa.amazon.com and log in with the same account that your Echo devices are registered with.
Go to Skills, search for DS Audio, install the skill, and you'll be asked to provide your DiskStation's information.
The "host" you enter here should be https://<the DDNS name you created in step 1>:5001
So, for example, https://mydiskstationname.synology.me:5001

The Alexa app will then use OAuth to verify your certificate and have you log into your NAS. I had some trouble with this step when I was doing it from a desktop PC inside my network, because the DDNS didn't work locally. I expect this was a curiosity of my exotic network configuration, but if you encounter this problem, try repeating step for from your phone without using WiFi, to ensure the app is correctly able to resolve the domain.

That should do it! Saying "Alexa, tell Audio Station to play X" should find the song titled X in your Audio Station music library and play it. The last I checked, there doesn't seem to be any support for artists or genres yet. Tracks play on repeat instead of stopping when they're done. "Play album X" seems to work, but the album plays in shuffle order for some reason. Asking Alexa the name of what's playing doesn't seem to work yet, either, but this whole thing is pretty new, so I'm hopeful there will be some improvement.
jhmorri2
I'm New!
I'm New!
Posts: 5
Joined: Tue Mar 21, 2017 12:04 am

Re: Amazon Echo/Dot Alexa skills

Postby jhmorri2 » Fri Nov 17, 2017 4:52 am

andrewmv wrote:
jhmorri2 wrote:I called synology as I have been unable to figure out how to setup the SSL Cert and then the ability to configure audio station to stream to Alexa. I own over 12 Synology devices and sale them all the time. You would think synology would give me a bit more time other than just telling me its in beta so they can't help.

If anyone has gone through the process from start to finish in setting up the SSL Cert, and audio station to stream; please post a step by step and screen shots. Synology knowledge base is useless when it comes to anything more than the easiest way to set it up, and without any issues.


It was a bunch of trial and error for me, but it's actually not difficult when you guess at what they're asking for. I'll preface the steps, however, by staying that the Alexa skill, while functional in the strictest technical definition of the word, is quite primitive, and not actually very useful. Some of this it to be expected with beta software, of course, but I feel like it has a long way to go for primetime.

Setting up Alexa skill for Audio Station:
1) If you have not already, Set up DDNS, which is not a new feature, but having a domain name is a prerequisite for the Alexa skill. If you already have a domain name for your network, or another DDNS appliance, you can skip this step, but if you don't know the answer to this question, you don't.
To set up DDNS, in your DSM desktop, go to Control Panel -> External Access -> DDNS -> Add
Use Synology as the service provider, whatever you would like as your hostname, though I recommend the same thing you're using as your QuickConnect ID if you already have one of these. Otherwise just a word that uniquely describes your DiskStation. Provide your DiskStation username and password, and follow the prompts.

2) If you have not already, create a certificate. This is also not a new feature, but is a prerequisite for the Alexa skill. Alternatively, you could create and install a certificate manually, but I'll assume here that, like most people, you have not.
To create a certificate, go to Control Panel -> Security -> Certificates -> Add -> Add a new certificate -> Get a certificate from Let's Encrypt
In the prompts, provide the information you just entered into the DDNS in step 1.
When asked what services you'd like it associated with, use this new certificate for the "Default" service, which encompasses Audio Station

3) Ensure the OAuth Service is installed on your DiskStation, which is required for authenticating your Amazon account to your NAS.
To do this, open Package Center, search for OAuth Service, and click install. It shouldn't require any kind of special setup.

4) Set up the Alexa skill
Open the Alexa app on your phone, or go to alexa.amazon.com and log in with the same account that your Echo devices are registered with.
Go to Skills, search for DS Audio, install the skill, and you'll be asked to provide your DiskStation's information.
The "host" you enter here should be https://<the DDNS name you created in step 1>:5001
So, for example, https://mydiskstationname.synology.me:5001

The Alexa app will then use OAuth to verify your certificate and have you log into your NAS. I had some trouble with this step when I was doing it from a desktop PC inside my network, because the DDNS didn't work locally. I expect this was a curiosity of my exotic network configuration, but if you encounter this problem, try repeating step for from your phone without using WiFi, to ensure the app is correctly able to resolve the domain.

That should do it! Saying "Alexa, tell Audio Station to play X" should find the song titled X in your Audio Station music library and play it. The last I checked, there doesn't seem to be any support for artists or genres yet. Tracks play on repeat instead of stopping when they're done. "Play album X" seems to work, but the album plays in shuffle order for some reason. Asking Alexa the name of what's playing doesn't seem to work yet, either, but this whole thing is pretty new, so I'm hopeful there will be some improvement.


I appreciate the walk through. I had done exactly those steps previously and still recieve the "A Valid SSL Certificate is required for authentication" error. Any ideas?
Pfalder
Trainee
Trainee
Posts: 10
Joined: Wed Sep 26, 2012 9:40 pm

Re: Amazon Echo/Dot Alexa skills

Postby Pfalder » Sat Nov 25, 2017 2:28 pm

I still cannot configure the Alexa skill.
When I input my account link as myname.synology.me:5001 I get the error saying can’t connect ensure external access is available.
I know external access is available as I can connect this address via browser from an off network device.
I thought that Alexa maybe used other ports so I temporarily opened incoming firewall traffic to all but that had no effect.
Since someone at least has this working, what could be going wrong?
danmeljeff
Trainee
Trainee
Posts: 17
Joined: Thu Nov 29, 2007 5:52 am

Re: Amazon Echo/Dot Alexa skills

Postby danmeljeff » Mon Nov 27, 2017 8:55 pm

I went round and round for quite a while, and finally was able to get it to work. The trick for me was to open the 5001 port on my router. I wasn't allowing in external access. I too had to "Enable Amazon Alexa Service" within the DSM Audio Station, but couldn't do this until I opened up the router port.

Hope this helps.
DrO
I'm New!
I'm New!
Posts: 1
Joined: Mon Nov 27, 2017 10:31 pm

Re: Amazon Echo/Dot Alexa skills

Postby DrO » Mon Nov 27, 2017 10:40 pm

I am unable to find the DS Audio skill when I log on to the Alexa website. I'm accessing it from the UK - is this a regional thing?

Return to “Feature Requests & Product Improvement Suggestions”

Who is online

Users browsing this forum: No registered users and 2 guests