Page 1 of 1

Jira on Synology

Posted: Thu Oct 22, 2009 7:46 am
by winfredp
Does someone have experience with installing Jira on Synology ? In my case 209

http://www.atlassian.com/software/jira/

JVM should be running on the box and a seperate (internal) webservice of jira.

Please let me know if someone can share some experience

w

Re: Jira on Synology

Posted: Wed Nov 11, 2009 1:31 pm
by jibjab
I'm interested in this too if anyone has information.
thanks
Adrian

Re: Jira on Synology

Posted: Mon Sep 12, 2011 2:29 pm
by Wzzl

Re: Jira on Synology

Posted: Thu May 10, 2012 6:26 am
by briankb
Thanks for posting that how to Wzzl!

Have you had any issues? I have a DS211+ and I would upgrade to DS1512+ if we could run the entire family of Atlassian products including the new Stash (git repo manager).

What happens when you upgrade from one DSM version to another (like 3.2 to 4.0)?

Re: Jira on Synology

Posted: Sat Jun 08, 2013 7:07 pm
by slavikf
Sadly, link to posterous is not working anymore.
And as I tried to install latest JIRA (6.0.1) on my Synology DS 412+,
I got few issues:
1) Error message: "Sorry, but I could not find gunzip in path. Aborting"
gunzip is present in Synology. It just "different". So, we need to disable that error message.
To do so:
make sure you have gunzip installed and than fix it by editing the file with vi atlassian-jira-X.Y.x32.bin and remove the following lines:

Code: Select all

gunzip -V  > /dev/null 2>&1
if [ "$?" -ne "0" ]; then
  echo "Sorry, but I could not find gunzip in path. Aborting."
  exit 1
fi


2) Then I got another error message:

Code: Select all

Unpacking JRE ...
Starting Installer ...
Error: dl failure on line 864
Error: failed /volume1/Shared/atlassian-jira-6.0.1-x32.bin.12994.dir/jre/lib/i386/client/libjvm.so, because /volume1/Shared/atlassian-jira-6.0.1-x32.bin.12994.dir/jre/lib/i386/client/libjvm.so: cannot handle TLS data


It seems to be issue installing JAVA.
I am not sure, what cam be done about it.
Any idea, how to fix it?

Re: Jira on Synology

Posted: Sat Jun 08, 2013 8:25 pm
by slavikf
I tried to install previous version (tried 5.2.11 and 4.4.5)
No problem with JAVA installation

However, got another issue. Installation aborted with following error:

Code: Select all

 java.io.IOException: Cannot run program "/volume1/Shared/atlassian-jira-5.2.11-x32.bin.21946.dir/bin/setup_user.sh" (in directory "/volume1/Shared/atlassian-jira-5.2.11-x32.bin.21946.dir/."): java.io.IOException: error=2, No such file or directory


I verify and in fact such file exist at this location
And I am running, as root.

Synology starting to disappoint me. This would work without issue on regular PC.

Found this guide:
http://qroot.tistory.com/entry/Synology ... 4%EC%B9%98
But running at the same problem
Copy of the guide:
http://slavikf.dyndns.org/Files/JIRA_Synology.pdf

Re: Jira on Synology

Posted: Sat Jun 08, 2013 11:10 pm
by slavikf
Found solution:
BASH has to be installed on the system, before you can install JIRA

I used following guide to install BASH:
http://literatitech.blogspot.ca/2011/03 ... s210j.html
Copy available here:
http://slavikf.dyndns.org/Files/Literati.pdf

Re: Jira on Synology

Posted: Sat Jun 08, 2013 11:30 pm
by slavikf
And one more thing you would need to do:
According to JIRA install manual (section 3):
https://confluence.atlassian.com/displa ... A+to+MySQL

You'll need to download MySQL driver.
Not sure why it could not be included.

Here is direct link to it:
http://cdn.mysql.com/Downloads/Connecto ... 5.1.25.zip

Re: Jira on Synology

Posted: Tue Aug 27, 2013 5:31 am
by slavikf
I upgraded my Synology to DSM 4.3 and now JIRA will not start.

So, I troubleshooted and found, that problem is that bash will not start.

Solution:
Need to execute this command: (it needs to be executed once, after each DSM upgrade):

Code: Select all

ln -s /opt/bin/bash /bin/bash

Re: Jira on Synology

Posted: Sat Dec 14, 2013 7:38 am
by toppplaya312
So, I see this hasn't been updated in a while. I just wanted to confirm the reasons that the earlier versions could be installed, but not the 6.x.x+ versions. That is because 5.2.11 is the last one that is based on Java 6. Java 7 is only supported on the ARM / PPC versions of the DiskStations.

I really want to make sure that the newer 6.x.x versions of Jira can be installed. So, I'm wondering if anyone has heard anything about Java 7 support on the x86 versions of DiskStations.

Also, does anyone have any idea what the incompatibility between x86 and Java 7 is? I assume it has something to do with the TLS data error; however, I'm not sure what is exactly causing the error, yet. I'm still investigating, but has anyone else looked into this?

Re: Jira on Synology

Posted: Sun Apr 20, 2014 10:53 am
by SimonH
Note you can find a copy of the Posterous article on the Wayback Machine https://web.archive.org/web/20130513184943/http://websel.posterous.com/jira-on-the-synology-nas-reloaded-dragon-ques but author is the same as http://webselblog.wordpress.com/2011/09/06/installing-jira-4-on-a-synology-diskstation/

I've got a DS213+ (PPC) which I was wondering about installing JIRA issue tracker and Agile on but it only has 512MB - the JIRA docs (https://confluence.atlassian.com/display/JIRA/Installing+JIRA+on+Linux) talk about 2GB so it's probably a non-starter on a relatively small NAS (and probably not a good use of Synology resources really, compared to running in, say, a 4GB VM).