RT2600AC and Intel AC-7260 - I found a solution for the 5Ghz SSID loss!

Discussion about the hardware compatibility of the Synology router.
Forum rules
1) On 12/25, Synology Forums will be getting a new layout. During this time, content will still be accessible but you will be unable to make new threads and posts.

2) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://account.synology.com/support/support_form.php?lang=enu

3) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
Moan
Trainee
Trainee
Posts: 13
Joined: Fri Sep 29, 2017 12:48 pm

RT2600AC and Intel AC-7260 - I found a solution for the 5Ghz SSID loss!

Postby Moan » Tue Oct 10, 2017 7:20 pm

Around two weeks ago I bought the RT2600AC router. So far I loved it, but I experienced a strange problem with the 5Ghz radio. The first thing I did after buying the router was updating the firmware to version 1.1.5-6542 (which was already released).

Hardware I have:
- Laptop MSI GT70 2PC with Intel AC-7260 WiFi.
- Router: RT2600AC.
- NAS Drive (WDMyCloud) connected to the router by Ethernet.

Problem symptoms:
Whenever I changed the 5Ghz radio channel width to: "80+80" or "20/40/80/160" and started transferring a big file from my NAS using WiFi AC - the speed was dropping from ~500Mb/s to 0. After that I couldn't open any website. After few seconds, the 5Ghz SSID was disappearing and it couldn't be found by any device (smartphones, laptop). The only solution that fixed this problem was a router reboot or changing 5Ghz radio settings and applying changes. After that the network SSID was appearing again, but whenever I started copying a file from the NAS - it was crashing again.

What solutions I tried:
- Restoring router factory settings - didn't help.
- Getting help from the Synology Support. They tried to help and I gave them a remote access. After some days they said they're unable to reproduce the problem and asked me to send the router for warranty.
- Refunding the router, and getting a new one.

Final tests:
Today, I received a new router RT2600AC from a different store. Since I knew about those 5Ghz problems I decided to make some tests before the firmware update.
The first version installed on the router was: 1.1.1-6414 Update 1. The 5Ghz radio did not hang when I was transferring files, however the speed was lower than before (200-300Mb/s instead of 500-600Mb/s ~4 meters away from the router).
After I updated the firmware to the newest version (1.5.5-6542 Update 2) - the problem returned. It was exactly the same as on the RT2600AC which I sent back :/ I was very disappointed, because I simply like the SRM firmware and I really wanted to use it. That's why I bought the same router model after refunded it... I mailed the support again attaching the 42 minutes long video (recorded screen of my laptop) where I showed what happens before and after the update.

How I found a solution?
I know a little about the Linux (at least basic things). I enabled SSH access and viewed file: /var/log/wifi.log.
I noticed, that whenever problem occurs there are following lines in the log:

Code: Select all

2017 10 10 15 01 36 SynologyRouter kernel: [  280.240018] [wifi0] FWLOG: [286439] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 37 SynologyRouter kernel: [  281.240174] [wifi0] FWLOG: [287120] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 38 SynologyRouter kernel: [  282.240362] [wifi0] FWLOG: [287800] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 38 SynologyRouter kernel: [  282.240362] [wifi0] FWLOG: [288480] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 39 SynologyRouter kernel: [  283.240549] [wifi0] FWLOG: [289149] WAL_DBGID_DEV_TX_TIMEOUT ( 0x0, 0x1 )
2017 10 10 15 01 40 SynologyRouter kernel: [  284.240706] [wifi0] FWLOG: [289829] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 40 SynologyRouter kernel: [  284.240737] [wifi0] FWLOG: [290509] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 41 SynologyRouter kernel: [  285.241143] [wifi0] FWLOG: [291189] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 42 SynologyRouter kernel: [  286.241362] [wifi0] FWLOG: [291869] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 42 SynologyRouter kernel: [  286.241393] [wifi0] FWLOG: [292549] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 43 SynologyRouter kernel: [  287.241580] [wifi0] FWLOG: [293229] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 44 SynologyRouter kernel: [  288.241768] [wifi0] FWLOG: [293909] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 44 SynologyRouter kernel: [  288.241799] [wifi0] FWLOG: [294589] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 45 SynologyRouter kernel: [  289.241986] [wifi0] FWLOG: [295230] WAL_DBGID_DEV_TX_TIMEOUT ( 0x0, 0x1 )
2017 10 10 15 01 46 SynologyRouter kernel: [  290.242424] [wifi0] FWLOG: [295910] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 46 SynologyRouter kernel: [  290.242455] [wifi0] FWLOG: [296590] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 47 SynologyRouter kernel: [  291.242611] [wifi0] FWLOG: [297271] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )
2017 10 10 15 01 48 SynologyRouter kernel: [  292.243049] [wifi0] FWLOG: [297951] WAL_DBGID_DEV_TX_TIMEOUT ( 0x7, 0x1 )

I did some research on google with "WAL_DBGID_DEV_TX_TIMEOUT" and I found this website: https://gtacknowledge.extremenetworks.c ... unreliable
And that was it! When I changed the "Throughput Booster" to "Disabled" in device properties the problem was gone! I can finally use 80+80 or 20/40/80/160 channel width.

Solution (Windows):
1. Go to "This PC", click the right mouse button and click on "Properties".
2. Click on the "Device Manager" link on the left.
3. In the Device Manager go to "Network Adapters", and click the right mouse button on "Intel(R) Dual Band Wireless-AC 7260", then "Properties".
4. Go to "Advanced" tab, and find option "Throughput Booster", then switch it to "Disabled" and press "OK" to apply changes. Your network adapter will restart.
Image

Conclusion:
The problem is caused by the Intel AC 7260 settings, but was not present with the older firmware version of RT2600AC. In my opinion the router should not shut down / crash the 5Ghz radio, even when the client's network adapter is "broken". So definitely it should be updated and I asked the support to do it. Anyway, since I spent some time on this issue I decided to post the solution at this forum, maybe somebody else will find it useful.

Greetings.
prevaljo
Trainee
Trainee
Posts: 15
Joined: Tue Apr 23, 2013 9:53 pm

Re: RT2600AC and Intel AC-7260 - I found a solution for the 5Ghz SSID loss!

Postby prevaljo » Mon Dec 04, 2017 10:38 pm

Great post @Moan, I have an issue with the latest update on my Synology router where the 5 Gig WLAN drops clients, unfortunately it happens to Cellular clients so a Windows fix is no use. It does however highlight the fact that the latest Synology release is buggy and needs to be fixed.
Moan
Trainee
Trainee
Posts: 13
Joined: Fri Sep 29, 2017 12:48 pm

Re: RT2600AC and Intel AC-7260 - I found a solution for the 5Ghz SSID loss!

Postby Moan » Tue Dec 05, 2017 5:19 pm

@prevaljo, I also still experience 5Ghz drops, but not as often as with the "Throughput Booster" bug.
I noticed, that when I set the Channel width to "80+80Mhz" and Channel to: "112 + 58" - the 5Ghz radio was crashing every 2-3 days, usually when no devices were connected to it. For now, I set "80+80Mhz" and Channel to "Auto" and it seems to work stable for over 1 week. I agree that the current firmware is not stable, and I really hope it will be fixed soon. Routers are devices that should work flawlessly.

Return to “Hardware Compatibility”

Who is online

Users browsing this forum: No registered users and 1 guest