Please Help - Major Virus killing devices at random

Topics pertaining to SRM usage, usability and management
Forum rules
Synology Community is the new platform for the enthusiasts' interaction, and it will soon be available to replace the Forum.
wsu99999
I'm New!
I'm New!
Posts: 1
Joined: Mon Jun 11, 2018 6:34 pm

Please Help - Major Virus killing devices at random

Unread post by wsu99999 » Mon Jun 11, 2018 7:01 pm

I need your help. I have tried reaching out to Synology directly several times but they would push me off, and now I no longer have access to the email address (one I've had for 6 years) due to whatever virus I'm dealing with.

EVERY device in my home is infected. 4 Kindle Fires, 5 Laptops, 1 brand new Ryzen PC (a month old build) 3 ANDROID DEVICES, one of which is now bricked!, MY SMART TV (LG WebOS), probably my coffee maker at this point.

The only thing connecting all of these is the router. (Synology RT2600), over a 1 gig connection.

All of my internet traffic is redirected. If I do a google search for anything specific "viruses that redirect internet traffic", I will get what appears to be google results, but they are coming from a different engine (looked in the html code) and they are extremely limited.

My internet is all cached - and poorly at that. Every link I click isn't live.

My computers all run like crap - even the new build (which was amazing until hit with this). They will load decent, then after about 5 minutes begin to crash about 80% of the time (even when not connected to the router).

OK - I know this sounds crazy - but this virus intercepts my CD ROM drive (bluray drive) and if I load a boot disk, it mirrors it and runs their copy of it. Another crazy sounding thing is I can not unconnect from a random usergroup/workgroup even though all of my settings say not to allow remote connections - no antivirus system seems to work (even when I put legitimate viruses on the computer) - it is as if they have disabled the virus database.

All certificates in windows are forged - they are also stored in my bios. I can't get rid of them (have tried flashing and resetting cmos in bios, no change).

It appears that it is actually living on a pci connection (several actually). I booted some old utilities and noticed some weird PCI activity.

Also- my drive seems to be "rooted" for lack of a better term. My c: is something like :\\xxx - you can only notice when installing certain programs. Tried Norton Secure Erase, but it said it was incompatible with the way my hard drive is setup.

I am very technical (not from a coding standpoint, but I know computers, have been building them over 27 years) - I have never encountered anything like this.

1 do not know what to do at this point. I've done so many dban's and installs of OS's over the past MONTH that I can do them in my sleep. I've resetted the MB, Router, Modem, you name it.

This began almost a month ago to the day - I am honestly a little afraid.

I've reached out to Microsoft, Malwarebytes, and had two security experts look at it and scratch their heads. They can't determine what the problem is other than there is a problem. They told me to reach out to the FBI - but I really just want a fix to this problem. I'm giving it a few more days then will be speaking to the boys in blue.

Anyone else having anything remotely similar?

User avatar
eaz
Specialist
Specialist
Posts: 1158
Joined: Sun Mar 04, 2007 9:04 pm

Re: Please Help - Major Virus killing devices at random

Unread post by eaz » Mon Jun 11, 2018 7:42 pm

I would reach out to my antivirus supplier, if anyone can solve it, they are.

It is clear, if everything is infected, that you need to shut off everything, Do not switch anything on again when attached to a network.
Do not trust your internet modem too, something may have got access to the modem/router. Reset it to manufacturere default first.

Stop using the network and decontaminate each device at a time, preferably started from a USB disk (take care to make this read only).

Add one decontaminated device at the time. Adding one infected one can re-infect everything.
Please share if a reply was useful or how the issue was solved, it helps other DS users.

DS415+ (4TB HGST+ 4TB Seagate raid1 + 2*480GB SSD raid1), DS212+ (2*WD red 2TB), previous DS411J, DS106

User avatar
WST16
Versed
Versed
Posts: 261
Joined: Sun Oct 02, 2016 10:03 am

Re: Please Help - Major Virus killing devices at random

Unread post by WST16 » Tue Jun 12, 2018 6:22 pm

Wow man! Burn the house and run for your life.

That’s what I’d do. Sorry I couldn’t resist :-|
DS216+II : DS118 : APC Back UPS ES 700 : Mac user

NigelL
Novice
Novice
Posts: 56
Joined: Sun Jun 01, 2008 3:20 pm

Re: Please Help - Major Virus killing devices at random

Unread post by NigelL » Wed Jun 13, 2018 9:03 am

wsu99999 wrote:
Mon Jun 11, 2018 7:01 pm
OK - I know this sounds crazy - but .... EVERY device in my home is infected... I am very technical .... I am honestly a little afraid... They told me to reach out to the FBI...
'Just because you're paranoid doesn't mean they aren't after you.' - Joseph Heller :wink:

User avatar
Twisted World
Seasoned
Seasoned
Posts: 558
Joined: Sun Jun 12, 2016 8:29 am
Location: Netherlands
Contact:

Re: Please Help - Major Virus killing devices at random

Unread post by Twisted World » Wed Jun 13, 2018 7:01 pm

Sounds to me like you are the first person in the entire world EVER who has so many different devices all infected at once. I find it kind of hard to believe actually... :?

Image
[ DS918+ | DS916+ | DS216+II | DS1815+ | DS115j | EDS14 | DS212+ | DS211+ | DS411slim ]

sincarne
Guru
Guru
Posts: 1578
Joined: Wed Feb 15, 2017 9:57 pm

Re: Please Help - Major Virus killing devices at random

Unread post by sincarne » Thu Jun 14, 2018 4:06 am

this good read op :lol:
you have US government attack you :mrgreen:

Post Reply

Return to “Installation and Configuration”