Most (local network) pages through WebVPN don’t load.

Topics pertaining to SRM usage, usability and management
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/support_form.php?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
relink2013
Beginner
Beginner
Posts: 20
Joined: Sun Dec 29, 2013 12:38 am

Most (local network) pages through WebVPN don’t load.

Postby relink2013 » Sat Jan 13, 2018 1:48 am

I bought this router (AC1900) specifically for the webvpn feature. However when I use it most of the local servers I try to connect to either get stuck on the synology loading animation, or they just display an empty white page.

On the other hand some (1) of my pages do work such as my unraid webui loads fine.

What can I do? Also the synology vpn app for iOS works beautifully.
Babylonia
Distinguished
Distinguished
Posts: 818
Joined: Tue Jul 26, 2016 10:47 am

Re: Most (local network) pages through WebVPN don’t load.

Postby Babylonia » Sat Jan 13, 2018 8:40 am

Can you give examples which pages from servers don't load?
What is the down-- / upload speed of your internet connection.
What is the down-- / upload speed of the external internet connection you try to connect from, to your home.
relink2013
Beginner
Beginner
Posts: 20
Joined: Sun Dec 29, 2013 12:38 am

Re: Most (local network) pages through WebVPN don’t load.

Postby relink2013 » Sat Jan 13, 2018 12:45 pm

Sure, most of the pages I am trying to access are servers I’m hosting at home. So far I have tried the following.

UnRaid - works beautifully
TVHeadend - get login prompt, then blank white page.
NextPVR - blank white page
OnlyOffice - stuck at “Connecting via WebVPN”

Those are the only servers I have tried so far, and only 1 out of 4 work.

My home internet connection (host) is 300Mb X 25Mb
The remote internet I’m connecting with is 200Mb X 50Mb
Both ISP are Spectrum
relink2013
Beginner
Beginner
Posts: 20
Joined: Sun Dec 29, 2013 12:38 am

Re: Most (local network) pages through WebVPN don’t load.

Postby relink2013 » Mon Jan 15, 2018 2:36 am

So I’ve had a little bit of progress, I can get to the OnlyOffice login page, but when I click the lgoin button nothing happens. All the other services still just display a blank white screen.

Any help is greatly appreciated, the VPN plus server was 100% of the reason I bought the synology router in the first place.
Babylonia
Distinguished
Distinguished
Posts: 818
Joined: Tue Jul 26, 2016 10:47 am

Re: Most (local network) pages through WebVPN don’t load.

Postby Babylonia » Mon Jan 15, 2018 3:12 am

To use "WebVPN", do you have a proper SSL "wildcard" certificate for your WAN IP domain??
relink2013
Beginner
Beginner
Posts: 20
Joined: Sun Dec 29, 2013 12:38 am

Re: Most (local network) pages through WebVPN don’t load.

Postby relink2013 » Mon Jan 15, 2018 2:19 pm

No, at least not yet. I have just been clicking through the cert errors for now. I wanted to get it working before spending the extra money.
Babylonia
Distinguished
Distinguished
Posts: 818
Joined: Tue Jul 26, 2016 10:47 am

Re: Most (local network) pages through WebVPN don’t load.

Postby Babylonia » Mon Jan 15, 2018 7:50 pm

Without certificate it shall not work as such, as in todays browsers https connections security wise, the pages shall be blocked.
You have to make exceptions for each webpage it shall generate, as connections do have a random code, as prefix in front of a domain name.
One or other web-browser do have better solutions to make exceptions (Firefox do have better options in my opinion).
But not praticall at all, as every time a random prefix shall be generated.

By testing, in my opnion "WebVPN" has to many disadvantages and "insecure" for using, as a follow-up tab within your browser can have a "normal" connection outside VPN.
Better to use one over the other VPN-methods. More easy in usage and better control.
Maurice118
Sharp
Sharp
Posts: 178
Joined: Wed Jul 24, 2013 9:02 pm
Contact:

Re: Most (local network) pages through WebVPN don’t load.

Postby Maurice118 » Mon Jan 15, 2018 9:15 pm

@relink2013 which browser do you use? Have you already looked at the error console of your browser, maybe error messages could show some more inside what is going wrong?
Another option is to contact synology and explain your problem there. They are normally very helpful to solve issues with vpn plus server.
aka divx118 #synology at freenode.net
rt1900ac packages https://synology.timara.nl
relink2013
Beginner
Beginner
Posts: 20
Joined: Sun Dec 29, 2013 12:38 am

Re: Most (local network) pages through WebVPN don’t load.

Postby relink2013 » Mon Jan 15, 2018 9:18 pm

Maurice118 wrote:@relink2013 which browser do you use? Have you already looked at the error console of your browser, maybe error messages could show some more inside what is going wrong?
Another option is to contact synology and explain your problem there. They are normally very helpful to solve issues with vpn plus server.


I contacted synology on Friday and have still not heard back yet. I primarily use Firefox, but I also tried Chrome, IE, and Edge, it’s the same in all of them. How would I go about pulling up this error log?
Maurice118
Sharp
Sharp
Posts: 178
Joined: Wed Jul 24, 2013 9:02 pm
Contact:

Re: Most (local network) pages through WebVPN don’t load.

Postby Maurice118 » Mon Jan 15, 2018 9:27 pm

Well in chrome you can just right click on the page and select "inspect" then you go to the tab "console" to see error messages. For firefox, IE or edge there must be something similar. Just googling error console and the browser name should get you going.
For synology support, you have to be a bit more patient. Normally about a week for the first response at least in my experiences with them.
aka divx118 #synology at freenode.net
rt1900ac packages https://synology.timara.nl
Babylonia
Distinguished
Distinguished
Posts: 818
Joined: Tue Jul 26, 2016 10:47 am

Re: Most (local network) pages through WebVPN don’t load.

Postby Babylonia » Tue Jan 16, 2018 12:09 am

As for checking security issues by a browser. It could also be related to the "HSTS" security detection / control.
To undo, more information and testing WebVPN in general I wrote on the Dutch Synology forum, see translation by Google < HERE >

Return to “Installation and Configuration”

Who is online

Users browsing this forum: Babylonia and 1 guest