DSM running as container cannot access SynoCommunity

Discussion room for Docker, a lightweight virtualization application that gives you the ability to run thousands of containers created by developers from all over the world on DSM
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
MacLovin
I'm New!
I'm New!
Posts: 1
Joined: Mon Oct 16, 2017 1:52 pm

DSM running as container cannot access SynoCommunity

Unread post by MacLovin » Mon Oct 16, 2017 2:13 pm

Strange problem this and it's repeatable as a friend tried to do this on his Synology and got exactly the same result.

I'm running DSM in a container on docker for a number of reasons, primarily as it allows me to run an instance of DSM through my VPN. So far this has all been working perfectly and just ticks along running Download Station without any issues. However, I want to run Headphones on this instance as well so I tried to add the Syno Community repository to Package Centre, but no matter what I do and no matter if I have the VPN connected or not I get the same problem "Invalid Location". I have tried changing the trust level but that doesn't make any difference either.

Any ideas? Am I missing something really obvious here?

Cheers!

Image

mightbetrue
Versed
Versed
Posts: 273
Joined: Sun Oct 02, 2016 9:41 am

Re: DSM running as container cannot access SynoCommunity

Unread post by mightbetrue » Thu Oct 19, 2017 9:35 am

While the SynoCommunity mast brancher does not cover the dockerx64 plattform, the dsm6 branch does. You need spks for the dockerx64 plattform.
I guess it's just a matter of time, until the changes from the dsm6 branch get merged into the master and used for building the available packages.

If you can't wait, just use the synocommunity docker image , start a container, checkout the dsm6 branch sources (all required sources and tool chains) and compile the spk yourself.
The whole process might look a little bit scary, but it's actually not that hard.

Locked

Return to “Docker”