DSM 5.1 - 5021 - Update 2

A new DSM aimed at boosting Data security (new Security advisor, AppArmour and digital signature for packages...), increasing business productivity (new Proxy Server, IPv6 support, NFS VAAI...), creating a more integrated private cloud (Windows ACL support in Cloud Station, support for OneDrive, Box and hubic in Cloud Sync as well as cloud backup to Microsoft Azure...), and providing flexible collaboration tools with Note Station/DS note and Public link sharing in all key multimedia packages
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
pvs
Student
Student
Posts: 73
Joined: Fri Mar 21, 2014 5:39 pm

DSM 5.1 - 5021 - Update 2

Unread post by pvs » Sun Dec 28, 2014 1:06 am

I went ahead and upgraded. I am happy to report that it went VERY smoothly ... better than the past few, actually.

The update itself took only 1 minute ... another 2 to shut down, and another 2 until the beep and the solid blue LED.

I did NOT reboot the NAS, nor my network switches (which I needed to do for the past two upgrades). I just proceeded to log in as my regular user account, and disable the Admin account. (I always run upgrades from the Admin account. So I enable it before the upgrade and then log in as Admin, do the upgrade, and then immediately disable it.) I then proceeded to test the various features I depend upon.

So far, I have tested Windows File Service, HTTP/HTTPS, FTP, SFTP, TFTP, NTP, DS File (from iOS 7), Keyed SSH and SCP. All appear to be working well.

FWIW, I typically need to add some lines to /etc/httpd/conf/httpd.conf-user after these upgrades, to re-enable .htaccess authentication and hostname lookups using dns. This is the first upgrade that seems to have preserved my settings! I am very happy about this, though I believe I will continue to check those lines after upgrades.

Anyway, good luck to all, and an early Happy New Year!!! :D
« DS 1813+ | DSM 5.2-5967 Update 8 | 8 * Western Digital WD40EFRX (in a single SHR Disk Group) | Motorola NVG589 Gateway | Cisco SG300-10 Switch | CyberPower 1350PLCLCD »

adam.sloan
I'm New!
I'm New!
Posts: 1
Joined: Fri May 30, 2014 12:29 pm

Re: DSM 5.1 - 5021 - Update 2

Unread post by adam.sloan » Sun Dec 28, 2014 2:14 am

I upgraded last night from the previous 5.1 release to 5021 then applied update 2 and no issues seen so far.

No issues seen with my volumes mounting too either on my DS1813+

Happy new year!

Cheers,
Adam.

Ferry
Novice
Novice
Posts: 44
Joined: Tue May 12, 2009 10:10 am

Re: DSM 5.1 - 5021 - Update 2

Unread post by Ferry » Sun Dec 28, 2014 2:22 am

Unfortunatelly, not my experience: I just updated my DS210J to 5021 Update 2 and now my DS marks, in Control Panel, as it has 1 update pending, but when it tries to check, says "System is busy". It has not rebooted after update installation process, blue led and HD green ones are solid, only net green led blinks every some seconds.

I can access it by web browser, but it cannot be accessed as a net volume, FTP server or DLNA server. It does not allow me to reboot, it says theres an ongoing DSM update, but it has been in this very state for two hours or so.

What can I do? I cannot lose the data, of course, but I need to access it.

Help me, please.

Saluditos,

Ferrán.

SteveNYC
I'm New!
I'm New!
Posts: 3
Joined: Sun Dec 28, 2014 2:42 am

Re: DSM 5.1 - 5021 - Update 2

Unread post by SteveNYC » Sun Dec 28, 2014 2:46 am

Not my experience either. Update occurred overnight as scheduled. Had tons of trouble viewing DiskStation volumes via AFP. No trouble from File Station. Happened to have the previous version of DSM on my computer so I downgraded. AFP working fine now.

User avatar
Rusty1281
Sagacious
Sagacious
Posts: 3246
Joined: Fri Jun 03, 2011 10:51 pm

Re: DSM 5.1 - 5021 - Update 2

Unread post by Rusty1281 » Sun Dec 28, 2014 10:30 am

ds211j and ds412+ all went well. Everything works (plex, webstation, tiny rss, DBs etc...)
Synology DS918+ (4x4TB WD RED - RAID 5 with 2x250GB 960EVO NVMe) | Synology DS412+ (4x3TB WD RED - RAID 5) | RT1900AC

unxadm
I'm New!
I'm New!
Posts: 5
Joined: Sun Nov 10, 2013 5:24 pm

Re: DSM 5.1 - 5021 - Update 2

Unread post by unxadm » Sun Dec 28, 2014 2:57 pm

I upgraded this morning from the previous 5.1 release to 5021 then applied update 2 and no issues seen so far. I'm running an 1813+ with a DX513 attached filled with WD Red 3.0 TB drives. No modifications.

Thanks.

htfu
I'm New!
I'm New!
Posts: 1
Joined: Sun Dec 28, 2014 2:57 pm

Re: DSM 5.1 - 5021 - Update 2

Unread post by htfu » Sun Dec 28, 2014 3:06 pm

DS214+ - no issues. Media services all working as expected (Photo, Music, Video). Shares mounted from MacMini without any issues. Hope that helps.

Ferry
Novice
Novice
Posts: 44
Joined: Tue May 12, 2009 10:10 am

Re: DSM 5.1 - 5021 - Update 2

Unread post by Ferry » Sun Dec 28, 2014 5:06 pm

Well, I finally solved the issue pulling the power plug. I first tried to access my DS via Telnet and force a reboot, but it didn't work. I mean, I was able to access and write the command ("reboot -f") but it did nothing, so I pulled the plug.

My DS rebooted, took a long time to do it, but it finally did and I can access all the services I use (Time Machine, FTP, AFP, VPN…), but no update has been made.

I think I'll try a manual update later…

Saluditos,

Ferrán.

Cat Scratch
Novice
Novice
Posts: 56
Joined: Mon Jan 27, 2014 10:00 pm

Re: DSM 5.1 - 5021 - Update 2

Unread post by Cat Scratch » Sun Dec 28, 2014 7:40 pm

As I posted in another thread, 5021 - Update 2 seems to be working fine for me but I only use the DS as a large shared drive in my local LAN (backups, pictures, movies, etc).

For those who use their systems more extensively and are having problems, you have my sympathy.
Synology DS1813+ (4Gb RAM) w/8 x Seagate ST10000VN004 (In a single SHR2 Volume)
CyberPower PR1500LCD UPS - Synology RT2600ac Router - Arris SB6183 Modem - Netgear GS116 Switch - CAT6 Cabling

Wolf
Sharp
Sharp
Posts: 171
Joined: Wed Dec 05, 2012 12:49 pm
Location: Italy

Re: DSM 5.1 - 5021 - Update 2

Unread post by Wolf » Sun Dec 28, 2014 11:22 pm

Updated my DS213+, no problem to report.
Router/Firewall pfSense 2.4 - Supermicro A1SRi-2558
AP Netgear R7000 (FW Stock)
Switch Cisco SG350-10
HTPC Intel NUC5i3RYH
NAS Synology DS1515+ (5 x WD50EFRX) 16GB RAM
NAS Synology DS213+ (2 x ST3000DM001)
Laptop AlienWare M17xR2

User avatar
mark-in-seattle
Rookie
Rookie
Posts: 32
Joined: Mon Jan 23, 2012 11:52 am

Re: DSM 5.1 - 5021 - Update 2 - OK on DS212j

Unread post by mark-in-seattle » Mon Dec 29, 2014 1:00 am

Upgraded without incident on a DS212j all the way from DSM 4.3 in stages up to this DSM 5.1 Update 2. Helping my brother in Boston utilize his Synology NAS.

Very simple system with only a few packages, however plan to install OpenVPN and configure for iOS remote secure access as have done with my DS1512 in Seattle.
I am Godot...sorry for the wait.

Pgale
Rookie
Rookie
Posts: 30
Joined: Sun Apr 27, 2014 6:47 pm

Re: DSM 5.1 - 5021 - Update 2

Unread post by Pgale » Mon Dec 29, 2014 10:25 am

DS1815+ updated to update 2 with no problems found so far. (Unlike the previous version!)

WillySis
I'm New!
I'm New!
Posts: 3
Joined: Mon Dec 29, 2014 10:35 am

Re: DSM 5.1 - 5021 - Update 2

Unread post by WillySis » Mon Dec 29, 2014 10:59 am

I updated my DS211j to DSM 5.1 - 5021 update 2 yesterday using the automatic update. Since then it is inpossible to acces the DS through the web interface. It does recognise the password (replies useraccount or password not recognized), but with the right password I get a reply "Verbinding vervallen. Meld u opnieuw aan" (in Dutch). Translated in to English this wil be something like "Connection lost. Please reconnect". Wich is a never ending loop.
Nearly all other functions (Disk-acces, Audiostation, Photostation, FTP, webpages) are working as normal.
So the Nas is not totally bricked, but the use is quite limmited.

Did not find any solution to come out of this loop.
Anyone got a reply from Synology helpdesk or knows a solution?

Ferry
Novice
Novice
Posts: 44
Joined: Tue May 12, 2009 10:10 am

Re: DSM 5.1 - 5021 - Update 2

Unread post by Ferry » Mon Dec 29, 2014 12:27 pm

Well, I just did a manual update, and all seems to be working OK: my DS did its reboot process after uploading the .pat file and everything went as supposed to go.
WillySis wrote:Since then it is inpossible to acces the DS through the web interface.
Have you tried to access it via Telnet? On a Mac, open Terminal and type:

telnet IP-ADDRESS-OF-YOUR-DS

In Windows, same in a System Prompt window (search for and execute "cmd" command, it will open a system prompt window)

It will ask for login and password. Try with root and its corresponding password, at least you'll be able to issue some commands, f.ex., "reboot".

Saluditos,

Ferrán.

WillySis
I'm New!
I'm New!
Posts: 3
Joined: Mon Dec 29, 2014 10:35 am

Re: DSM 5.1 - 5021 - Update 2

Unread post by WillySis » Mon Dec 29, 2014 2:37 pm

TelNet won't work. I had to switch if of due to many hack-attacks.

Locked

Return to “DiskStation Manager 5.1-5004 and onward versions”