No HTTPS connection to local servers

Discussion room for Proxy Server package
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
Rafkat
Beginner
Beginner
Posts: 27
Joined: Wed May 29, 2013 3:50 pm

No HTTPS connection to local servers

Postby Rafkat » Fri Oct 10, 2014 4:25 pm

Hi guys,

Is anyone experiencing same issue as me - I'm not able to access https sites inside of my network (i.e. NAS DSM, SickRage, CouchPotato etc), though I can access http site such as Plex.

Many thanks.
User avatar
ds410boy
Versed
Versed
Posts: 249
Joined: Wed Nov 03, 2010 9:30 pm

Re: No HTTPS connection to local servers

Postby ds410boy » Sun Oct 19, 2014 12:03 pm

Do you not exclude local address from the proxy on the browser setting ?
User avatar
cread
Versed
Versed
Posts: 292
Joined: Sat Jan 08, 2011 5:56 am

Re: No HTTPS connection to local servers

Postby cread » Sat Oct 25, 2014 5:16 pm

I'm having the same issue. Browser set to no proxy.
Chrome reports connection was rejected.
Firefox was a bit more brief.
Same results in IE
http://192.168.1.2:5000 is ok
https://192.168.1.2:5xxx <-port number matched the one in the network tab (altered from baseline)

OK: while typing this I tried going back to the default of 5001, it worked!
I then reset the number back to my altered port number and ........ it worked!

So try setting the number to the default and then back to any non-standard port you were using. That seems to fix it.
Smells a little like a config translation/install issue.
- Chip
DS916+, DSM 6.1.3-15152 Update 5, 2x HGST NAS 4T HDN724040ALE640, USB backup of DS, APC UPS
Apache 2.2,Audio,Calendar,CardDav,Cloud Server,Docker,Doc Viewer,Download,File,Media,Note,Office,Surveillance,Text,VPN,Web,Audio,Photo,Python,Hyper Backup, WebDav, MariaDB, PHP7, (SMB, SSH, FTP)
DS211, DSM 6.0.2-8451 Update 6, 2x HGST NAS 4T HDN724040ALE640, USB backup of DS,
PC= Win7, I7-860 Trubo@3.5G, 8G, and 5T HD's installed
User avatar
cread
Versed
Versed
Posts: 292
Joined: Sat Jan 08, 2011 5:56 am

Re: No HTTPS connection to local servers

Postby cread » Sat Nov 08, 2014 11:23 pm

Still have this issue on 5004 (5.1 release). It occurs each time I reboot (something I did not notice as I stopped rebooting due to issue with the drives being detected as new).
- Chip
DS916+, DSM 6.1.3-15152 Update 5, 2x HGST NAS 4T HDN724040ALE640, USB backup of DS, APC UPS
Apache 2.2,Audio,Calendar,CardDav,Cloud Server,Docker,Doc Viewer,Download,File,Media,Note,Office,Surveillance,Text,VPN,Web,Audio,Photo,Python,Hyper Backup, WebDav, MariaDB, PHP7, (SMB, SSH, FTP)
DS211, DSM 6.0.2-8451 Update 6, 2x HGST NAS 4T HDN724040ALE640, USB backup of DS,
PC= Win7, I7-860 Trubo@3.5G, 8G, and 5T HD's installed
lcompston
Beginner
Beginner
Posts: 21
Joined: Sun Dec 23, 2012 3:17 pm

Re: No HTTPS connection to local servers

Postby lcompston » Tue Nov 25, 2014 11:23 am

How to improve your Web Proxy Auto Discovery experience and allow SSL to connect - the HTTPS Interface of DSM for example works with this on my implementation - http://forum.synology.com/enu/viewtopic.php?f=246&t=93580
h00ligan
Beginner
Beginner
Posts: 21
Joined: Sat Apr 20, 2013 5:48 am

Re: No HTTPS connection to local servers

Postby h00ligan » Tue Feb 17, 2015 6:16 am

Doesn't this only apply if you're running dhcp and DNS on the synology?

I'd like to get a proxy setup here but two things

1) local https connection issue
2) any way to add bulk lists?

Return to “Proxy Server”

Who is online

Users browsing this forum: No registered users and 1 guest