Proxy blocking connection on Windows 8.1

Discussion room for Proxy Server package
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
SeeGull
I'm New!
I'm New!
Posts: 2
Joined: Sun Dec 27, 2015 4:51 pm

Proxy blocking connection on Windows 8.1

Postby SeeGull » Sun Dec 27, 2015 5:51 pm

NAS: DS1815+
DSM: 5.2
WiFi: D-Link USB Access Point

I got the system set up so that with 'Enforce Proxy Server for Wireless Router Mode' and it appears to work fine for all manner of Windows 7, Apple and Android devices. No need to set proxy details on each device. Just connect to the Access Point and surf away.

I just got an Acer All-in-one running Windows 8.1

It connects to the AP o.k. the system status even reports that it is connected to the Internet. However, all URLs return an error message saying that access is denied and to contact system Admin (me).

Manually setting proxy IP and Port on the client results in an error message indicating that the proxy is not responding.

Unchecking the 'Force Proxy Server for Wireless...' box and leaving the client proxy settings blank results in a successful connection and all URLs can be reached.

This behaviour can be duplicated on IE11 and Chrome.

At all times (with or without a successful Internet connection) can be pinged successfully and the Windows 8.1 client can also connect to various public and private directories on the NAS.

Is this a W8.1 specific problem or is it just uncovering something wrong at a deeper level?

Many thanks in advance for all help and support.
htc2010
Rookie
Rookie
Posts: 30
Joined: Wed Jun 11, 2014 6:08 pm

Re: Proxy blocking connection on Windows 8.1

Postby htc2010 » Tue Jan 05, 2016 7:14 am

I have a feeling this is something on a deeper level. I don't use the Synology USB wifi interface so I'm not 100% sure but on a plain wired level, there are some issues with Synology's proxy. If you are trying to run a transparent proxy, which seems like the case of "enforcing via wireless router mode" is not implemented in this package. At least, in a similar setup from DS to router, if you try to filter HTTP traffic at the router level, pointing it directly to the DS (transparent) Squid fails and gives you the error you describe. However, if you set the proxy at the client level, per PC, it should work...

However, you say that your other non Win 8 clients connected to the wifi are working fine, which leads me to suspect that within your DS, the DHCP has the "specify proxy server" check box off, which means that your mobile clients are not receiving a proxy address to use. If you DO have "specify proxy server" checked and your clients DO work still, then I probably can't chime in any further.

Can you re-confirm which device on your network serves as DHCP server and if your DHCP settings are pointing clients to your DS as a proxy? God, I would love to get a fully transparent HTTP Proxy for the DS. It would make things so much more convenient to hit the settings up at the router level and not hope and wonder if individual clients are appropriately detecting and/or using a proxy for HTTP.
SeeGull
I'm New!
I'm New!
Posts: 2
Joined: Sun Dec 27, 2015 4:51 pm

Proxy blocking connection on Windows 8.1 [SOLVED]

Postby SeeGull » Mon Jan 11, 2016 2:33 pm

Router: FritzBox

My DSL Modem is also my primary router. I checked through the settings and realised that I had made a typing error on a single IP Address entry in the many port forwarding rules (*.58 instead of *.57). With this corrected the Proxy Server on the DS suddenly behaved as expected for all clients!

I am at a loss to explain why only the W8.1 machine was tripping up on this but I don't need an autopsy. The perpertrator has allready confessed and been prosecuted for his crime!

Just to confirm:

With the 'force proxy for WiFi' box checked, the NAS is ABSOLUTELY working as a transparent proxy. 100% certain. I have burrowed into the depths of my DS and have set up ACL filters by hand in the 'proxy.conf'. All connected clients are subject to these filters without me having to make any adjustment on individual machines. This causes Me== :D


For completeness:

To answer your question. I haven't explicitly configured any DHCP stuff myself. The "specify proxy server" check box is off.

The router automaticaly assigns IP addresses at its level '192.168.etc.etc' (the DS is assigned an IP by the router) so I suppose it is the DHCP at that level.

The DS is assigning IP addresses to connected wifi clients '10.1.etc.etc' so it is the DHCP at that level.

I have Synology DNS running on the DS. This currently just 'confirms' the domain name forwarded through the Router from my DynDNS account for the purposes of the WEB services I have running.

Return to “Proxy Server”

Who is online

Users browsing this forum: No registered users and 1 guest