Page 1 of 1

Squid pointers not right

Posted: Sat Aug 29, 2015 3:50 am
by maged_mmh
hello,

I just finished setting up proxy/DNS, when I checked cache.log, I found this:

lynx> tail cache.log
2015/08/29 01:40:00 kid1| '/var/packages/ProxyServer/target/squid/share/errors/en-us/ERR_CONNECT_FAIL': (2) No such file or directory
2015/08/29 01:40:00 kid1| WARNING: Error Pages Missing Language: en-us
2015/08/29 01:40:02 kid1| '/var/packages/ProxyServer/target/squid/share/errors/en-us/ERR_CONNECT_FAIL': (2) No such file or directory
2015/08/29 01:40:02 kid1| WARNING: Error Pages Missing Language: en-us
2015/08/29 01:40:06 kid1| '/var/packages/ProxyServer/target/squid/share/errors/en-us/ERR_CONNECT_FAIL': (2) No such file or directory
2015/08/29 01:40:06 kid1| WARNING: Error Pages Missing Language: en-us
2015/08/29 01:40:35 kid1| '/var/packages/ProxyServer/target/squid/share/errors/en-us/ERR_CONNECT_FAIL': (2) No such file or directory
2015/08/29 01:40:35 kid1| WARNING: Error Pages Missing Language: en-us
2015/08/29 01:51:27 kid1| '/var/packages/ProxyServer/target/squid/share/errors/en-us/ERR_READ_ERROR': (2) No such file or directory
2015/08/29 01:51:27 kid1| WARNING: Error Pages Missing Language: en-us


Looking into the path, I found only "en" folder, rather than "en-us":

ls: /var/packages/ProxyServer/target/squid/share/errors/en-us/: No such file or directory
lynx> ls -l /var/packages/ProxyServer/target/squid/share/errors/
drwxr-xr-x 2 root root 4096 Apr 30 08:36 en
drwxr-xr-x 2 root root 4096 Apr 30 08:36 templates


Can we have a patch to solve this?

meanwhile I've been thinking about creating a symlink with the name en-us pointing to en, will this work?

side question: no man pages in that linux version?!