Quickconnect not so quick anymore

Discussion room for the QuickConnect service, which frees you from router setup and port-forwarding, while providing access to all the management and application services on DSM.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
Adrian@EPS
I'm New!
I'm New!
Posts: 3
Joined: Wed Sep 05, 2018 5:36 pm

Quickconnect not so quick anymore

Unread post by Adrian@EPS » Wed Sep 05, 2018 5:48 pm

Hi

My knowledge of IT and software is extremely limited, however despite my lack of IT knowledge I've managed to set up my NAS drive. When I set up the NAZ originally remote access via Quickconnect was very quick, however since I've played around with some settings remote access is painfully slow. I've Googled the problem and its pointing me towards "Relay Service" and "Port Forwarding" (whatever that is??!). The problem is I can't access these settings remotely as "The settings on this page cannot be modified, because you are currently logged into DSM via QuickConnect.".

Is there any way that I can change these settings remotely to see if this will fix the problem?

Any other ideas as to why remote access has slowed down?

Regards
Adrian

User avatar
Shadow771
Enlightened
Enlightened
Posts: 473
Joined: Sun Jan 28, 2018 11:48 pm
Location: the Netherlands

Re: Quickconnect not so quick anymore

Unread post by Shadow771 » Wed Sep 05, 2018 9:30 pm

NAS model?

Do same basic trouble shooting: do you also experience this slowness when connecting to the NAS directly with the internal IP? And what exactly is slow, DSM web interface and/or SMB file share access?
Synology DS216+II <--> Synology RT1900AC <--> <site-to-site VPN tunnel> <--> Synology RT1900AC <--> Synology DS118

Adrian@EPS
I'm New!
I'm New!
Posts: 3
Joined: Wed Sep 05, 2018 5:36 pm

Re: Quickconnect not so quick anymore

Unread post by Adrian@EPS » Thu Sep 06, 2018 1:29 pm

NAS model is a synology ds918+

The NAS is quick and instant when operated directly with the internal IP. Its slow when the NAS is remotely accessed through DSM web interface.

sincarne
Guru
Guru
Posts: 1578
Joined: Wed Feb 15, 2017 9:57 pm

Re: Quickconnect not so quick anymore

Unread post by sincarne » Fri Sep 07, 2018 12:41 am

Adrian@EPS wrote:
Thu Sep 06, 2018 1:29 pm
NAS model is a synology ds918+

The NAS is quick and instant when operated directly with the internal IP. Its slow when the NAS is remotely accessed through DSM web interface.
your local network is fast and internet speed are not fast... this is not issue this normal

tb123
Knowledgeable
Knowledgeable
Posts: 362
Joined: Sun Sep 03, 2017 10:55 am

Re: Quickconnect not so quick anymore

Unread post by tb123 » Fri Sep 07, 2018 3:15 am

The most basic form of QuickConnect in DSM uses the QuickConnect Relay service. Basically it means that all your data must transit the Synology Servers so instead of you accessing a file and it goes A <> B, it must go A <> B <> C via the Synology corporate network for want of a better term. When I first started using QuickConnect I found it to be too slow to stream movies or audio when remote, it caused many dropouts and buffering.

The beauty of QuickConnect is that you don't need to make any changes to the security of your network, just turn it on and it works, however there are some limitations, it is "basic" remote access.

The next step is to turn off the Relay Service part of it, however this means that you need to get a Public IP address on the WAN interface of your router and then port forward your router to the DS918. Some ISP's don't allow you to have a public IP address due to the way their network operates. However if you can achieve this, then your data is now handled in a true point to point Client to NAS, A <> B fashion (after Synology sets up the initial connection.)

The next step to remote access is to set up Dynamic Domain names (DDNS) which allows for greater flexibility in remote access for many more features including VPN's etc.

Obviously this all relies on the speed of your internet connection as well, if your upload is slow, so too will the remote connection and even more so if it transits Synology servers in the middle. Your network at home is likely to be many, many times faster than anything you'll get over the internet, unless of course you are running gigabit internet connection :)

I'm not sure about accessing administrator level access to DSM using QuickConnect, it's been a long time since I've used it, but cannot remember not being able to access it that way, are you signing in with an admin account?
DS916+, 3 x 4TB WD Red, 1 x 4TB WD Purple
UniFi USG, 16 port PoE switch and 4 x AP’s, some Windows, Mac, Android and iDevices

Adrian@EPS
I'm New!
I'm New!
Posts: 3
Joined: Wed Sep 05, 2018 5:36 pm

Re: Quickconnect not so quick anymore

Unread post by Adrian@EPS » Sun Sep 09, 2018 5:33 pm

Many many thanks for your replies tb123, shadow71 and sincarne. My internet speed is 230 Mbs, I suspect that the slow remote speed is due to the A <>B <> C. I'll apply for a Public IP address and try and find a local IT expert to do the rest as this is way beyond my IT capabilities.

Once again many thanks!

sincarne
Guru
Guru
Posts: 1578
Joined: Wed Feb 15, 2017 9:57 pm

Re: Quickconnect not so quick anymore

Unread post by sincarne » Sun Sep 09, 2018 8:42 pm

Adrian@EPS wrote:
Sun Sep 09, 2018 5:33 pm
Many many thanks for your replies tb123, shadow71 and sincarne. My internet speed is 230 Mbs, I suspect that the slow remote speed is due to the A <>B <> C. I'll apply for a Public IP address and try and find a local IT expert to do the rest as this is way beyond my IT capabilities.

Once again many thanks!
is your upload speed same as download speed? many time download 10x faster than upload

shentar
I'm New!
I'm New!
Posts: 6
Joined: Fri Jul 20, 2018 8:15 pm

Re: Quickconnect not so quick anymore

Unread post by shentar » Wed Sep 26, 2018 12:03 am

Just in case this helps anyone else.

I was trying to use DS Audio to access media files on my NAS. It worked fine from within my home network using WiFi but would not connect using Quickconnect and mobile data from my phone. Nothing seemed to help until in desperation I looked at the application permissions of the UserID I was accessing my media with. Because I might want to share this with friends I had set it up with read-only access to the media files and no access to DSM. Allowing DSM access immediately allowed access to the music.

I have no idea why disallowing DSM access prevents DS Audio via mobile but not via local WiFi

<EDIT> OK, it has stopped working again. This is getting ridiculous.

Locked

Return to “QuickConnect”