Playlist/Album only plays one song then stops

Forum rules
This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
timfy
Experienced
Experienced
Posts: 103
Joined: Thu Nov 24, 2011 11:36 pm

Re: Playlist/Album only plays one song then stops

Postby timfy » Fri Jan 25, 2013 11:32 am

Also I have an off topic question, if I may...

The Cambridge Audio Stream Magic, how are you finding it generally? Are you happy with it? And can it stream multichannel audio in via the network and out via its digital outputs?

thanks, and sorry for the threadjack!
moonwalker0921
Novice
Novice
Posts: 59
Joined: Sun Sep 23, 2012 11:34 am

Re: Playlist/Album only plays one song then stops

Postby moonwalker0921 » Sun Jan 27, 2013 10:05 am

i also like to know anyone able to connect synology nas to "stream magic 6" via usb and play songs successfully using IOS ds audio app ?
tomal
I'm New!
I'm New!
Posts: 9
Joined: Sat Dec 08, 2012 8:36 pm

Re: Playlist/Album only plays one song then stops

Postby tomal » Mon Jan 28, 2013 8:36 pm

For all those with the "one song only" problem here is an update.
Synology support asked me to install Twonky Beam app on my iPad and also try the Windows Media Player "Play To" function and here is my result. Twonky Beam can see the SM6 but has the same issue as the DS Audio app in that one song from the playlist is played and then I get the "End of Queue" on the SM6. WMP12 "Play To" can "see" the SM6 but when I actually try to use "Play To" I get the error the the "Device is not responding". According to Synology support this is due to the fact that UPnP/DLNA rendering is "differently implemented" on the SM6 than what is generally used.
Cambridge Audio support told me that the SM6 currently does not support songs being "pushed" to the SM6 but that they are working on it. I'm waiting on an answer from them to elaborate on this issue and give me more precise information. For SM6 users there seem to be only two options to use playlists right now: 1) use the playlist function directly at the player, or 2) use Cambridge Audio Stream Magic app on your iPad.
For all of you who don't have an SM6 but other devices with the same problem I would suggest to try Twonky and WMP with your devices to see if the problem persists.

I just hope Cambridge can sort this out soon, because the player itself is very good. The sound form the DAC is great.
timfy
Experienced
Experienced
Posts: 103
Joined: Thu Nov 24, 2011 11:36 pm

Re: Playlist/Album only plays one song then stops

Postby timfy » Tue Jan 29, 2013 11:12 am

It is a shame that the SM6 is not a proper DLNA renderer yet, I was seriously thinking of getting one.. I hope CA can sort it out because just using the remote with the small screen on the device is not very satisfactory. It should not be too hard for CA to update the firmware to allow it to be controlled via DLNA properly.

Meanwhile on the issue with DS Audio/Audio Station; I still believe there is a problem with the Synology DLNA control code. I can play multiple tracks happily to my amp via AirPlay from the NAS, I can play multiple tracks to my amp via DLNA using BubbleUPnP app on my phone/tablet, but not with DS Audio/Audio Station and DLNA. My support case is still under investigation...
ericveracx
Beginner
Beginner
Posts: 20
Joined: Sat Jan 19, 2013 4:46 pm

Re: Playlist/Album only plays one song then stops

Postby ericveracx » Thu Jan 31, 2013 11:05 am

tomal wrote:@ericveracx
Did you ever try to install a different UPnP server on your Diskstation, such as PLEX to see if the problem is solved just to make sure it is not your Philips player?


hi,
I found out that the Philips BDP7600 blu-ray does not realy support DMrenderer. All works fine when pushing to my TV, which has full DM renderer functionality.

So my next question :

Does somebody knows a device that supports digital media renderer (audio only is fine)
Should connect to my wireless (no cables), support dmr (audio) and have an analog audio output to connect to my 'old' music installation. (I'm thinking of something in the style of the Logitech Wireless Speaker adapter for Bluetooth audio devices.)
Georges1954
I'm New!
I'm New!
Posts: 1
Joined: Sat Feb 16, 2013 3:07 pm

Re: Playlist/Album only plays one song then stops

Postby Georges1954 » Sat Feb 16, 2013 3:35 pm

Same problem with AudioStation "sending" music to a Rotel RT12 :it works for one track, then it stops,the RT12 displays "loading" forever, and needs to be restarted.( whereas it works fine "pulling" music from the RT12).
I have also tried using DS Audio on an Ipad, and I get the same stop after one track.
If someone has any idea ...
novaphile
I'm New!
I'm New!
Posts: 1
Joined: Mon Feb 18, 2013 10:39 pm

Re: Playlist/Album only plays one song then stops

Postby novaphile » Mon Feb 18, 2013 10:43 pm

I have a Rotel RT-12 with exactly the same problem using a Qnap NAS...

So far I have found no way around it.

Please report the problem to Rotel.
ericveracx
Beginner
Beginner
Posts: 20
Joined: Sat Jan 19, 2013 4:46 pm

Re: Playlist/Album only plays one song then stops

Postby ericveracx » Sat Feb 23, 2013 1:42 pm

the "only one song played" in streaming mode UPnp/DLNA seems to be caused by the DMR device that is not really a properly Renderer.
I played around with android devices , using the app AIRPin of Waxrain, turning your device in a DMR. Audio-station behaves as expected, streaming music in the waitinglist quite beautifull.
There are a lot of android mini pc (tv-boxes) in the market (mostly chinese), with an analog audio (AV) connection that I could connect to my AMP to stream music from Synology to my speakers.
However the different forums of those devices are not all optimistic (especially when it comes to streaming video, frimware problems, hardware issues which I don't need)
So the question is which one is ok and delivers as expected.
Anybody experience with some of those devices, that work?
timfy
Experienced
Experienced
Posts: 103
Joined: Thu Nov 24, 2011 11:36 pm

Re: Playlist/Album only plays one song then stops

Postby timfy » Tue Feb 26, 2013 6:59 pm

Well Synology support made a remote connection to my NAS and reproduced the issue with DLNA only playing one track.. they have said they will address it future updates... so I guess we wait and see...
ornette
Trainee
Trainee
Posts: 10
Joined: Tue Jul 26, 2011 6:46 pm

Re: Playlist/Album only plays one song then stops

Postby ornette » Tue Mar 05, 2013 12:11 pm

Not fixed in the latest upgrade (4.4 iPhone).
timfy
Experienced
Experienced
Posts: 103
Joined: Thu Nov 24, 2011 11:36 pm

Re: Playlist/Album only plays one song then stops

Postby timfy » Wed Mar 06, 2013 1:10 pm

Not fixed on Android either, or on Audio Station in the latest releases :-(
clarkes71
Rookie
Rookie
Posts: 32
Joined: Mon Mar 14, 2011 8:43 pm

Re: Playlist/Album only plays one song then stops

Postby clarkes71 » Mon Mar 25, 2013 3:26 pm

Any news on this issue? Seems to be an issue on my Android and iPhone devices still. Very annoying and almost don't even want to use DS Audio if I have to click 'next' after every song?
timfy
Experienced
Experienced
Posts: 103
Joined: Thu Nov 24, 2011 11:36 pm

Re: Playlist/Album only plays one song then stops

Postby timfy » Mon Mar 25, 2013 3:41 pm

clarkes71 wrote:Any news on this issue? Seems to be an issue on my Android and iPhone devices still. Very annoying and almost don't even want to use DS Audio if I have to click 'next' after every song?


If you are using Android and DLNA then download BubbleUPnP.. it works perfectly.
oluv
Beginner
Beginner
Posts: 21
Joined: Wed Jan 09, 2013 12:01 am

Re: DS Audio plays, then hangs until manual advance to next

Postby oluv » Mon Apr 15, 2013 8:03 pm

i have the same problem with streaming to an iphone.
it seems as if DSAudio app wouldn't hold the Wifi-connection active. So after DSAduio having cached 2-3 songs, the Iphone will drop Wifi connection as there is no need to keep it active, but before playing the next song which is not cached, DSAudio doesn't request a new Wifi-connection and just hangs without playing anything. Really annoying. Even if i reactivate the connection manually DSAudio won't start playing, but i rather have to restart the same track or skip to the next one in order to make it play again.

This is a serious limitation and i wonder why this hasn't been sorted out yet.
PlugPlayer for example has an option to keep Wifi active regardless of screenlock or no. There should be such an option for DSAudio too.
clarkes71
Rookie
Rookie
Posts: 32
Joined: Mon Mar 14, 2011 8:43 pm

Re: DS Audio plays, then hangs until manual advance to next

Postby clarkes71 » Wed Apr 17, 2013 2:58 pm

Here is another thread of the same issue...

viewtopic.php?f=216&t=62304

No real solutions that I heard of yet. I put a support ticket in over a week ago and got a big...
NOTHING !! from Synology support :evil:

If I do hear something, I will post back.

Return to “DS audio”

Who is online

Users browsing this forum: No registered users and 1 guest