Php + MariaDB (10) issue

Questions about hosting a Website, using MySQL, PhP or MariaDB may be posted here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
DuMees
I'm New!
I'm New!
Posts: 9
Joined: Thu Apr 12, 2012 11:22 am

Php + MariaDB (10) issue

Unread post by DuMees » Thu Apr 19, 2018 10:03 am

Hi All,

Since 3 days I'm having a problem with my Php application that I created. The issues started after my Synology gave messages about error in filesystem (did run the checkdisk tool).

First the issue had to do with session_start (received vague error message that either the file or permission was not set correctly). When I commented the session_start pages did load, only to find out that page with DB connection also got stuck (times out with 504).

I decided to uninstall and reinstall everything (yes I know, a pain). I reinstalled: Webstation, php 5.6, Php7, PhpMyadmin, Apache 2.2, Apache 2.4, MariaDB5, MariaDB10 (and Photostation due to dependancy).

I've managed to get everything up and running again, session_start issue is gone, but once DB connection is created (MariaDB10), it never returns result (even when querying a 1 record DB) and the Php times out resulting in a 504.

Anyone some idea's where I need to start looking?

Regards,

DuMees

Post Reply

Return to “Web Server + PHP / MySQL + MariaDB”