Joomla going from PHP5.6 to PHP7.0

Questions about hosting a Website, using MySQL, PhP or MariaDB may be posted here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
mkparis
I'm New!
I'm New!
Posts: 3
Joined: Sat May 19, 2012 8:12 am

Joomla going from PHP5.6 to PHP7.0

Postby mkparis » Wed May 24, 2017 8:15 am

I have two Joomla sites installed in the Web folder and accessed through WebStation
These old sites are regularly updated and just moved to Joomla 3.7.2.
Since this update, an alert message appears

Your version of PHP, 5.6.30, currently only receives security patches from the PHP project. This means that your version of PHP will soon no longer be supported. We recommend that you plan to upgrade to a new version of PHP before reaching the end of support on 31/12/18. Joomla will be faster and safer if you upgrade to a newer version of PHP (PHP 7.x is recommended). Please contact your host for upgrade instructions.

PHP7.0 is also installed on WebStation - there are two packages installed and running togerther - but if I switch in Webstation from PHP5.6 to PHP7.0 my sites are no longer accessible and everything comes back in order when I go back in PHP5.6

What changes to make in my Joomla sites to make them go from using PHP5.6 current version to PHP7.0?
I read in some places that it is enough to modify a file .htaccess but I do not have such a file in the root of my Joomla sites?
Or is it a .htaccess elsewhere on Synology and if so where is and how to change it?
Are there other steps?

Thank you for your help
User avatar
eagleman
I'm New!
I'm New!
Posts: 9
Joined: Sat Sep 06, 2008 8:04 pm

Re: Joomla going from PHP5.6 to PHP7.0

Postby eagleman » Sun Jun 18, 2017 7:32 pm

I also have the same problem. How do i go from PHP 5.6 to 7. My Joomla-site stops working when i switch t PHP 7
smedest
I'm New!
I'm New!
Posts: 3
Joined: Thu Mar 31, 2016 9:17 am

Re: Joomla going from PHP5.6 to PHP7.0

Postby smedest » Tue Jun 27, 2017 11:29 am

When I uninstall php 5.6 and apache 2.2 I have to stop Joomla and phpmyadmin.
If I then want to start up joomla again, it says I have to install php 5.6 and apache 2.2 Even for personal website you need those as well

Weird, looks like Joomla / phpmyadmin only runs on php 5.6 while it's getting out of support soon.

Return to “Web Server + PHP / MySQL + MariaDB”

Who is online

Users browsing this forum: No registered users and 2 guests