Discourse Unable to Send Mail

The discussion lounge for third-party packages.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
tscott
I'm New!
I'm New!
Posts: 9
Joined: Tue Aug 04, 2015 7:28 pm

Discourse Unable to Send Mail

Unread post by tscott » Tue Dec 05, 2017 4:03 pm

I installed the Discourse package and it is successfully running in a Docker container but it is unable to send account activation emails so I can't get registered to complete the setup. Any idea what I should check?

mvern
Beginner
Beginner
Posts: 20
Joined: Sun Aug 04, 2013 4:38 am

Re: Discourse Unable to Send Mail

Unread post by mvern » Thu Feb 22, 2018 3:05 am

I've got the same problem.
Not a lot of information on the web about how to address.
I tried to follow the same e-mail setup I used for phpBB but no dice.
Not sure how much longer I'll fiddle with it.
--------------------
DS212j, DS716+II

sinamics
Trainee
Trainee
Posts: 14
Joined: Wed May 07, 2014 1:03 pm

Re: Discourse Unable to Send Mail

Unread post by sinamics » Mon May 14, 2018 7:06 pm

I got the same issue. I also run DSM mail server and i have tried various SMTP settings. localhost, 127.0.0.1, nas_ip, and my mail dns mail_xxxxx@domain.com. But nothing get registered in the mail server log. Strange.

The documentation is terrible.
If anyone find a solution then please share it with us..

Best Regards
Sinamics

sinamics
Trainee
Trainee
Posts: 14
Joined: Wed May 07, 2014 1:03 pm

Re: Discourse Unable to Send Mail

Unread post by sinamics » Mon May 14, 2018 8:38 pm

[SOLVED]
Finally.... The problem was that Discourse uses SSL verify TRUE as default..
I dont have any SSL certs for my site yet.
I simply had to uncheck the SSL check box in the installation window. (where you type the SMTP, mail, ect).

the Discourse logfile pointed me in the right direction..

Code: Select all

cat /volume1/docker/discourse/log/rails/production.log 
I had certificate verify failed

Cheers

Post Reply

Return to “Third-party Packages”