Dokuwiki installation issues

The discussion lounge for third-party packages.
Forum rules
Please note the Disclaimer before modifying your Synology Product.
awayand
I'm New!
I'm New!
Posts: 9
Joined: Mon Feb 17, 2014 12:22 am

Dokuwiki installation issues

Postby awayand » Sun Aug 06, 2017 8:59 am

I have just wasted my entire Sunday to get dokuwiki to work on my latest DSM6 synology.
I have uninstalled the entire package, including the data, reinstalled completely clean, and still keep getting this error:

/volume1/web/dokuwiki/conf/local.php already exists

Why the hell can't Synology do a simple quality test before publishing this crap??????? Why do I have to be a rocket scientist to do a simple installation?????? What the hell
mkha98
I'm New!
I'm New!
Posts: 3
Joined: Sat May 17, 2014 3:02 am

Re: Dokuwiki installation issues

Postby mkha98 » Tue Aug 22, 2017 2:45 am

I'm having a similar issue, but I think I have a better understanding of the symptoms.

I've uninstalled and reinstalled DokuWiki on the server several times. I've even unpackaged an instance of DokuWiki (using Unix, not the Synology interface) which works ..except for permissions (an error on the ACL page). Installing via the Synology DSM interface gives troubles and I'll try to explain here.

When I did the install via Synology,
Step 1 - looks ok


Image
https://ibb.co/hYm5CQ

Step 2 - looks bad
Image
https://ibb.co/iZ82sQ

I think that the issue is permissions but I cannot put my finger on it. I've been fighting this for a couple of days now.
Last edited by mkha98 on Tue Aug 22, 2017 12:09 pm, edited 1 time in total.
mkha98
I'm New!
I'm New!
Posts: 3
Joined: Sat May 17, 2014 3:02 am

Re: Dokuwiki installation issues

Postby mkha98 » Tue Aug 22, 2017 3:02 am

I should have included this in my post earlier...

The reason that /volume1/web/dokuwiki/conf/local.php already exist error comes up (for me) is because
a.) The middle area is blank
b.) The only links are on the right
c.) This restarts the incomplete install process which is a consequence of a.)

Many thanks to anybody who is able to solve this. It has been a time sink for me. And anybody who looks at this will be spending time as this is a non-trivial issue.
JDS
I'm New!
I'm New!
Posts: 1
Joined: Tue Sep 05, 2017 10:25 pm

Re: Dokuwiki installation issues

Postby JDS » Tue Sep 05, 2017 10:26 pm

This is post from the DokuWiki website that fixed my issues. Maybe it will help here. I only have to enable "mcrypt".
"openssl" was already enabled for me.


[quote=schnaba:1497536445]
Hi berend!

Came here via google because I had the very same problem with DokuWiki on Synoloy DSM 6.1. Solved it:

In the Synology admin website go to WebStation --> PHP settings, select your php version (5.6 on my Synology) and activate the extensions "mcrypt" and "openssl". Before the DSM upgrade, mcrypt was not necessary. Now it is, apparently. Everything works as expected again.

The "golden link" for me was this one: https://github.com/kanboard/kanboard/issues/2060

Good luck!
[/quote]
mkha98
I'm New!
I'm New!
Posts: 3
Joined: Sat May 17, 2014 3:02 am

Re: Dokuwiki installation issues

Postby mkha98 » Tue Sep 12, 2017 8:45 pm

JDS,
Thank you for your advice. I did the following things:

a.) Activated the extensions as you recommended.
b.) Uninstalled Dokuwiki
c.) Restatarted Synology
d.) Installed Dokuwiki
e.) Success.

I'm not sure if this would have worked without a restart in the middle, but I suspect that it may have.

JDS - you have been incredibly helpful and have justified the many hours I spent fighting the system. Thank you.

Return to “Third-party Packages”

Who is online

Users browsing this forum: No registered users and 3 guests