Sonarr on DSM 6.1 Mono version etc

The discussion lounge for third-party packages.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
stuart0001
Beginner
Beginner
Posts: 29
Joined: Mon Jun 08, 2015 10:16 am

Sonarr on DSM 6.1 Mono version etc

Unread post by stuart0001 » Thu Feb 23, 2017 11:29 pm

After having Sonarr running fine for a week, I've updated to DSM 6.1 & now it won't start.

I see various fixes for 6.0 but just wondered what the recommended set-up is now eg which Mono, SYnology or community, beta or not?

Also I hadn't performed a Sonarr backup so would refer not to have to uninstall if possible but if I do, so be it & a lesson learnt.

Many thanks for any assistance

User avatar
Rusty1281
Sagacious
Sagacious
Posts: 3043
Joined: Fri Jun 03, 2011 10:51 pm

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by Rusty1281 » Fri Feb 24, 2017 10:37 am

I'm running 6.1 with Sonarr 2.0.0.4613 and Mono 4.6.2.7-8 (beta).

0 problems
Synology DS918+ (4x4TB WD RED - RAID 5 with 2x250GB 960EVO NVMe) | Synology DS412+ (4x3TB WD RED - RAID 5) | RT1900AC

TheRealTomTom
Novice
Novice
Posts: 41
Joined: Sun Jul 22, 2012 8:49 am

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by TheRealTomTom » Fri Feb 24, 2017 1:34 pm

I too can't get it to start!

No idea what to try. Don't really want to reinstall as had to do that again recently but will be the next thing to try!

From a Reddit User:

I can help! I had this issue yesterday after updating. The fix is essentially the same as its always been on DSM6+ where you need to change the monopath location. What seems to have happened recently is that the official synology package binary has moved.
The fix that has worked for me is to uninstall / reinstall the official synology Mono (this may not be necessary, but I did it anyway whilst trying to fix it).
Then the standard fix of changing the mono path in
/var/packages/nzbdrone/scripts/start-stop-status
Then change
MONO_PATH="/usr/local/mono/bin"
to
MONO_PATH="/var/packages/Mono/target/usr/local/bin"
Note This is different from the similar previous fixes as the path now seems to have changed from "/var/packages/Mono/target/usr/bin", essentially adding the local folder.
Hope this helps.
edit This also works on Radarr by doing the exact same but editing the '/var/packages/radarr/scripts/start-stop-status' file.
Last edited by TheRealTomTom on Fri Feb 24, 2017 1:50 pm, edited 1 time in total.

User avatar
Rusty1281
Sagacious
Sagacious
Posts: 3043
Joined: Fri Jun 03, 2011 10:51 pm

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by Rusty1281 » Fri Feb 24, 2017 1:43 pm

before you reinstall it and go down that route, try and log in via ssh into your nas. If you have installed Sonarr via Package center then try and locate this path:

Code: Select all

/usr/local/nzbdrone/var/.config/NzbDrone/logs
There should be all sonarr logs (TXT files). The ones called sonarr#.txt are the actual ones and most current. See what your can pick up from those logs and maybe your can narrow down and error.
Synology DS918+ (4x4TB WD RED - RAID 5 with 2x250GB 960EVO NVMe) | Synology DS412+ (4x3TB WD RED - RAID 5) | RT1900AC

stuart0001
Beginner
Beginner
Posts: 29
Joined: Mon Jun 08, 2015 10:16 am

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by stuart0001 » Wed Mar 01, 2017 3:49 pm

Thanks for the advice all. I've only just seen them as wasn't getting notifications from here.

I got it working simply by adding a NZbdrone user & giving access to associated folders & apps

Flo1H
I'm New!
I'm New!
Posts: 2
Joined: Sun Mar 05, 2017 8:52 pm

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by Flo1H » Sun Mar 05, 2017 9:01 pm

I have the same issue...

Since I have updated to DSM 6.1 Sonar won't start via the "DSM paket manager" :cry:

@stuart0001: can you please describe exactly what you did? Have you simply add a new user via the DSM system control? And what rights and password did this new user have?

Would be great I you have any support on this for me!

Cheers,
Florian

User avatar
Rusty1281
Sagacious
Sagacious
Posts: 3043
Joined: Fri Jun 03, 2011 10:51 pm

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by Rusty1281 » Mon Mar 06, 2017 12:03 pm

Flo1H wrote:I have the same issue...

Since I have updated to DSM 6.1 Sonar won't start via the "DSM paket manager" :cry:

@stuart0001: can you please describe exactly what you did? Have you simply add a new user via the DSM system control? And what rights and password did this new user have?

Would be great I you have any support on this for me!

Cheers,
Florian
have you updated Mono?
Synology DS918+ (4x4TB WD RED - RAID 5 with 2x250GB 960EVO NVMe) | Synology DS412+ (4x3TB WD RED - RAID 5) | RT1900AC

Flo1H
I'm New!
I'm New!
Posts: 2
Joined: Sun Mar 05, 2017 8:52 pm

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by Flo1H » Mon Mar 06, 2017 11:18 pm

Rusty1281 wrote:
Flo1H wrote:I have the same issue...

Since I have updated to DSM 6.1 Sonar won't start via the "DSM paket manager" :cry:

@stuart0001: can you please describe exactly what you did? Have you simply add a new user via the DSM system control? And what rights and password did this new user have?

Would be great I you have any support on this for me!

Cheers,
Florian
have you updated Mono?
Thanks for your update hint for Mono! I haven't activated the option to show beta versions. After I activated the option I was able to upgrade Mono to the latest beta version (4.6.2.7-8) and after reinstalling Sonarr now everything works :D

Thanks for your support!

medric
I'm New!
I'm New!
Posts: 4
Joined: Thu Mar 09, 2017 7:58 pm

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by medric » Sun Sep 03, 2017 11:06 pm

I don't see the option to download sonarr and i have the beta option checked and community packaged setup but no sonarr

sincarne
Guru
Guru
Posts: 1411
Joined: Wed Feb 15, 2017 9:57 pm

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by sincarne » Mon Sep 04, 2017 2:17 am

medric wrote:I don't see the option to download sonarr and i have the beta option checked and community packaged setup but no sonarr
use docker

User avatar
Rusty1281
Sagacious
Sagacious
Posts: 3043
Joined: Fri Jun 03, 2011 10:51 pm

Re: Sonarr on DSM 6.1 Mono version etc

Unread post by Rusty1281 » Mon Sep 04, 2017 12:44 pm

medric wrote:I don't see the option to download sonarr and i have the beta option checked and community packaged setup but no sonarr
What repository did you add to your package center? SynoCommunity is the one that hosts Sonarr (I'm running it just fine) but yes Docker would be also a great solution if your NAS model support it.
Synology DS918+ (4x4TB WD RED - RAID 5 with 2x250GB 960EVO NVMe) | Synology DS412+ (4x3TB WD RED - RAID 5) | RT1900AC

Post Reply

Return to “Third-party Packages”