Subsonic

The discussion lounge for third-party packages.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
Ellul
I'm New!
I'm New!
Posts: 9
Joined: Mon Apr 11, 2016 10:14 pm

Re: Subsonic

Unread post by Ellul » Sun Nov 12, 2017 7:57 pm

psyfer9983 wrote:
sincarne wrote: that not how docker work. you think i tbetter when you give root access instead through package?
Most docker apps for subsonic that I've used\tried launch with the user "no one" which caused me permission problems due to that user not existing in a way so I could assigning permissions to shares. The subsonic package in this thread uses a user "subsonic" which makes it possible for me to assign permissions to shares. I've even looked through the docker startup scripts on every one of them I've tried and couldn't get them to work with another user. It was only this package that worked for me.
Same here. PS thanks psyfer9983 for the SSL tutorial you posted previously, very useful :)

I came on here really to answer my own earlier question: The packaged version does not allow for disk hibernation on my 716+

sincarne
Guru
Guru
Posts: 1578
Joined: Wed Feb 15, 2017 9:57 pm

Re: Subsonic

Unread post by sincarne » Tue Nov 14, 2017 1:29 am

psyfer9983 wrote:
sincarne wrote: that not how docker work. you think i tbetter when you give root access instead through package?
Most docker apps for subsonic that I've used\tried launch with the user "no one" which caused me permission problems due to that user not existing in a way so I could assigning permissions to shares. The subsonic package in this thread uses a user "subsonic" which makes it possible for me to assign permissions to shares. I've even looked through the docker startup scripts on every one of them I've tried and couldn't get them to work with another user. It was only this package that worked for me.
you have to assign user and storage to all docker app. that not unique to subsonic

psyfer9983
Sharp
Sharp
Posts: 180
Joined: Wed Jan 23, 2013 7:16 am

Re: Subsonic

Unread post by psyfer9983 » Tue Nov 14, 2017 8:52 am

sincarne wrote:
psyfer9983 wrote:
sincarne wrote: that not how docker work. you think i tbetter when you give root access instead through package?
Most docker apps for subsonic that I've used\tried launch with the user "no one" which caused me permission problems due to that user not existing in a way so I could assigning permissions to shares. The subsonic package in this thread uses a user "subsonic" which makes it possible for me to assign permissions to shares. I've even looked through the docker startup scripts on every one of them I've tried and couldn't get them to work with another user. It was only this package that worked for me.
you have to assign user and storage to all docker app. that not unique to subsonic
Did. I tried every option for shares and it just wouldn't work until I gave the user "Everyone" full access to my music. I didn't want everyone on my NAS having full access to my music share let along Subsonic. Didn't want it changing track tags and such by accident. Anyway, I have the package working and thats all that matters. Thanks.
Please correct me if I'm wrong, I don't like giving out inaccurate information.

Synology DS1813+ with 8 x 5TB HDDs Hybird RAID SHR2
Synology DS1813+ with 8 x 3TB HDDs Hybird RAID SHR2
Synology DS212j with 2 x 2TB HHDs RAID 1
Synology RT1900ac - Great router, love the free content filtering supplied by Synology.

sincarne
Guru
Guru
Posts: 1578
Joined: Wed Feb 15, 2017 9:57 pm

Re: Subsonic

Unread post by sincarne » Tue Nov 14, 2017 11:16 pm

psyfer9983 wrote:
sincarne wrote:
psyfer9983 wrote: Most docker apps for subsonic that I've used\tried launch with the user "no one" which caused me permission problems due to that user not existing in a way so I could assigning permissions to shares. The subsonic package in this thread uses a user "subsonic" which makes it possible for me to assign permissions to shares. I've even looked through the docker startup scripts on every one of them I've tried and couldn't get them to work with another user. It was only this package that worked for me.
you have to assign user and storage to all docker app. that not unique to subsonic
Did. I tried every option for shares and it just wouldn't work until I gave the user "Everyone" full access to my music. I didn't want everyone on my NAS having full access to my music share let along Subsonic. Didn't want it changing track tags and such by accident. Anyway, I have the package working and thats all that matters. Thanks.
what container you use? https://hub.docker.com/r/linuxserver/libresonic/
that say how to set user. you clearly not try every option or use docker before so you make statement about how it work when you not know how it work. your package will fail again when DSM update or when java package have issue.

Thesalan
I'm New!
I'm New!
Posts: 6
Joined: Fri Nov 03, 2017 8:52 am

Re: Subsonic

Unread post by Thesalan » Wed Nov 15, 2017 8:56 am

psyfer9983 wrote:
Thesalan wrote:Same here...

I try on port 4040 and 4041, and including in http groups, but it doesn't work
Strange. Wondering if you have a bad install. Try uninstalling the package, reboot the nas, go to control panel and delete the subsonic user, reboot yet again, then reinstall making sure to check run during the installation. When it's finished installing see if you can actually see the server before modifying any of the settings. If you can't then there is something not installing correctly. See if you can get your log files. It'll be nice to see the config files for your subsonic install as it may be an easy fix.
Finally, truth is out there...

Subsonic worked fine, it's just I can't access it using the address xxx.synology.me, I must use ip address!
I'm on local network, I don't have to configure the router... So, it's stange!

Other problem: Subsonic can't access my music folder! In control panel, I add read/write permissions on music shared folder for subsonic user, but no changes...

Thesalan
I'm New!
I'm New!
Posts: 6
Joined: Fri Nov 03, 2017 8:52 am

Re: Subsonic

Unread post by Thesalan » Tue Nov 28, 2017 10:29 am

Thesalan wrote:Other problem: Subsonic can't access my music folder! In control panel, I add read/write permissions on music shared folder for subsonic user, but no changes...
Nobody? :(

dogJW
I'm New!
I'm New!
Posts: 6
Joined: Thu May 18, 2017 2:34 am

Re: Subsonic

Unread post by dogJW » Wed Dec 20, 2017 3:10 pm

Thank you ghenry22 for creating and maintaining this package!

I just installed Subsonic on a DS214play and it reads and displays the full catalog and all tracks just fine. However when I select a track to play through a remote web browser, it shows the selected track but then just buffers endlessly with no progress or sound. (trying through a web browser - haven't tried other options)

I have given the subsonic user full read permission to the shared folder, and port 4040 is open on the router. What am I missing? My subsonic settings on the NAS are identical to the subsonic settings on my Mac, which works perfectly.

Thank all for any help!

dogJW
I'm New!
I'm New!
Posts: 6
Joined: Thu May 18, 2017 2:34 am

Re: Subsonic

Unread post by dogJW » Wed Dec 20, 2017 6:28 pm

I just installed Subsonic on a DS214play and it reads and displays the full catalog and all tracks just fine. However when I select a track to play through a remote web browser, it shows the selected track but then just buffers endlessly with no progress or sound. (trying through a web browser - haven't tried other options)
UPDATE... actually the problem seems to be limited to transcoding (with the default setting) only AAC .m4a files (both self-created and purchased from itunes), which buffer endlessly but don't play.
Transcoding of apple lossless (.m4a) and all other formats (.aif, flac, mp3) works perfectly, as does playing files without transcoding (de-selecting the 'active transcoding' in the player.

Is a transcoder package missing? If yes, how would I install?

many thanks all!

sincarne
Guru
Guru
Posts: 1578
Joined: Wed Feb 15, 2017 9:57 pm

Re: Subsonic

Unread post by sincarne » Wed Dec 20, 2017 10:44 pm

dogJW wrote:
I just installed Subsonic on a DS214play and it reads and displays the full catalog and all tracks just fine. However when I select a track to play through a remote web browser, it shows the selected track but then just buffers endlessly with no progress or sound. (trying through a web browser - haven't tried other options)
UPDATE... actually the problem seems to be limited to transcoding (with the default setting) only AAC .m4a files (both self-created and purchased from itunes), which buffer endlessly but don't play.
Transcoding of apple lossless (.m4a) and all other formats (.aif, flac, mp3) works perfectly, as does playing files without transcoding (de-selecting the 'active transcoding' in the player.

Is a transcoder package missing? If yes, how would I install?

many thanks all!
why you want transcode lossy file? everything play AAC these day

dogJW
I'm New!
I'm New!
Posts: 6
Joined: Thu May 18, 2017 2:34 am

Re: Subsonic

Unread post by dogJW » Thu Dec 21, 2017 12:19 am

why you want transcode lossy file? everything play AAC these day
Good question - most of my music is lossless (ALAC) m4a but there are a few lossy (AAC and other) files. I prefer to keep the 'active transcoding' setting on -- in order to conserve data usage when streaming to mobile devices, phones, etc. where lossless fidelity isn't needed.

The real question here is how to get subsonic on the DS214play to transcode AAC files. Transcoding of everything else (including lossless, mp3, etc.) seems to work fine.

phid4141
I'm New!
I'm New!
Posts: 1
Joined: Sun Dec 24, 2017 6:59 pm

Re: Subsonic

Unread post by phid4141 » Sun Dec 24, 2017 7:07 pm

Sorry if this is a dumb question.

I've installed this and it seems to run fine on port 4040. Set up a user, pointed at volume1/music (which it likes OK. Music is organised by folder.)

But it does not see any music - an I missing something obvious. Had Subsonic running on this file structure on windows, but never tried it on my synology nas before.

Any suggestions appreciated

psyfer9983
Sharp
Sharp
Posts: 180
Joined: Wed Jan 23, 2013 7:16 am

Re: Subsonic

Unread post by psyfer9983 » Sat Jan 06, 2018 9:52 pm

For Subsonic not finding music, I'm sure it's a permission error. If you have the subsonic user in the use panel, then you should be able to assign permissions to your music share for subsonic. You may need to reboot the nas afterwards. You only really need read access for the share for subsonic for it to find music, and I mean full read access. You may also what to check the path in the subsonic settings for the music share. Double check the case as it is case sensitive.

If I'm not mistaken, my path looks like this:

/volume1/music/
Please correct me if I'm wrong, I don't like giving out inaccurate information.

Synology DS1813+ with 8 x 5TB HDDs Hybird RAID SHR2
Synology DS1813+ with 8 x 3TB HDDs Hybird RAID SHR2
Synology DS212j with 2 x 2TB HHDs RAID 1
Synology RT1900ac - Great router, love the free content filtering supplied by Synology.

SeaFox
I'm New!
I'm New!
Posts: 1
Joined: Sat Feb 10, 2018 5:08 am

Re: Subsonic

Unread post by SeaFox » Sat Feb 10, 2018 5:12 am

phid4141 wrote:Sorry if this is a dumb question.

I've installed this and it seems to run fine on port 4040. Set up a user, pointed at volume1/music (which it likes OK. Music is organised by folder.)

But it does not see any music - an I missing something obvious. Had Subsonic running on this file structure on windows, but never tried it on my synology nas before.

Any suggestions appreciated
Go into your settings on Subsonic and double-check your username's permissions.
Even though you may be logged in as admin, I found I did not have me checked to have access to the Music folder already. After checking that and saving the settings, the music files I knew had been scanned suddenly were visible for me.

psyfer9983
Sharp
Sharp
Posts: 180
Joined: Wed Jan 23, 2013 7:16 am

Re: Subsonic

Unread post by psyfer9983 » Sat Feb 10, 2018 11:42 am

SeaFox wrote:
phid4141 wrote:Sorry if this is a dumb question.

I've installed this and it seems to run fine on port 4040. Set up a user, pointed at volume1/music (which it likes OK. Music is organised by folder.)

But it does not see any music - an I missing something obvious. Had Subsonic running on this file structure on windows, but never tried it on my synology nas before.

Any suggestions appreciated
Go into your settings on Subsonic and double-check your username's permissions.
Even though you may be logged in as admin, I found I did not have me checked to have access to the Music folder already. After checking that and saving the settings, the music files I knew had been scanned suddenly were visible for me.
Very true! I totally forgot about that in the settings. I think by default, Subsonic has that option unchecked (disabled) which means you need to give every user (Subsonic users, not DSM users) access. Its a separate permission from the DSM. As long as the DSM permissions are set correctly and the users in Subsonic are set to have access to the music share(s), it should work.
Please correct me if I'm wrong, I don't like giving out inaccurate information.

Synology DS1813+ with 8 x 5TB HDDs Hybird RAID SHR2
Synology DS1813+ with 8 x 3TB HDDs Hybird RAID SHR2
Synology DS212j with 2 x 2TB HHDs RAID 1
Synology RT1900ac - Great router, love the free content filtering supplied by Synology.

Locked

Return to “Third-party Packages”